Jump to content

Erreur 500 à répétition sur 1.6


Recommended Posts

Bonjour à tous,

 

Un de mes sites sous Prestashop 1.6.1.9 se met régulièrement (une fois toutes les 8-10 jours) en erreur 500 sur le front office. De son côté, le back office est parfaitement accessible et fonctionne normalement.

 

Regénérer le .htaccess solutionne le problème à chaque fois.

 

J'ai également passé le site en mode debug quand l'erreur 500 apparaît mais il n'affiche aucune erreur.

 

Je sèche maintenant et ne sais pas comment identifier la cause de ces erreurs 500 à répétitions.

 

Je précise aussi que le site est en ligne depuis octobre dernier, qu'il n'a généré aucune erreur 500 pendant plusieurs semaines. Le problème est apparu en janvier (peut-être ne veut-il pas changer d'année  :unsure: ). Aucun nouveau module ou fonctionnalité n'ont été ajouté à cette période.

 

Une âme charitable pourrait-elle m'aider à régler ce problème ?

Merci.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

j'ai exactement le même souci,
Dernier problème erreur 500 il y a 10 minutes.
A chaque fois ca foire les catégories. :(
Je n'ai pas trouvé la solution, c'est vraiment aléatoire.

Seul méthode pour moi, vider le cache.

Si quelqu'un pouvait nous aider, ca serait vraiment gentil! :) 

Share this post


Link to post
Share on other sites

en mode debug j'ai ce message d'erreur as tu le même?

Fatal error: Uncaught --> Smarty: unable to write file /homepages/22/d206959822/htdocs/presta/cache/smarty/cache/productcomments/1/1/1/2/1/8/97/05/13/be/wrt58b035320531e6_21578629 <-- thrown in /homepages/22/d206959822/htdocs/presta/tools/smarty/sysplugins/smarty_internal_write_file.php on line 46

Share this post


Link to post
Share on other sites

si tu utilises un client FTP comme FileZilla, tu te connectes à ton ftp, et tu vas jusqu'au répertoire /homepages/22/d206959822/htdocs/presta/cache

Un clic droit sur le répertoire, attributs du fichier, et tu mets 777 ou 755, et "récursion"

Share this post


Link to post
Share on other sites

Bonjour,

 

Désolé, j'ai pris quelques jours de congés et je viens de voir vos réponses. De mon côté, le problème venait en fait de mon hébergement qui n'était pas suffisant. les ressources allouées étaient insuffisantes pour assurer le trafic et lors de pic de connexion sur le site, le serveur "plantait", ce qui expliquait les erreurs 500.

 

Depuis le passage à un hébergement mieux dimensionné, l'erreur 500 n'est plus réapparue.

Share this post


Link to post
Share on other sites

  • 3 weeks later...
  • 1 month later...

Bonjour a tous
fausse joie, ça recommence :( 
 

mais a voir le nombre de post a ce sujet, je ne suis pas le seul a avoir cela, d'un coté ça rassure!
J'ai vidé le cache comme un c**, donc j'ai pas eu le temps de mettre le mode debug!
A très vite quand le bug reviendra, c'est 1 à 3 fois par semaine.
Merci pour votre futur aide! :) 
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More