Jump to content
alex4129

PS 1.7.0.4 - installation - pas d'accès aux modules

Recommended Posts

Bonjour,

 

C'est ma première installation de PS 1.7.0.4 chez mon hébergeur.

 

Dans le back-office, quand je clique sur modules, j'obtiens le message suivant :

Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache

 

Savez-vous comment solutionner ce problème ?

N'ayant pas accès aux modules, je ne peux pas afficher de nouvelle catégorie dans le module "menu"

 

Je n'ai pas cette erreur sur mon serveur de test local (WAMP) où j'ai bien accès à la liste des modules installés par défaut et peux les mettre à jour, les configurer, etc.

Share this post


Link to post
Share on other sites

bonjour,

 

je suis dans le même cas mais son PS 1.7.0.3 

 

quand je clique sur modules, j'obtiens le message :

Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache

 

j'ai donc verifier toute les dernier erreur sur se probleme lier au ancienne version toout est bon si quelqu un a une solution merci 

 

cordialement

Share this post


Link to post
Share on other sites

La version 1.7 n'est sortie qu'en novembre 2016 et la documentation en français est encore incomplète
Il va y avoir pas mal de bugs, cette version est toute jeune.

Donc j'ai décidé de "rétrograder" en version 1.6.1

 

Le problème a été évoqué sur le forum anglophone mais les solutions proposées ne marchent pas aujourd'hui :

https://www.prestashop.com/forums/topic/564209-modules-and-services-are-inaccessible/

Share this post


Link to post
Share on other sites

bonjour,

 

je suis toujours a la recherche de la solution j ai pu lire sur le forum anglophone que certain serai passé en PHP 5.6 quel version avais vous?

 

car si je pase en version 5.6 je doit modifié la base de 3 site puff du taf juste pour un site qui déconne 

Share this post


Link to post
Share on other sites

Bonjour,

 

J'ai le même problème et nous sommes nombreux visiblement !! Je trouve ça dingue que personne de PRESTASHOP ne réponde... J'ai mis 1 heure à joindre quelqu'un par téléphone pour m'entendre dire que le problème vient d'OVH mais chez OVH on me répond qu'il n'y a aucun problème et que ça vient bien de PRESTASHOP à priori, ce qui semble plus plausible quand on voit le nombre de personne touchées par ce bug qui ne sont pas forcément chez le même hébergeur. Ca fait 3/4 d'heure que j'essaye de nouveau de joindre quelqu'un par téléphone... Si quelqu'un a des réponses... Merci

  • Like 1

Share this post


Link to post
Share on other sites

Après avoir finalement réussi à avoir un interlocuteur par téléphone je n'ai pas de chance, il est 12h45, toute l'équipe est partie en "meeting" jusqu'à environ 14h donc personne en mesure de répondre... HAHAHA!!!

Share this post


Link to post
Share on other sites

Bonjour , 

 

Moi aussi j'ai le même problème!

J'ai installer la dernière version de Prestashop 1.7.0.4 en local avec wamp server , tous marche très bien sans erreurs.

 

je créer un domaine et une base de donné ( hébergement ) par OVH. J'ai déplacer mon travail du local vers dossier racine www Avec Filezilla. je fais l'import et l'export de la base de donné avec les modifications nécessaire ( changer le nom de domaine de localhost a mon nom de domaine par ovh ect.. ).

 

Enfin, c'est fait mais un seul problème dans L'onglet Modules et service ( inaccesible ... avec un message d’erreur ) :

 

Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache

 

et Quand je clique sur Installed module ou notification j'ai reçois un autre erreur :

ConnectException in RequestException.php line 49:

cURL error 35: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

 

Je fait 2 imprime écran pour ces 2 problèmes .

S'il vous plait J'attend la réponse et comment résoudre ce problème ?  

 

Si il y a une solution svp !! Sinon Quelle est la meilleur version de prestashop et je l'utilise ! 

 

post-1319974-0-86933100-1485261213_thumb.jpg

post-1319974-0-32368400-1485261219_thumb.jpg

Edited by jam3oun (see edit history)

Share this post


Link to post
Share on other sites

personnellement jai touvé la solution je suis passé en PHP 7 plus de problème 

Share this post


Link to post
Share on other sites

@baillot, moi je l'étais déjà du coup j'avais fait le contraire (essayé de repasser en php 5.6) mais rien. Et après avoir lu plusieurs choses disant que PRESTASHOP 1.7 n'était pas du tout au point et pleine de bug, j'ai tout désinstallé pour ré-installer la version 1.6. Maintenant tout roule ;-)

Share this post


Link to post
Share on other sites

Bonjour,

 

Même problème pour moi.

Hébergé chez OVH.

 

Je suis passé en PHP 7 et les modules s'affichent... cool, mais pas trés rassurant tout ça. Je vais attendre un peu avant de passer en production je crois.

 

Merci

 

 

 

Share this post


Link to post
Share on other sites

Bonjour,

 

problème strictement identique à jam3oun.

D'après plusieurs info sur CURL, il faudrait updater cURL and OpenSSL.Mais avec OVH en mutualisé c'est pas possible (c'est nul).

Donc la solution de passer à une version supérieure résout le problème normalement comme le propose JC et baillot.

 

Ma question est comment avez-vous fait,

je suis sous ps 1.7.0.4 theme Classic en mode Debug et PHP7 et je récolte une [ erreur 501 Method Not Implemented GET to ]

j'appelle PHP7 au lieu de 5.6 avec

app.engine.version=7.1 

dans un fichier .ovhconfig

 

Une idée SVP ?

Share this post


Link to post
Share on other sites

Bref malgres mes recherches impossible de trouver une solution, j ai finalement finis par installer une version antérieur.

Share this post


Link to post
Share on other sites

Petit UP

 

et aussi, quelqu'un aurait un exemple de site en ps1.7 qui fonctionne en production ?

 

Merci,

Share this post


Link to post
Share on other sites

Pour ceux qui sont sur un hébergement mutualisé OVH, j'ai pu résoudre le problème, dans mon cas, an ajoutant ces lignes dans un fichier .ovhconfig à placer à la racine du site:

 

app.engine.version=7.0
environment=production
container.image=stable

Edited by Theme01 (see edit history)

Share this post


Link to post
Share on other sites

@Theme01,

Merci, j'ai en effet résolu mon problème en appelant 7.0 et non 7.1 qui n'est pas actif chez OVH en mutu. Le problème venait aussi d'un conflit entre deux fichiers .ovhconfig :-p

Pour info, sur du multi-site, on peut bien avoir plusieurs .ovhconfig, un pour chaque site, mais alors mieux vaut ne pas en mettre un autre à la racine !

Si ça peut aider ( ).

 

Quelqu'un aurait un site sous 1.7 en production à montrer ?

Merci.

Share this post


Link to post
Share on other sites

@WAJWAJ,

 

bon à savoir pour le multisite, le fait qu'il ne faille pas en avoir un à la racine en plus.

 

Moi j'ai des sites visibles mais c'est juste pour démo, donc pas forcément représentatif d'une vrai boutique:

 

http://theme01.com/prestashop/demos/01oslo_1_7_fr.html

http://theme01.com/prestashop/demos/01grid_1_7_fr.html

http://theme01.com/prestashop/demos/01premium_1_7_fr.html

 

 

http://theme01.com/prestashop/demos/01response_1_7_fr.html

Share this post


Link to post
Share on other sites

@theme01,

 

oui, c'est suite à une discussion avec le support OVH.

Sympa tes thèmes made in, ça peut m'intéresser pour de futur site, merci.

 

A +

Share this post


Link to post
Share on other sites

Bonjour,

 

Je viens d'installer la dernière version de PS 1.7(1.7.0.5) et impossible d'accéder aux modules car il y a une erreur 404 :  

index.php/module/catalog?_token=xxx

 

Quelqu'un a une idée ?

Share this post


Link to post
Share on other sites

Wokky je viens d'installer presta j'ai le même souci que toi une erreur 404 ou une redirection vers la page d'accueil du front (selon le choix des urls simplifiées ou pas dans paramètres de la boutique->traffic)  si je veux accéder aux modules ou aux produits dans le back;

As-tu trouvé une solution depuis le temps?  Parce que là j'entends les sirènes de woocommerce .......

Share this post


Link to post
Share on other sites

Coincidence ou pas je viens de lire que ce sont les 2 pages (modules et produits dans le back) qui sont gérés via sf2. Le reste du back office fonnctionne normalement... :wacko:

Share this post


Link to post
Share on other sites

Bonjour, 

 

actuellement j ai le même probleme d erreur 504? savez vous m orienter la dessus? Merci

Share this post


Link to post
Share on other sites

Pour ceux qui sont sur un hébergement mutualisé OVH, j'ai pu résoudre le problème, dans mon cas, an ajoutant ces lignes dans un fichier .ovhconfig à placer à la racine du site:

 

app.engine.version=7.0

environment=production

container.image=stable

Tu me sauve la vie ! Ça fait 1 semaine que je suis comme un fou à chercher et la .... ça fonctionne !!!! Merci a toi au dieu de l'informatique 

Share this post


Link to post
Share on other sites

Pour ceux qui sont sur un hébergement mutualisé OVH, j'ai pu résoudre le problème, dans mon cas, an ajoutant ces lignes dans un fichier .ovhconfig à placer à la racine du site:

 

app.engine.version=7.0

environment=production

container.image=stable

Merci beaucoup ça fait aussi 1 semaine que je chercher cette solution tu es au top !

Pour corriger cette erreur Cannot get catalog data, please try again later. Reason: Data from PrestaShop Addons is invalid, and cannot fallback on cache

 

 

Je suis passer en PHP global 7.0 puis j'ai modifier le fichier .ovhconfig et tout a fonctionné !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More