Jump to content

Error: ERR_TOO_MANY_REDIRECTS Prestashop 1.7


ugur7
 Share

Recommended Posts

Hi,


I get the ERR_TOO_MANY_REDIRECTS error just modules and products page on the prestashop admin panel. When i try to connect pages url is contain ...security/compromised.... I was changed the all modules names for the making disable. But its not help to me.


How can i fix? Which methods can I try?


Thanks


Share this post


Link to post
Share on other sites

  • 4 weeks later...

I am also having the same problem. I have LAMP server. I uploaded the entire zip and index.php. It was able to extract then it sends ERR_TOO_MANY_REDIRECTS error. 

 

I also tied to put 777 permision to the root folder and also the app folder. nothing changed

Share this post


Link to post
Share on other sites

  • 2 months later...
  • 2 months later...

No, in 1.7.1.2 this error now
Cant use search in admin side, products or modules

Google result 1900+ pages about "err_too_many_redirects + symfony2"
3 day cant works with shop.. any ideas?
How i can fix that?

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Hi!

Is there any solution for this error ("ERR_TOO_MANY_REDIRECTS")?

I've tried everithing but the error still persists.

- clean cache;

- regenerate .htaccess;

- define('_PS_MODE_DEV_', false);

- URL's in DB and backoffice which seem ok;

 

What else?!

 

Thanks in advance.

Share this post


Link to post
Share on other sites

  • 2 months later...
  • 1 month later...

Solution for Cpanel - 

In your MultiPHP INI Editor or PHP.ini File;

under 'session.save_path ' make sure that you point to "/home/(YOUR CPANEL NAME)/php"

this worked for me as it was defaulting to /var/cpanel/php/sessions/ea-php56

Share this post


Link to post
Share on other sites

  • 10 months later...

I have the same issues, update to 1.7.4.3 from 1.6.x, it appears to get random admin pages error. Problem i found is in the token generation as you can see in the screen captures. (PHP version 7.2)

 

You can see working ok in cap1, working bad in cap2 and what happens when i click a bad link in cap3

 

Funny about that is sometimes the page which give me the error stop malfunctioning. Testing right now is catalog->products, modules->Modules and services, modules-> Modules catalog, store configuration, product configuration, customer configuration, and some of the advanced configuration

 

I regenerate htaccess, clean cache, put dev mode to true... nothing working and this has nothing to do with nginx

 

someone has a solution please?

1-enlace-bien.jpg

2-enlace-mal.jpg

3-redireccion-mal.jpg

Share this post


Link to post
Share on other sites

  • 3 weeks later...
  • 9 months later...
  • 5 months later...
On 1/18/2017 at 1:49 PM, ugur7 said:

Hi,

 

I get the ERR_TOO_MANY_REDIRECTS error just modules and products page on the prestashop admin panel. When i try to connect pages url is contain ...security/compromised.... I was changed the all modules names for the making disable. But its not help to me.

 

 

How can i fix? Which methods can I try?

 

 

Thanks

 

Check if you have enough disk space in your server. A missconfiguration in a backupmodule filled my server and caused this redirects problem. Deleted the junk geneerated and solved. You should start checking for this.

Share this post


Link to post
Share on other sites

  • 5 months later...

This problem is most of the times related to SSL issues.

If you have HTTP to HTTPS redirects enabled while there is some other setting which redirects a https request to an http webpage, hen you will get this error.
For example, if you have HTTP to HTTPS redirects enabled, but you have a setting in .htaccess which redirects like this: Redirect 301 * http://<DOMAIN_NAME>.com/
Or if you see some other settings in there which redirects to a http page.

That's most commonly related to this issue in my opinion.



Next is if you for example use Cloudflare.
Cloudflare has 4 SSL options:

1. "Off (Not Secure)"
2. "Flexible"
3. "Full"
4. "Full (Strict)"

What SSL setting should I use?

This setting controls how Cloudflare’s servers connect to your origin for HTTPS requests. We recommend enabling the Full SSL (Strict) setting if possible. Common use cases for each are:

Off: No visitors will be able to view your site over HTTPS; they will be redirected to HTTP.

Flexible SSL: You cannot configure HTTPS support on your origin, even with a certificate that is not valid for your site. Visitors will be able to access your site over HTTPS, but connections to your origin will be made over HTTP.
* Note: You may encounter a redirect loop with some origin configurations.

Full SSL: Your origin supports HTTPS, but the certificate installed does not match your domain or is self-signed. Cloudflare will connect to your origin over HTTPS, but will not validate the certificate.

Full (strict): Your origin has a valid certificate (not expired and signed by a trusted CA or Cloudflare Origin CA) installed. Cloudflare will connect over HTTPS and verify the cert on each request.



And last one you can check is for when you get this error while you did just install Prestashop.

1. Try to log in to the backend via: https://<my-domain.com>/Backoffice/index.php

2. In PrestaShop Backend, click Shop Parameters (under Configure) > General.

3. Click "Yes" next to Enable SSL and click Save to apply the changes.

4. Then click "Yes" next to Enable SSL on all pages and click Save to apply the changes.

 

Share this post


Link to post
Share on other sites

  • 1 month later...
  • 2 months later...

Fixed

For me cause was - 'session.save_path'

But it's important to understand why. 

In my case I migrated from cPanel to Docker installation. And in the root directory I had .htaccess, .user.ini and php.ini with:

php_value session.save_path "/opt/alt/php72/var/lib/php/session"

this string cPanel add automatically.

But after migration (or if you change hosting or PHP version) this path may be invalid. 


Solution:

Check your files for this parameter: session.save_path

  • remove this string (I did so. PHP will be use default session.save_path from php.ini)
  • or edit to the correct path. (php70/71/72/73/74 and check if this path really exists and it's enough of permissions to write there)

Share this post


Link to post
Share on other sites

  • 2 weeks later...
  • 2 months later...
  • 2 months later...
Posted (edited)
On 7/11/2020 at 1:06 PM, Crypt0Maniak said:

This problem is most of the times related to SSL issues.

In deed, on my case, it was an SSL issue. I had an old PrestaShop 1.5.x site, which I upgraded to 1.5.6.3. I only had the files and the database because the website was closed long time ago. So, I didn't recall how my old server was setup. After fixing some MySQL and PHP problems related to the newer versions, I was getting that error. Then I realized that in the Apache VirtuaIHost was doing an SSL redirection. On the PrestaShop backoffice, the option "Enable SSL" was set, so, I removed it and the problem was gone.

 

It seems that the SSL redirection was done twice: once by Apache and the other one by the .htaccess file created by PrestaShop, so, this created an infinite loop that at the end caused that error.

 

Let's see if I get this upgraded to PrestaShop 1.6 and then to 1.7.

 

Thanks for your post.

 

Best regards

Josef

Edited by jmeile (see edit history)

Share this post


Link to post
Share on other sites

Just for the record: I upgraded my Prestashop to 1.6.0.5. It was working on my server because I still had an old PHP version. Then I updated my server and Prestashop stop working because of PHP 7.2. Ok, then I updated Prestashop to version 1.6.1.24 (last stable version of 1.6). The back-office worked, but the front-end was showing again: "ERR_TOO_MANY_REDIRECTS".

I fixed this by setting: "Redirect to the canonical URL" to: "No redirection (you may have duplicate content issues)". It is working now with some small issues.

I will now proceed to upgrade to 1.7.x

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Hello,

To solve this problem, only you must enable the SSL for PrestaShop.

Enabling SSL for PrestaShop

To enable SSL for PrestaShop, follow these steps:

1) Log in to PrestaShop as the administrator.

2) On the left sidebar, click Preferences, and then click General.

image.png.8e8bc413ca05f43eb52022a6cd55bb6e.png

3) Click Please click here to check if your shop supports HTTPS and follow the orientations.

4) Enable SSL, clicking in Yes Button

5) Save changes

6) Enable SSL on all pages, after save step 3

7) Save changes again and test your website.

If the SSL test for your shop succeeds, the Enable SSL field displays YES and NO options, and the URL in the browser address bar starts with https://. Alternatively, if you receive a warning message (or any other type of error message) after the test, your site either does not have an SSL certificate installed, or it is configured incorrectly.

To enable SSL for customer account logins and order processing, next to Enable SSL, click YES.

To enable SSL for all of the pages on your PrestaShop site, next to Enable SSL on all pages, click YES.

Click Save. SSL is now enabled for PrestaShop.

After enabling SSL, you and your customers may receive browser warnings about insecure content. This occurs when a secure page loads embedded resources insecurely using http:// instead of https://. (Custom themes are a common cause of this problem.) For information about how to resolve issues with insecure content, please see this article.

 Good luck.

Share this post


Link to post
Share on other sites

  • 3 weeks later...
  • 3 months later...

This happened to me when I used Let's Encrypt SSL on a Bitnami LAMP server. Let's Encrypt has an automated setup that installs the certificate and automatically adds an HTTPS redirect in the Apache virtual host file (mine is at opt/bitnami/apache/conf/vhosts/vhost.conf).

I was unable to get into PrestaShop because of the "too many redirects " error, so the solution was to edit the Apache virtual host file by adding a pound sign (#) in front of these lines:

	RewriteEngine on
	RewriteCond %{SERVER_NAME} =example.com
	RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

...so that it looks like this:

	# RewriteEngine on
	# RewriteCond %{SERVER_NAME} =example.com
	# RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

The pound signs turn those lines into comments that will be ignored by the web server. 

Then restart Apache...

sudo /opt/bitnami/ctlscript.sh restart apache

After that, I was able to log into PrestaShop and enable SSL, using the detailed instructions provided by Raphael Duarte elsewhere in this thread.

The instructions above are specifically for a Bitnami LAMP server, but could be adapted to any Apache-based server. The file names and paths will be different, but the concept is the same.

Share this post


Link to post
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More