Jump to content

Recommended Posts

Boa tarde, tudo bem?

 

As vezes quando o cliente cadastra, e tenta acessar um produto, ele recebe a mensagem de erro, dizendo que não tem acesso aquele produto. Se eu vou no cliente e desativo e ativo novamente, volta o acesso, alguém já passou por isso?

 

515b8fe7e3444971b2de3f6eadf38483.png

 

Obrigado!

Share this post


Link to post
Share on other sites

Vc. deveria dar uma olhada no produto em questao que está dando problema, pode ser que nao está ativado para um grupo de clientes específico.

 

Se os produtos estiverem ativados para todoso os grupos de cliente, entao deleta o smarty cache e verifique se o seu servidor está configurado de acordo com os requisitos mínimos.

 

Deletar cache: https://www.prestashop.com/forums/topic/287689-cole - post#2

 

Requisitos mínimos: http://www.prestashop.com/forums/topic/236128-tutorial-servidor-configuracao-minima-para-ps-15/

Share this post


Link to post
Share on other sites

Esse erro aparece em todos os produtos.

 

Vou explicar mais detalhado. Eu migrei do Opencart para o Prestashop com o Cart2Cart, então todos os clientes migrados da esse erro em todos os produtos.

 

Se eu entro nos dados do cliente, desativo e ativo novamente, volta a funcionar.

Share this post


Link to post
Share on other sites

Erro de migracao. Se pegou o servico pago, entao entre em contato com os craques do cart2cart para que estes possam debugar o erro. Provavelmente faltou a ativacao dos produtos para grupos de clientes.

Share this post


Link to post
Share on other sites

Se quando loga não consegue mais ver nenhum produto / categoria, acredito que deve verificar as permissões dos grupos de clientes em cada categorias.

Share this post


Link to post
Share on other sites

Se sao todos os produtos, entao o erro está nas categorias. Verifique a configuracao. Provavelmente as categorias estao desativadas para certs grupos de clientes.

 

ABA: Catalogo -> categorias -> edite TODAS as suas categorias (master e sub-categoria). No final desta página ative os grupos de clientes que poderao visitar os produtos da categoria correspondente.

 

post-741527-0-12632300-1485074468_thumb.jpg

Share this post


Link to post
Share on other sites

Eu verifiquei todas as Categorias, estão todas com as permissões ativadas. O problema é que o cliente cadastra, ele fica sem permissão, eu apenas vou lá em CLIENTES, DESATIVO e ATIVO ele novamente, e volta o acesso.

Share this post


Link to post
Share on other sites

Os seus clientes form importados com o cart2cart ? Pode ser que estes importados nao foram atribuídos à um grupo de clientes ativo. Isto somente verificando no banco de dados. Para evitar o problema, vc. deveria retrabalahar os seus clientes, verificando/ativando os grupos ao qual cada um deles pertence. Pode ser que na importacao eles foram importados a um ID de grupos nao existente, sendo assim fica ativado no back-office um grupo qualquer, em vez do grupo atual/ativo.

Share this post


Link to post
Share on other sites
Posted (edited)

Olá, estou com o mesmo problema na versão 1.7.3, já fiz todos os passos citados acima e não tive resultado algum, como  resolver?

Edited by Gabriel Dias (see edit history)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More