Jump to content

Prestashop 1.7. Error 404 in admin after installing!


Recommended Posts

Hi. I have installed a lot of CMS. But I have a problem installing prestahop 1.7-

I have:

  • a compatible hosting
  • created a database
  • uploaded the Prestahop 1.7 files
    • uploading a zip file and then unzipping with the hosting tool
    • uploading directly with FTP client
  • installed well prestahop

But after finishing installing and I click i backend, it is telling me "Error 404".

If I go to the front it is working, but i can not access to the back(admin).

 

Uploading by ftp I have three errors uploading files:

  • vendor/doctrine/orm/bin/doctrine.bat
  • vendor/doctrine/orm/docs/en/make.bat
  • vendor/symfony/symfony/src/Symfony/Component/Console/Resources/bin/hiddeninput.exe

 

I have tried several times, and always "Error 404"

 

Any idea what is happening?

 

THanks!

Share this post


Link to post
Share on other sites

It is a new project(I am going to migrate from Joomshopping to Prestahop). I have seen that 1.6 is going to be continued untill october 2018.

 

Do you think that I should use 1.6?

 

No, the admin folder has not changed. Anyway,I have changed the name, and the same problem.

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 2 months later...

fresh install of presta 1.7.0.6

just downloaded from presta web site, and installed.

frontend works, admin panel generates 404 error.

 

crappy. nobody tried to install it before distributing...?

 

its a shame for presta.

Share this post


Link to post
Share on other sites
  • 4 weeks later...
  • 2 weeks later...
  • 4 weeks later...

Hello,

 

I had the same issue and i solve it looking into my error logs from cpanel.

 

The problem is more related to some kind of missconfiguration rather that any php fpm settings.

 

In order to solve the problem u need to look into your error log and fix the file permission... i had a lot of core files with 666 permision and it should be 644.

 

 

Best regards

Edited by pdsolutions (see edit history)

Share this post


Link to post
Share on other sites
  • 2 months later...

I suggest:

  1. check excact name od admin directory and go to http://domainname/AdminDir/ if still 404:
  2. change .htaccess file name and try again, if there is an error now, it means that problams lays in some php error in backend script
  3. look in error log file and try to find the reason

In My case it was Options -MultiViews in admin/.htaccess file. After I commented it prestashop works fine.

Share this post


Link to post
Share on other sites
  • 1 month later...

Hello, i had this problem too.

 

I fixed the problem by doing the following steps:

 

1) Go to the "admin" folder

2) Find the file .htaccess, (backup in another location) and delete it

3) For security, rename the "admin" folder example: "consola"

4) Try enter again with the direction: "yourdomain.com/consola"

 

View tutorial here: https://youtu.be/nHyHBJBf57o

  • Like 1

Share this post


Link to post
Share on other sites
  • 3 months later...
  • 1 month later...
  • 2 months later...

Check for the name of your admin folder. That's important. Also check your folder permissions.

Next check whether you are using apache or nginx. Nginx doesnt use .htaccess files.

If you are using nginx locate your nginx configuration file for your domain/virtual host and add this block (Note: rename admin folder to yours)

location /yourAdminDir/ {
            try_files $uri $uri/ /yourAdminDir/index.php?$args;
        }

Share this post


Link to post
Share on other sites
  • 7 months later...

For me works: 

1. Check the exactly name of your admin folder and put it into URL

yourdomainname/admin - doesn't work

yourdomain/nameofadminfolder - its work

 

Share this post


Link to post
Share on other sites
  • 4 months later...

yes in my case after installing presta 1.7.3.3 "admin" folder is changed to "admin3006mgwd1". After I add this to the end of url everything works well.

Share this post


Link to post
Share on other sites
  • 10 months later...

Same issue for me. Turns out the admin folder had been renamed to something like admin312213hh.

It worked perfectly fine as soon as I had deleted the "install" directory and typed the correct admin directory in the browser.

Version 1.7.5.1 by the way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More