Jump to content

Can't translate Email templates into slovenian


Go to solution Solved by dusko.dusko,

Recommended Posts

Hello,

 

I am having problems translating email templates into slovenian language. After translation the changes don't take effect. Email templates are still delivered in english. However in backend they are saved in slovenian.

 

Does anyone know what could be causing this?

 

Please help.

 

I am running prestashop 1.6.1.6 with own theme copied from default bootstrap. Installed languages english and slovenian.

 

Thanks,

Dusko

Share this post


Link to post
Share on other sites

back office-->localization-->translations-->email template translations-->

 

here you  can select 'core no theme' or a theme.

 

Some themes like default theme do not have a mails folder, they would be translated 'core no theme'.  other themes (espeically 3rd party) have their own mails folder.

 

using ftp check that the mails folder (files below) have been updated in root folder or theme folder.  it sounds to me like ps is using one mail folder and you are translating another.

 

el

Share this post


Link to post
Share on other sites

Here I must contradict you slightly. :)

You need to select a theme. Modified mail translations are always stored into the active theme's folder - or should be. They work like an override. So don't use the option Core- no theme selected for mails. It wouldn't work.

Share this post


Link to post
Share on other sites

Hi elezar! happy 2017.  What I noticed is that 'mails' folder is not contained in default theme folder, so I'd assume 'core no theme', but did not test it.  The core/theme selector sure has tripped a lot of people up over the years.  Happy day, el

Share this post


Link to post
Share on other sites

Hi, el,

honestly, who needs logic when you can have ... PrestaShop!  :D

noje08s40lemmy313687tq-2.jpg

 

 

lol...yea...the drop down for core/themes....has created a lot  of issues for 'many'.  myself included...I got tripped up on this doing module xlations....wrote an  article here..now lost to mother time....I  got to get a blog....lol

 

hey tell the mod group....retirement from moderation, I will outlive them all...jajajaja

Share this post


Link to post
Share on other sites
  • Solution

Hey guys,

 

thanks for all the help. I noticed I had two folders of my theme one with caps MYTHEME and one with lower case mytheme. After removing the wrong folder my translations for email templates work again.

 

I am translating back office-->localization-->translations-->email template translations-->mytheme (slovenian language).

 

Thanks,

Dusko

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More