Jump to content
miguel pulido

1.7 No guarda cambios en producto

Recommended Posts

A modificar un producto como su descripción o precios, le doy clic a guardad y aparece el recuadro verde que dice los cambios se han guardado pero al previsualizarlo o al recargar la pagina no hizo el cambio, ya borre cache y trate de duplicar y modificar el producto pero no guarda cambios

  • Like 1

Share this post


Link to post
Share on other sites

Hola Miguel,

 

Indicarte que la versión 1.7 por ahora da muchos fallos, se recomiendo tirar por el momento con la 1.6 que va a tener soporte de actualizaciones hasta 2018.

 

Por otro lado, referente a tu error en la 1.7

 

Revisa si en el repositorio: https://github.com/PrestaShop/PrestaShop/pulls esta reportado el error como bug aunque no parece que sea un bug por lo que dices..

 

¿La versión que usas es la 1.7.0.3  u otra mas anterior como la 1.7.0.2?

 

¿Te pasa cuando creas cualquier producto "Nuevo" o cuando editas uno?

Share this post


Link to post
Share on other sites

Ese error lo tenia en la version 1.6.1.7 hasta ayer que tuve que cambiar para la version 1.6.1.10 que esta ultima funciona bien.

 

 Antes tenia que editar un articulo y darle a guardar unas cuantas veces hasta que me lo guardaba. Ahora con la version 1.6.1.10 va perfecto.

 

SUpongo que la 1.7 le pasa lo mismo. Mi recomendacion es que retrocedas a la que te digo yo.

Share this post


Link to post
Share on other sites

El mismo error tengo, cualquier cambio que desea hacer en los productos no me deja guardar, me sale un error NO SE PUEDE ACTUALIZAR LA CONFIGURACIÓN y en la pestaña de ajustes básicos me sale en rojo, estoy en la versión 1.7.0.4. ayuda por favor

  • Like 1

Share this post


Link to post
Share on other sites

Tengo muchos problemas en la sección productos,  dentro cuando relleno los campos "envío" "precios" no me deja guardar 

  • "The CSRF token is invalid. Please try to resubmit the form."  (producto con combinaciones)

Share this post


Link to post
Share on other sites

Hay mas errores que ese, no importa bien los catálogos de productos cvs, y el smarty internal templabase da errores , tampoco contacta bien con el carro de la compra ni el tvp virtual ni los impuestos

Share this post


Link to post
Share on other sites

Mi recomendacion es que pases de la version que tengas a la version 1.6.1.10 He actualizado ya 3 paginas a esta version y va de lujo de momento. Nada que ver con las anteriores. 

 

 Lo que hice primero fue hacer una copia de seguridad. Tanto de archivos como de base de datos ( esto es lo primero ) por si algo falla siempre puedes volver a un clic!

 

Tras bajarte los archivos a tu ordenador desde el servidor y ponerlos a buen recaudo, bajas tambien la base de datos aunque pesen bastante. Hay programas que te dejan subir despues las bases de datos de gran peso al servidor.

 

paso 2:

 

Añadele un _ al nombre que tienes de la carpeta de archivos en el servidor de tu web. Por ejemplo: _mi web (antes: mi_web) o bien renombrarllo con otro nombre. Eso te servirá como copia de seguridad temporal ( tu pagina dejara de funcionar mientras tengas el " _ "

 

Paso 3: crea una carpeta o mejor crea esa carpeta nueva con el nombre que tenias de tu carpeta web. DOnde tenias o tienes instalado los archivos de tu web: Ejemplo: MI WEB quedando la copia de seguridad en servidor como " _MI WEB.

Accede a tu panel de control de hosting, a la seccion de Dominios, y redirige tu dominio a la nueva carpta que creaste ( mi consejo es que hayas puesto la misma carpeta, y a la original solo haber puesto un " _MIWEB " asi no necesitas redireccionar el dominio y los vinculos funcionaran perfectamente.

 

paso 4: crea una base de datos nueva en tu servidor hosting.

 

Todo esto sirve para que hagas una instalacion en paralelo, manteniendo  tu pagina intacta, que en un casual algo te sale mal, solo tienes que volver al estado anterior sin necesidad de subir ningun archivo ni base de datos en caso de catastrofe.

 

paso 5:

 

Ahora desde el panel control de tu hosting, creas una nueva base de datos.

 

paso 6:

 

  Sube a esa nueva carpeta la nueva version 1.6.1.10 ( esta version va muy bien, al menos con el tema que nos incumbe ) si no la tienes te la mando por email. Despues te dejo mi telefono por si me quieres llamar y te ayudo por telefono. Una vez subidos los archivos, haz la instalacion nueva, con el nombre de la NUEVA BASE de datos que creaste. COmo si hubieras hecho una instalacion nueva.

 

paso 7: Una vez con una instalacion nueva, tienes que hacer lo siguiente. La base de datos que bajaste de tu tienda antes, haz una copia y ponla a recaudo. Abre una de ellas y busca el nombre de esa base de datos, y cambialo por el nuevo nombre de la nueva base de datos. Una vez hecho esto, ve a tu hosting, a bases de datos, y le das a modificar la nueva que creaste nueva. Una vez visible todas las tablas, vas abajo o arriba, depende tu hosting, las señalizas todas y le das a eliminar dejando la base de datos vacia ( ojo, hablamos de la nueva base de datos. La antigua no la toques. Bien, una vez eliminada, subes la base de datos original que abriste y que modificaste el nombre por la nueva. Subes esa base de datos. Si pesa mucho, usa cualquier programa que te permita subir bases de datos de alto peso.

 

paso 8: Si intentas entrar a tu tienda no te dejará seguramente. Pon que has perdido la contraseña  y entra con la contraseña que te envia la web.

 

paso 9: Subes los archivos de la carpeta: Themes/ y la carpeta img/ de la plantilla que tenias antes sustituyendo por los nuevos, y pruebas a entrar. Recuerda cambiar nuevamente la contraseña. Si ves que las fotos no se ven bien o no se ven, ve a la seccion de SEO+URLS de tu black office y donde pone configuracion de enlaces, le das a enlace amigable y guardas. SI no estaba activado lo activas y desactivas. Pero si tienes la web en varios idiomas, te recomiendo activarlo. Una vez hecho esto, las imagenes volveran a verse.

 

 Aun asi, te recomiendo que me llames por telefono al 966 300 254 y te asesoro mejor.

 

Espero que te sirva.

Edited by Dartacan36 (see edit history)

Share this post


Link to post
Share on other sites

muchas veces también tiene que ver la configuracion que te proporcione tu proveedor de Hosting, en mi caso hay un cantidad de errores 500 en mi servidor que antes no había detectado, por ahora voy a pasarme a web empresa, que al parecer es un hosting especializado en prestashop.

 

les estaré avisando como me va, saludos.

Share this post


Link to post
Share on other sites

Hola!

 

Tengo ese problema. Estoy con la versión 1.7.0.4.

¿No es posible solucionarlo sin tener que pasar a una versión anterior?
En otra cadena he leído que había que eliminar unas líneas del archivo:

 /adminXXXX/themes/default/template/controllers/products/helpers/form/form.tpl: https://github.com/P...m.tpl#L252-L254
Pero yo no tengo la carpeta /products así que no encuentro ese archivo.

 

¿Alguien me puede echar una mano?

Gracias!

  • Like 1

Share this post


Link to post
Share on other sites

Tengo muchos problemas en la sección productos,  dentro cuando relleno los campos "envío" "precios" no me deja guardar 

  • "The CSRF token is invalid. Please try to resubmit the form."  (producto con combinaciones)

Parece ser un problema con PHP. Intenta aumentar el parametro max_input_vars (predefinido es 1000) en php.ini. Si tienes combinaciones necesitas más "request parameters" que 1000.

Share this post


Link to post
Share on other sites

Saludos, espero no sea tardía mi respuesta. Tenía el mismo problema y tras probar todas las soluciones posibles, esta fue la única que me dio resultado:

 

Ubicar el archivo src\PrestaShopBundle\Form\Admin\Type\CommonAbstractType.php

 

En el reemplazar la línea:

$new_list[$item[$mapping_name]] = $item[$mapping_value];

 

por:

 

$new_list[$item[$mapping_name].$item[$mapping_value]] = $item[$mapping_value];

 

Aparentemente de esta forma es posible que coexistan categorías con el mismo nombre pero con un único valor de referencia.

Share this post


Link to post
Share on other sites

Sinceramente no supe remediarlo, elimine la instalación e instale la nueva versión y tuve que volver a hacer todo, la app de clic to upgrade tampoco me funciono

Share this post


Link to post
Share on other sites
On 29/9/2017 at 5:41 PM, jmcaicedo said:

Saludos, espero no sea tardía mi respuesta. Tenía el mismo problema y tras probar todas las soluciones posibles, esta fue la única que me dio resultado:

 

Ubicar el archivo src\PrestaShopBundle\Form\Admin\Type\CommonAbstractType.php

 

En el reemplazar la línea:

$new_list[$item[$mapping_name]] = $item[$mapping_value];

 

por:

 

$new_list[$item[$mapping_name].$item[$mapping_value]] = $item[$mapping_value];

 

Aparentemente de esta forma es posible que coexistan categorías con el mismo nombre pero con un único valor de referencia.

Hola, disculpa hice el cambio y me sigue dando error

Por otra parte la otra solucion que plantean de cambiar el archivo form.tpl: de la ubicacion adminXXXX/themes/default/template/controllers/products/helpers/form/
no lo puedo hacer por que no hay la carpeta Pe /products en mi instalacion

por favor me pudes ayudar?.

Share this post


Link to post
Share on other sites
On 23/3/2017 at 2:09 PM, coalval said:

Hola!

 

Tengo ese problema. Estoy con la versión 1.7.0.4.

¿No es posible solucionarlo sin tener que pasar a una versión anterior?
En otra cadena he leído que había que eliminar unas líneas del archivo:

 /adminXXXX/themes/default/template/controllers/products/helpers/form/form.tpl: https://github.com/P...m.tpl#L252-L254
Pero yo no tengo la carpeta /products así que no encuentro ese archivo.

 

¿Alguien me puede echar una mano?

Gracias!

HOla disculpa, pudiste soucionar y encontrar la carpeta /products? me pasa lo mismo que a ti, mi instalacion no hay esa carpeta

Share this post


Link to post
Share on other sites

Alguna solución, aumente el limte de de 5000 luego 15000 luego 3000000 y nada persiste el problema

Share this post


Link to post
Share on other sites

Hola,

 

El problema me parece que es por el exceso de carácteres en los campos de descripción corta y descripción.

Para aumentar los carácteres permitidos en la descripción corta, modificarlo en:

Parmámetros de la tienda > Configuración de productos > Tamaño máx. de la descripción corta (resumen) del producto

Un saludo,

Share this post


Link to post
Share on other sites

Si muchas gracias, eso ya lo cambié, da mas errores en la columna de nombre tampoco los coje bien y si pones ignorar columna nombre da errores garrafales con otros modulos y pasarela de pago y no funciona nada.

 

Share this post


Link to post
Share on other sites
On 2/13/2019 at 12:03 PM, soymultimedia said:

Hola,

 

El problema me parece que es por el exceso de carácteres en los campos de descripción corta y descripción.

Para aumentar los carácteres permitidos en la descripción corta, modificarlo en:

Parmámetros de la tienda > Configuración de productos > Tamaño máx. de la descripción corta (resumen) del producto

Un saludo,

Esto a mi me ha funcionado! Actualizaba el producto y decía guardado pero no actualizaba. Indicándole un límite de caracteres parece que funciona. Es una 1.7 algo antigua.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More