Jump to content
Sign in to follow this  
cankil

Photos produits non indexées par google[ RESOLU]

Recommended Posts

Bonjour,

Mon site est en ligne depuis le 24/04/2010 et je me rend compte aujourd'hui que les photos de mes produits ne sont toujours pas indexés, je n'ai aucune photos qui apparait dans google images. J'ai cherché dans le forum mais je n'ai pas trouvé de réponse.
Est-il possible que le problème vienne de mon fichier robots.txt ?
Est-ce que cette ligne en serait responsable: Disallow: /images.inc.php ????

Pouvez vous me dire d'ou vient le problème et comment le résoudre?

Merci

Share this post


Link to post
Share on other sites

Bonjour,
oui je pense que l'exclusion d'une page Disallow: /images.inc.php qui pose ce probleme de User-agent de google Googlebot salut.

Share this post


Link to post
Share on other sites

Merci pour cette réponse rapide.

J'ai supprimer la ligne en question du fichier robots.txt.

Sais-tu combien de temps il va falloir pour que les photos réapparaissent sur google images si le problème vient bien de là?

Share this post


Link to post
Share on other sites

ajout les 2 lignes Specific Special Bots :

User-agent: googlebot-image
Disallow: 



et il faut emp de temp.

Share this post


Link to post
Share on other sites

A quel niveau exactement je place cette ligne dans mon fichier robots.txt?

Share this post


Link to post
Share on other sites

je t'explique tu fais comme tu veux mais:

- User-agent: et Disallow: ne peuvent pas se trouver sur la même ligne.

- il est obligatoire de mettre une ligne vide entre des séries de directives successives concernant des
user-agents différents.

salut.

Share this post


Link to post
Share on other sites

J'ai bien compris mais je voulais juste savoir a quel niveau je devais insèrer cette partie dans le fichier robots.txt.

Merci.

Share this post


Link to post
Share on other sites

Ok, merci pour ton aide, J'ai plus qu'à attendre ...

Share this post


Link to post
Share on other sites

Bonjour,

Malgré la rectification du fichier robots.txt, je n'ai toujours aucune image d'indexée dans les moteurs, le site est en ligne depuis le 24/04/10.

Est-ce que quelqu'un aurait une autre idée?

Merci

Share this post


Link to post
Share on other sites

Bonjour,

un peu de patience...

Ce n'est pas en 2 jours que tes images seront indexées,
il faut laisser le temps que les robots passent sur ton site.

Share this post


Link to post
Share on other sites

Voici mon fichier robots.txt

Pouvez-vous me dire s'il vous semble correct?

Merci.

User-agent: *
# Directories
Disallow: /modules
Disallow: /config
Disallow: /download
Disallow: /mails
Disallow: /translations
Disallow: /tools
# Files
Disallow: /addresses.php
Disallow: /address.php
Disallow: /cart.php
Disallow: /footer.php
Disallow: /get-file.php
Disallow: /header.php
Disallow: /history.php
Disallow: /identity.php
Disallow: /init.php
Disallow: /n
Disallow: /?
Disallow: /order.php
Disallow: /orderby
Disallow: /order-slip.php
Disallow: /order-detail.php
Disallow: /order-follow.php
Disallow: /order-return.php
Disallow: /order-confirmation.php
Disallow: /orderway
Disallow: /pagination.php
Disallow: /password.php
Disallow: /pdf-invoice.php
Disallow: /pdf-order-return.php
Disallow: /pdf-order-slip.php
Disallow: /product-sort.php
Disallow: /statistics.php

User-agent: googlebot-image
Disallow:

Allow: /*

Share this post


Link to post
Share on other sites

Bonjour,

Ton fichier est correct.

Tu peux également indiquer l'adresse de ton sitemap avec une ligne

sitemap : http://www.monsite.com/sitemap.xml

Le robots txt peut également servir à bannir les robots indésirables ( bad bots ) avec la commande disallow ( interdire )


Cordialement

Ann

Share this post


Link to post
Share on other sites

Bonjour,

Plus d'un mois que j'attends et toujours aucune photo d'indexée. Par contre les photos des produits quand le site était sous oscommerce apparaissent bien, maintenant qu'il tourne avec prestashop, plus aucune image ne s'indexe. Je n'ai que les images du Bloc logo de paiement qui sont indexées.

Est-ce que quelqu'un aurait une idée?

Share this post


Link to post
Share on other sites
User-agent: googlebot-image
Disallow:


Excuse moi mais cette ligne empêche les indexations des images par Google, bref le contraire de ce que tu veux.

Je te suggère d'enlever toutes tes lignes du fichier robots.txt, c'est inutile.

Share this post


Link to post
Share on other sites

La syntaxe est bonne, essaie de faire quelques liens sur des images, ça peut aider.
Le "allow:" à la fin n'a pas d'utilité.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More