Jump to content
gh0stshell

HHVM & Prestashop

Recommended Posts

Created a new site and it runs on HHVM. When I upload prestashop and get to the last step it always fails at creating file something and never gets past 0%. If I choose another PHP version like Fast CGI etc... the install goes through just fine. I would like to use HHVM like all the other sites are using and working fine on my server.

 

Prestashop = 1.7.1/1.7.2

HHVM 3.15.3

Apache 2.2

 

If I install using a working version of PHP and then switch to HHVM the site works, but once a customer logs in the logout stops working unless they clear their cookies which an annoyance to log out of a site.

Edited by gh0stshell (see edit history)

Share this post


Link to post
Share on other sites

There are two types of servers in HHVM: FastCGI and Proxygen. In the first case, we see a standard usage similar to nginx + php-fastcgi. HHVM runs independently of web servers (apache, nginx and others). In the second embodiment, the HHVM virtual machine has a built-in full-fledged web server that allows it to receive requests directly, excluding an intermediate web server (for example, nginx).

Hope this helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More