Jump to content
MrChutney

Thème incompatible avec PrestaShop 1.7

Recommended Posts

Bonjour à tous,

 

Je commence tout juste à me mettre à Prestashop. Pas de souci pendant l'installation de la version 1.7. 

 

Le problème est quand j'essaie de créer un thème perso : 

 

- Je me connecte bien à l'admin

- J'exporte le thème actif "classic" 

- Je dézipe. Je modifie le nom du dossier et le nom du thème dans le config/theme.yml.

- Je zip le tout.

- Je clique sur ajouter un thème j'envoie le zip et là erreur : 

 

Ce thème n'est pas compatible avec PrestaShop 1.7

 

 

config/theme.yml

name: classic2
display_name: Classic2
version: 1.0.0
author:
  name: "PrestaShop Team"
  email: "pub@prestashop.com"
  url: "http://www.prestashop.com"

meta:
  compatibility:
      from: 1.7.0.0
      to: ~
 

Je ne vois pas du tout où serait le souci et je n'ai pas trouvé d'explication à ce sujet dans la doc mis à part l'utilisation d'un "Starter theme" mais aucune explication là-dessus.

 

Y a-t-il quelqu'un pour m'aider ?

 

Merci

 

Share this post


Link to post
Share on other sites

Regarde bien comment est fait le zip :) ne zip pas le dossier mais bien tous les dossiers

 

Jamais eu de réponse de la Team Presta la bas ... ne perd pas ton temps 

 

Comme sur les sujet fait par la Team presta d'ailleurs ...

Edited by okom3pom (see edit history)

Share this post


Link to post
Share on other sites

Salut Okom3pom,

 

Je ne peux pas suivre tous les sujets du forum (j'aimerai). Je te l'ai dit plusieurs fois, si je ne réponds pas, tu peux me pinguer en m'envoyant un message privé. Je le relaie ta question à l'équipe ensuite. :)

 

Merci.

Share this post


Link to post
Share on other sites

Merci pour vos réponses.
- Dans mon_prestashop/themes je n'ai (mis à part des fichiers comme .htaccess, core.js,..) qu'un dossier nommé "classic" qui est donc le thème par défaut. C'est celui là que j'ai essayé de dupliquer sans réussite.
 
- Maintenant je viens d'essayer avec le Starter thème, suivi les instructions d'installation.

Mais lorsque je lance le npm install pour les nodes_modules, la plupart s'installent bien, sauf pour quelques un ou j'ai des erreurs. 

(Je pense que ça vient du fait qu'il faille que je lance mes commandes "node" et "npm" précédé de "sudo" car sinon je n'ai pas les droits d'accès à local/bin.)

 

Jai quand même essayé de l'importer, sur un malentendu ça peut marcher, mais là encore, le même message :  Ce  thème n'est pas compatible avec PrestaShop 1.7.

 

 

nouveauTheme/_dev/npm-debug.log

52922 verbose pkgid node-sass@3.13.0
52923 verbose cwd /Applications/MAMP/htdocs/test_prestashop/themes/StarterTheme/_dev
52924 error Darwin 16.1.0
52925 error argv "/usr/local/bin/node" "/usr/local/bin/npm" "install"
52926 error node v7.2.1
52927 error npm  v3.10.10
52928 error file sh
52929 error code ELIFECYCLE
52930 error errno ENOENT
52931 error syscall spawn
52932 error node-sass@3.13.0 install: `node scripts/install.js`
52932 error spawn ENOENT
52933 error Failed at the node-sass@3.13.0 install script 'node scripts/install.js'.
52933 error Make sure you have the latest version of node.js and npm installed.
52933 error If you do, this is most likely a problem with the node-sass package,
52933 error not with npm itself.
52933 error Tell the author that this fails on your system:
52933 error     node scripts/install.js
52933 error You can get information on how to open an issue for this project with:
52933 error     npm bugs node-sass
52933 error Or if that isn't available, you can get their info via:
52933 error     npm owner ls node-sass
52933 error There is likely additional logging output above.
52934 verbose exit [ 1, true ]

Share this post


Link to post
Share on other sites

Dans mon_prestashop/themes je n'ai (mis à part des fichiers comme .htaccess, core.js,..) qu'un dossier nommé "classic" qui est donc le thème par défaut. 

 

 

 

Ne met pas de dossier classic 

 

Un dossierX tu rentres dedans tu sélectionnes tout et tu zippes. 

 

 

https://www.okom3pom.com/poups/themes/okom3pom.zip

Edited by okom3pom (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Bonjour

 

J'ai un gros probleme avec prestashop.

J'ai installé le theme electrolux, livré avec les modules JX dev by zemez.

le module megamenu ne fonctionnant pas j'ai opté pour sa réinstallation, ca n'a pas fonctionné, ni via l'admin en réimportant le dossier du module, ni via FTP, je ne le vois plus du tout sur l'admin prestasho

 

Du cou je me dis je désinstalle le thème et le réinstalle. pareil là il me dit votre thème n'est pas compatible ! bizarre hier ca fonctionnait !!!

 

aidez moi !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More