Jump to content
GuillaumeGD

"Accès refusé pour l'utilisateur" SQLSTATE[HY000] [1044] - Instal en local

Recommended Posts

Bonjour à tous,

 

J'essaie de reprendre un prestashop en local, d'un ancien webdesigner de ma boite. J'ai donc téléchargé les fichiers via Filezilla, je les ai mis dans le dossier "www" de Wamp et j'ai cré une base de donnée sur PhpMyAdmin.

Cependant, quand je veux me connecter en local à mon Presta j'ai le message suivant :

" Link to database cannot be established: SQLSTATE[HY000] [1044] Accès refusé pour l'utilisateur: '****'@'@localhost'. Base 'nomdelabase' "

 

J'ai vérifié dans mon fichier "settings.inc.php" mais le nom d'utilisateur est bien le bon (il faut créer l'utilisateur sur PhpMyAdmin n'est-ce pas? Y a t-il des réglages spécifiques?), le nom de la base est bon aussi; j'ai essayé avec et sans mdp mais pas de différence.

 

Merci par avance !

Cordialement,

 

Guillaume

Share this post


Link to post
Share on other sites

Bonjour

 

En local avec wamp sous windows, il n'y a pas de login ni de mot de passe pour accéder à la base de donnée, juste serveur de la base de donnée localhost nom de la base 

et login et mot de passe vous laissez vide

 

En local sur votre poste s'il est bien  protéger, personne viendras fouiller dans votre base de donnée, de plus avec wamp elle n'est pas active en permanence.

Share this post


Link to post
Share on other sites

Bonjour

 

En local avec wamp sous windows, il n'y a pas de login ni de mot de passe pour accéder à la base de donnée, juste serveur de la base de donnée localhost nom de la base 

et login et mot de passe vous laissez vide

 

En local sur votre poste s'il est bien  protéger, personne viendras fouiller dans votre base de donnée, de plus avec wamp elle n'est pas active en permanence.

 

Merci de votre réponse, mais j'ai oublié de préciser ceci :

Voilà ce que ça me dit quand j'efface l'utilisateur et le mdp :

"Link to database cannot be established: SQLSTATE[HY000] [1045] Accès refusé pour l'utilisateur: ''@'@localhost' (mot de passe: NON)"

 

et quand je supprime les lignes (utilisateur et mdp) :

"Link to database cannot be established: SQLSTATE[HY000] [1045] Accès refusé pour l'utilisateur: '_DB_USER_'@'@localhost' (mot de passe: OUI)"

Edited by GuillaumeGD (see edit history)

Share this post


Link to post
Share on other sites

Bonjour

 

En local avec wamp sous windows, il n'y a pas de login ni de mot de passe pour accéder à la base de donnée, juste serveur de la base de donnée localhost nom de la base 

et login et mot de passe vous laissez vide

 

En local sur votre poste s'il est bien  protéger, personne viendras fouiller dans votre base de donnée, de plus avec wamp elle n'est pas active en permanence.

erreur, s'il n'y en en effet pas de mot de passe, le login est quant à lui root !

Share this post


Link to post
Share on other sites

erreur, s'il n'y en en effet pas de mot de passe, le login est quant à lui root !

Exact j'ai omis mea culpa

Share this post


Link to post
Share on other sites

erreur, s'il n'y en en effet pas de mot de passe, le login est quant à lui root !

 

Merci pour vos réponses, quand j'utilise root j'ai une erreur (voir ci joint) en utilisant IE; mais en utilisant Mozilla par exemple j'ai une page vide... sans erreur ni rien, juste vide.

Alors que je n'ai touché à aucun autre fichier que "settings.inc".

 

post-1307489-0-71017600-1481098346_thumb.jpg

 

Je comprends vraiment pas ce qui peut bloquer autant... Y a t-il des fichier qu'il faut absolument pour l'installation? (Que l'ancien graphiste aurait supprimé).

 

Merci

Share this post


Link to post
Share on other sites

Bonjour

 

Ce n'est pas http://localhost/nomde la base/ en fait je ne sais pas à quoi correspond cela

L'emplacement des fichiers et dossiers c'est par défaut http://localhost/ ou si dans un dossier http://localhost/nomdudossier

 

Pour la base de donnée pour y accéder via phpmyadmin c'est  http://localhost/phpmyadmin/

et là normalement par défaut vous y arrivez directement dans l'interface qui permet de lire la base de donnée

 

Extrait du setting.inc.php

 

define('_MYSQL_ENGINE_', 'InnoDB');
define('_DB_SERVER_', 'localhost');
define('_DB_USER_', 'root');

define('_DB_PREFIX_', 'ps_');
define('_DB_PASSWD_', '');
define('_DB_TYPE_', 'MySQL');

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More