Jump to content
Pathandel

E-Mail Benachrichtigung bei neuen Bestellungen?

Recommended Posts

Hallo!

Wo oder wie kann ich einstellen das wenn eine Bestellung (oder neuer Kunde) eingegangen ist ich eine Benachrichtigung bekomme per mai.

 

Danke

Share this post


Link to post
Share on other sites

Die Einstellung wurde ziemlich gut im Modul E-Mail-Mitteilungen / Mailalerts versteckt.

Share this post


Link to post
Share on other sites

So Danke für die Antwort aber irgendwie bin ich zu blöd das Modul zu finden.

 Welche PS-Version?

Share this post


Link to post
Share on other sites

Backoffice -->Module -->Module und dann im Suchfeld "mailalerts" eintippen

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites

Ja, mal die zahlreichen Threads zu diesem Thema durchlesen. Ansonsten Prestashop-Version nennen, funktioniert Testmail, kommen andere Mails an?

Share this post


Link to post
Share on other sites

Hallo,

also ich habe das hier mal so in meinem Shop übernommen und die Einstellungen gemacht. Doch leider bekomme ich keine E-Mail Benachrichtigung, wenn eine neuen Bestellung reinkommt. Woran könnte es noch liegen?

 

Benutze Prestashop Version 1.6.1.11

 

LG Fredolin

Share this post


Link to post
Share on other sites

Da du nicht schreibst, was du gemacht oder geprüft hast, können wir auch nicht wissen, was du vielleicht nicht gemacht oder geprüft hast ...

Share this post


Link to post
Share on other sites

ich mach jetzt noch einen Kristallkugelshop auf... :D

 

kann doch nicht so schwer sein, die E-Mail-Adresse unten im kasten einzutragen, wo die Mails hinsollen, dann noch im Bereich der Maileinstellungen testen, ob der Shop Mails versendet, das sollte es dann gewesen sein.

Share this post


Link to post
Share on other sites

Na, die Vorlagen müssen auch an der richtigen Stelle sein (genau daran hat's ja wohl meist gehakt).

Share this post


Link to post
Share on other sites

Also erstmal danke an alle.

 

Bei mir hat das alles nicht funktioniert aber heute oh wie ein Wunder alles gut.

Ohne update auf neue Version zeigt er mir in Module tatsächlich "mailallerts" an - was er vorher nicht tat.

Ich bin also doch nicht blöd.

Konnte jetzt auch endlich meine Telefonnummer im Header tauschen auch hier seit heute Einstellungen möglich.

Share this post


Link to post
Share on other sites

Hallo ihr lieben,

dieses Thema ist jetzt schon ein bisschen älter. Aber ich habe auch das Problem, dass ich keine email bei einer Bestellung bekomme.

Und ich habe auch gleich mal nach diesem Modul geschaut. Das hab ich gar nicht?!

 

Ich habe jetzt die Version 1.6.1.15

 

Im Dashbord kann ich zwar meine Kontaktdaten angeben, habe auch meine email Adresse eingegeben aber ich bekomme keine email?!

Da habe ich nun alles durchforstet und nach allem geschaut was mit email und Benachtigung zu tun hat. Aber nix gefunden!

 

Weiß vielleicht einer mehr?

Share this post


Link to post
Share on other sites

Und du hst das Modul "mailalerts" installiert und eingerichtet?

 

Grüsse

Whiley

Share this post


Link to post
Share on other sites
Und ich habe auch gleich mal nach diesem Modul geschaut. Das hab ich gar nicht?!

 

 

Beitrag #6  : Backoffice -->Module -->Module und dann im Suchfeld "mailalerts" eintippen

 

 

Aber ich habe auch das Problem, dass ich keine email bei einer Bestellung bekomme.

 

was steht unter Verwaltung / Voreinstellungen  unten unter Nachrichten?

 

unter Erweiterte Einstellungen unten Test Email senden

 

 

Ich habe jetzt die Version 1.6.1.15

 

schön

 

 

Im Dashbord kann ich zwar meine Kontaktdaten angeben, habe auch meine email Adresse eingegeben aber ich bekomme keine email?!

 

Verwaltung / Benutzerrechte / Bearbeiten

Share this post


Link to post
Share on other sites

Und du hst das Modul "mailalerts" installiert und eingerichtet?

 

Grüsse

Whiley

Ich habe dieses modul nicht, zumindest wird mir nix anggezeigt wenn ich mailalerts in die suche eingebe.

Share this post


Link to post
Share on other sites

Hallo ihr lieben,

hab noch kleinigkeiten die ich machen muss.

 

Ich habe gerade gesehen das bei meinem mailalert modul ein gelbes dreieck mit ! zu sehen ist. Ist das immer da?

 

Bin gerade dabei das auch in der email die bilder angezeigt werden, weiß jedoch nicht wie ich das anstellen soll.....

 

Habt ihr eine idee?

 

Ich sag schon mal vielen lieben dank und einen sonnigen Tag!

Share this post


Link to post
Share on other sites

Ich seh gerade, das ist nicht was ich meine.

 

Wenn jemand eine bestellung macht, dann bekomme ich die email, jedoch ohne artikelbild und was es für ein artikel ist. Ich bekomme nur die summe...

Share this post


Link to post
Share on other sites

Theoretisch müsstest du die Mail Vorlagen vergleichen. Ist in irgendeiner Mail ein Bild des Produktes?

Den Code müsstest du dann auch in die mailalerts Vorlage packen können. Sollte so auf jeden Fall mit der Produktbeschreibung usw. klappen.

Mit dem Bild natürlich auch, ich weiß gerade nur nicht ob in irgendeine Mail das Produktbild gepackt wird.

Share this post


Link to post
Share on other sites

Ich kann ein screen von der email machen die ich bekomme wenn eine bestellung eingegangen ist. Moment, dauert ein bisschen. Bin gerade vom tablet aus hier.

Share this post


Link to post
Share on other sites

Also ich habe aus der Bestätigungsmail für uns einen Laufzettel gemacht. Da habe ich alles eingebaut was ich kriegen konnte.

Preise usw. raus, interessiert hier im Arbeitsablauf nicht aber dafür die Varianten der Produkte sauber aufgelistet und sowas.

Also möglich ist es, du musst dir halt nur bei bestehenden Mails die Variablen klauen.

Share this post


Link to post
Share on other sites

Ich habe jetzt mal 2 Screens gemacht.

Eines was ich bekomme... Da hab ich jetzt gesehen, dass der Artikel als Wort mit Link angezeigt wird (hab ich wohl übersehen)

 

http://www.karins-servietten.de/artikel_nur_als_link.jpg

 

Ich glaube das reicht dann! Muss ich wohl nicht noch basteln!

 

und eins was der Kunde bekommt.

 

http://www.karins-servietten.de/artikel_fehlen.jpg

 

Tha, was ich hier mache weiß ich nicht! Entweder begügen die sich damit, keine Ahnung!

Share this post


Link to post
Share on other sites

Bei der Mail an den Kunden fehlt aber tatsächlich was. Da müsste zumindest stehen welcher Artikel es ist.

Hast du daran auch etwas gemacht? Ansonsten mal eine neue Presta Version laden und da die Vorlage raus nehmen und mit deiner ersetzen.

Share this post


Link to post
Share on other sites

Bei der Mail an den Kunden fehlt aber tatsächlich was. Da müsste zumindest stehen welcher Artikel es ist.

Hast du daran auch etwas gemacht? Ansonsten mal eine neue Presta Version laden und da die Vorlage raus nehmen und mit deiner ersetzen.

 

 

Nö, gemacht hab ich da nix, zumindest wüsste ich das nicht?! Oder hab ich was vergessen. Muss ich denn diese Variablen bearbeiten? Ich hab keine Ahnung...?! :wacko::blink:

 

Ich weiß jetzt nicht was du meinst mit einer neuen Presta Version. ich hatte zu Anfang den 1.7, ..  Dann hat man mir davon abgeraten, und nu bin ich hier. Der andere Flohmarkt war aber auch schon fertig. Nochmal die Arbeit ne... Sorry, ich habe zwar Zeit, aber dreimal ist glaube ich auch für mich zuviel! :mellow:

 

wenn ich mich im Dashbord eingeloggt habe und die Bestellung sehe, ist auch ein Bild drin...

 

http://www.karins-servietten.de/in_Bestellung_drin.png

 

 

Edited by butterblume (see edit history)

Share this post


Link to post
Share on other sites

Normalerweise müßte in der E-Mail an den Kunden ja die Artikelauflistung stehen, entweder hast du etwas geändert oder es sind Dateien irgendwie beschädigt worden oder fehlen. Deshalb solltest du nach den Originaldateien schauen, entweder im Installationsarchiv oder in einer nach der Installation angefertigten Sicherheitskopie aller Dateien.

Share this post


Link to post
Share on other sites

Genau, neu machen musst du garnichts. Wenn das die Originalversion der Mail ist dann ist da was defekt.

Wenn du 1.6 benutzt, kannst du davon die neueste Version runterladen und dir aus dem zip Archiv nur diese Mail Vorlage nehmen und deine damit ersetzen.

Du musst den Shop nicht installieren und ganichts. Nur in den Ordner gehen in dem sich bei dir die Mail Vorlage befindet und dann die neue verwenden und danach mit einer Testbestellung gucken ob alles drin ist.

 

Das Problem ist das dein Kunde jetzt nicht sieht was er bestellt hat. Da ist das Bild an sich zweitrangig aber bei dir steht ja garnichts.

Er sieht nur den Preis und gerade bei mehreren bestellten Artikeln sieht er dann nur den Endpreis und nicht was die einzelnen Positionen kosten, geschweige denn was die einzelnen Positionen sind.

Share this post


Link to post
Share on other sites

Im Ordner themes/DeinTheme/mails/de sollten sich die Dateien order_conf.html und order_conf_product_list.tpl finden (Voraussetzung du schickst HTML-Mails). Die order_conf.html muß unterhalb des Tabellenkopfes "{products}" enthalten.

 

Eigentlich solltest du die Installations-ZIP von Prestashop noch haben, ansonsten kannst du die verschiedenen Versionen unter https://www.prestashop.com/de/vorgaengerversionen laden.

Share this post


Link to post
Share on other sites

Hallo christian,

Erst einmal vielen dank.

 

Ich versuche es mal. Habe mir die 1.6.1.16 runter geladen. Wenn ichs nicht hinbekomme melde ich mich nochmal!

 

Wünsche erst einmal einen schönen abend

Ich habe das von meinem anbieter, da war keine zip datei.... das wurde direkt auf den server installiert!

Share this post


Link to post
Share on other sites

Ich habe das von meinem anbieter, da war keine zip datei.... das wurde direkt auf den server installiert!

Das erste, was man dann macht, ist eine Kopie aller Dateien auf die Festplatte ziehen als Sicherung.

Share this post


Link to post
Share on other sites

Guten Morgen,

 

hast du denn mal in deinem installierten Shop geguckt ob du die angegebenen Dateien findest? Genau da müssten die auch in der Zip Datei sein.

Denk dann aber dran deine um zu benennen damit du "das original" noch hast falls irgendetwas schief geht.

 

Also ich schreibe im FTP Programm einfach immer original hinter die Datei. Dann kann diese nicht mehr erkannt werden und ich kann die neue platzieren ohne das die alte weg ist.

Share this post


Link to post
Share on other sites

Guten Morgen,

 

hast du denn mal in deinem installierten Shop geguckt ob du die angegebenen Dateien findest? Genau da müssten die auch in der Zip Datei sein.

Denk dann aber dran deine um zu benennen damit du "das original" noch hast falls irgendetwas schief geht.

 

Also ich schreibe im FTP Programm einfach immer original hinter die Datei. Dann kann diese nicht mehr erkannt werden und ich kann die neue platzieren ohne das die alte weg ist.

 

Guten morgen,

nein ich hab noch nicht geguckt. Mache ich nachher wenn ich mehr Zeit habe!

Share this post


Link to post
Share on other sites

Im Ordner themes/DeinTheme/mails/de sollten sich die Dateien order_conf.html und order_conf_product_list.tpl finden (Voraussetzung du schickst HTML-Mails). Die order_conf.html muß unterhalb des Tabellenkopfes "{products}" enthalten.

 

Eigentlich solltest du die Installations-ZIP von Prestashop noch haben, ansonsten kannst du die verschiedenen Versionen unter https://www.prestashop.com/de/vorgaengerversionen laden.

 

 

 

Ich habe jetzt mal die Zip entpackt und nachgesehen. Im Ordner themes she ich nur dies hier. Aber auch nicht mein Themes

 

http://www.karins-servietten.de/1.png

 

Mehr sehe ich da net!

 

Entweder bin ich blind oder zu dämlich! Vermutlich letzteres :D

Edited by butterblume (see edit history)

Share this post


Link to post
Share on other sites

Ja, default-bootstrap ist das mitgelieferte Theme, öffne diesen Ordner/mails/de. Wenn du ein anderes Theme verwendest, mußt du die Dateien evtl. in den Ordner dieses Themes/mails/de kopieren.

Share this post


Link to post
Share on other sites

Hallo chrisitan,

erst einmal vielen dank, dann versuch ich es nachher nochmal! Bin jetzt erst einmal weg!

Wünsche einen schönen tag!

Share this post


Link to post
Share on other sites

Hallo Chrisitan,

ich habe das na ein bisschen suchen endlich gefunden und in den Ordner kopiert. Beim hoch laden ist mir aufgefallen, das eine Datei gefehlt hatte. Nun werde ich mal eine Testbestellung machen und sehen ob sich was getan hat!

 

 

Hat alles funktioniert. Es ist zwar jetzt keine Grafik aber zumindest der Titel des Artikels

 

Hier alt

 

http://www.karins-servietten.de/alt.png

 

und hier neu

 

http://www.karins-servietten.de/neu.png

 

Ich sag vielen Dank für eure Hilfe!

 

Hatte schon befürchtet, dass ich es nicht hinbekomme. Der Flohmarkt hat ja nun doch ein paar mehr Datein und Ordner!

Edited by butterblume (see edit history)

Share this post


Link to post
Share on other sites

Das ist doch gut.

Grafiken sind da auch nicht vorgesehen da viele die Rechnungen ausdrucken. Und aus Platzgründen. Wenn du es trotzdem unbedingt willst müsste man gucken wo man sich den Code her nehmen kann. Sehe ic haber nicht als wichtig...

Share this post


Link to post
Share on other sites

Hallo,

 

kann es sein dass es das Modul "mailalerts" in der aktuellen Version 1.6.1.17 nicht mehr gibt? Finde es nirgends. Egal ob unter mailalerts, Mail-Benachrichtigung oder sonst einem Begriff.

 

Wäre über eine kurze Rückantwort sehr dankbar.

 

Grüße

 

Paddy

Share this post


Link to post
Share on other sites

Hi Cully,

 

danke für die mega schnelle Rückantwort.

 

Leider findet es Mail - Benachrichtigungen v3.6.1 bei mir auch nicht. :(

 

Hatte Prestashop 1.6.1.17 frisch installiert, also ohne update von einer vorherigen Version etc..

 

Bei mir gibt es da nur dann nur als Modul Auswahl Benachrichtigung brower-tab (Favicon).

 

Als separater Download finde ich das Modul auch so nirgends.

 

Grüße

 

Paddy

Share this post


Link to post
Share on other sites

Hallo Paddy,

Gerade geprüft - Du hast Recht. Im Archivfile ist das Modul nicht mehr enthalten.

Angehängtes ZIP entpacken und dann den Inhalt in das Verzeichis ./modules hochladen.

 

mailalerts.zip

  • Like 1

Share this post


Link to post
Share on other sites

Hallo Scully,

 

top! Hat geklappt und das Modul funktioniert! Vielen, vielen Dank für die schnelle Hilfe. Weltklasse!!

 

Grüße

 

Patrick

  • Like 1

Share this post


Link to post
Share on other sites
On 4/27/2017 at 12:25 AM, rictools said:

Na, die Vorlagen müssen auch an der richtigen Stelle sein (genau daran hat's ja wohl meist gehakt).

Hallo Zusammen,

wir haben gerade das gleiche Problem und da die bisher gefundenen Lösungsansätze keinen Erfolg ergaben, eröffene ich das alte Thema gerade wieder, mit der Hoffnung etwas übersehen zu haben und doch einer die Nadel im Heuhaufen finden kann.

Kurz zum System:
Prestashop V. 1.6.1.17
E-Mail-Benachrichtigungen V. 3.7.0
PHP 5.6 FPM

 

Folgendes Problem besteht bei uns:

Bei einer Bestellung erhält der Shop Admin/Verwalter keine E-Mail Benachrichtigung, über eine Bestellung die im Shop getätigt wurde.

Folgende E-Mails kommen an:
- Nachrichten die über das Kontaktformular versendet wurden.
- Der User/Kunde der im Shop bestellt bekommt jeweils eine E-Mail zu Bestellbestätigung und die Infos zur Zahlungsart.
- Über das Backend "Erweiterte Einstellungen" -> "Test Ihrer E-Mail-Einstellungen " funktioniert der Test E-Mail Versand auch ohne fehler.

Das Presta Modul "E-Mail-Benachrichtigungen" ist unter dem Punkt "Händler-Benachrichtigungen" wie folgt eingestellt:
Neue Bestellung "Ja" (diese E-Mail werden laut Provider nicht versendet.)
Nicht auf Lager  "Ja" (diese E-Mail kommen an.)

Das Feld  E-Mail-Adressen ist auch mit einer E-Mail Adresse befüllt.

Laut unserem Provider werden vom System aus keine E-Mails zu neuen Bestellungen verschickt:
"... Server Logs angesehen und konnte feststellen dass Ihr Shop diese zusätzlichen Emails überhaupt nicht an den sendmail Dienst des Servers übergibt.
Es schein also ein Problem im Shop selbst zu sein, dass die entsprechenden Emails nicht erzeugt werden."

Ich hoffe das Problem mit allen nötigen Infos beschrieben zu haben und sag schonmal Danke für eure Hilfe.

 

Achja wieso ich den Quote auf @rictools gemacht hab, evtl. liegt bei uns auch da das Problem.

Wir haben zwar den Inhalt des Ordners "/prestashop/mails/de" in das Verzeichnis "/prestashop/themes/theme1040/mails/de" kopiert, aber leider ohne Erfolg.

Müssen wir da evtl. etwas anderes kopieren? oder an einer anderen Stelle?

Vielen Dank

Share this post


Link to post
Share on other sites

Hallo und vielen Dank schonmal für die Hilfe.

Im EN Ordner "/prestashop/mails/en" liegen 75 Datein. Unter "/prestashop/mails/de" sind es 83.

folgende Dateien liegen zusätzlich im DE Ordner:

footer.html + .txt
header.html + .txt
header_order_conf.html + .txt
import.html + .txt

Wenn ich die mit der Zip Datei aus "https://www.prestashop.com/de/vorgaengerversionen" vergleiche fehlen keine, es sind nur einpaar zusätliche, wie die erwähnten, in dem DE Ordner.

Der Inhalt zu " /prestashop/themes/theme1040/mails/de " ist identisch, da wir diese ja selbst in dem Theme Ordner kopiert haben.

Welche HTML+txt Datei wäre denn für diese Benachrichtigung?

Vielen Dank

Share this post


Link to post
Share on other sites

Die Mail für die Benachrichtung über eine neue Bestellung ist bei den 1.7er Shops:

/modules/ps_emailalerts/mails/de/new_order.html

Welche genau es bei 1.6 ist kann ich nicht sagen aber vielleicht ist das ja auch ein eigenständiges Modul.

Share this post


Link to post
Share on other sites

Dafür ist ja das Modul mailalerts ( E-Mail-Benachrichtigungen V. 3.7.0 ).

"modules\mailalerts\mails\de" als auch der "en" Ordner haben eine new_order.html.

Wie beschrieben, ist im Heuhaufen nach einer Nadel suchen...

Share this post


Link to post
Share on other sites

Ganz blöd gefragt, update und/oder neuinstallation schon gemacht?

Wenn du die new_order.html auf macht ist da auch was drin oder ist die Datei evtl. defekt?

Ansonsten mal eine ältere Version installiert? Ist da genau das gleiche Problem?

Share this post


Link to post
Share on other sites

Update oder Neuinstallation ist bisher nicht gemacht worden.
Ist ein Shop der Live ist und muss dann erst einiges gemacht werden.

1 hour ago, Shad86 said:

Wenn du die new_order.html auf macht ist da auch was drin oder ist die Datei evtl. defekt?

Dachte ich auch erst, aber die Dateien lassen sich ganz normal öffnen und hab die Inhalte des Moduls mit der Zip Datei von Scully überprüft und keinen Fehler im Modul gefunden.

Vielen Dank

Share this post


Link to post
Share on other sites

Also Update und Neuinstallation des Moduls natürlich. Nicht vom Shop. Wenn das Modul gerade eh nicht richtig geht kannst du das ja neu installieren ohne das der Kunde etwas mitbekommt. Mach trotzdem vorher ein Backup für alle Fälle.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More