Jump to content
Sign in to follow this  
lylyka

pb de lien entre base de donnees hebergeur (ovh) et prestashop resolu

Recommended Posts

bonjour,

j'ai eu un petit soucis comme certain d'entre vous avec mon login sur l'admin de prestashop. Je l'ai deconnecte et il ne veut plus reconnaitre mes identifiants.
A partir de là j'ai voulu acceder à ma bdd pour faire la modification interne dans 'ps_employe' mais je me suis aperçu que ma boutique s'etait installe sans phpadmin (celui ci ne m'etait pas accessible)
j'ai donc exporté le sql et je l'ai remis dans un nouveau phpadmin sur mon serveur
seulement apres manip rien ne se passe. j'ai essayé le hash que vous indiquiez sur le forum avec la modif dans la bdd mais rien

je me demande donc si mon site communique bien avec la bdd ;)

sachant que mon arbo sur site est :
www/phpMyAdmin-3.3.3-all-languages pour le phpadmin
et que mes fichiers presta sont /www/PrestaShop
soit à côté mais dans un dossier... peut il y avoir un pb?

mon fichier config.inc.php s'appelle config.sample.inc.php est le suivant,( ai je fait une erreur? ) :

* cookie
*/
$cfg['blowfish_secret'] = ''; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */


$cfg['PmaAbsoluteUri'] = 'http://www.***.fr/phpMyAdmin-3.3.3-all-languages';


/*
* Servers configuration
*/
$i = 0;

/*
* First server
*/
$i++;
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = '[Edité - Divine]';
$cfg['Servers'][$i]['password'] = '[Edité - Divine]';
$cfg['Servers'][$i]['only_db'] = '[Edité - Divine]';
/* Server parameters */
$cfg['Servers'][$i]['host'] = 'mysql5-8.pro';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
/* Select mysqli if your server has it */
$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['Servers'][$i]['AllowNoPassword'] = false;

/* rajk - for blob[spam-filter] */
$cfg['Servers'][$i]['bs_garbage_threshold'] = 50;
$cfg['Servers'][$i]['bs_repository_threshold'] = '32M';
$cfg['Servers'][$i]['bs_temp_blob_timeout'] = 600;
$cfg['Servers'][$i]['bs_temp_log_threshold'] = '32M';

/* User for advanced features */
// $cfg['Servers'][$i]['controluser'] = 'pma';
// $cfg['Servers'][$i]['controlpass'] = 'pmapass';
/* Advanced phpMyAdmin features */
// $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
// $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
// $cfg['Servers'][$i]['relation'] = 'pma_relation';
// $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
// $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
// $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
// $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
// $cfg['Servers'][$i]['history'] = 'pma_history';
// $cfg['Servers'][$i]['tracking'] = 'pma_tracking';
// $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
/* Contrib / Swekey authentication */
// $cfg['Servers'][$i]['auth_swekey_config'] = '/etc/swekey-pma.conf';

/*
* End of servers configuration
*/

/*
* Directories for saving/loading files from server
*/
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';

?>


merci de votre aide sinon je devrais tout refaire... pffff ;)

Share this post


Link to post
Share on other sites

merci beaucoup pour votre reponse olecorre.
J'ai donc désinstaller le phpmyadmin en plus. J'ai toujours bien acces à ma bdd par le lien que vous m'avez donné et que j'avais déjà... seulement je ne suis pas convaincue que celle ci communique avec mon site...
Je n'arrive pas à débloquer mon acces au back office en changeant les mots de passe dans la bdd employé.

Que faire?

Share this post


Link to post
Share on other sites

Bonjour,

Est-ce que tu es sure que tu cryptes le mot de passe de la bonne façon ?

Share this post


Link to post
Share on other sites

bonjour,

merci encore pour toutes vos reponses mais j'ai enfin tout débog!
bon j'ai quand même perdu le contenu de mon site en parti et certains modules... je sais pas pourquoi mais j'ai retrouve mon back office et j'ai fait le lien entre site et bdd

j'avais mal renseigne mon setting.

merci encore

Share this post


Link to post
Share on other sites

Dans ce cas penses à ajouter [RESOLU] dans le titre de ton post :)

Share this post


Link to post
Share on other sites

Exact Thierry :)

Cela dit Lylyka tu devrais tout de même changer tes mots de passe pour plus de sécurité.

Share this post


Link to post
Share on other sites

Oui merci encore ! Je les ai changé quand j'ai recupéré les acces

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More