Jump to content
supermaguila

Error 500 al entrar al backoffice prestashop 1.7

Recommended Posts

Hola a todos, acabo de intalar prestashop 1.7, en una instalación limpia, la instalación se realiza correctamente ( he tenido que cambiar PHP a 7.09 en mi servidor, ya que no pasaba de 0%) y al terminar entra bien al fronoffice, pero al entrar al backoffice ( http://recambiosyalgomas.es/admin_access) me da error 500.

El _access se lo puse yo, ya que al trerminar la instalación no se renombro la carpeta sola.

Antes de renombrarla me daba error 404.

 

A ver si alguien me ayuda, me estoy volbiendo loco buscando por internet y no encuentro nada.

 

Gracias

Share this post


Link to post
Share on other sites

Bueno, he desinstalado el 1.7 y he vuelto a instalar el 1.6, ya que no habia manera de entrar al backoffice, mas adelante lo volveré a probar.

Share this post


Link to post
Share on other sites

Hola supermaguila, te comento que yo tuve el mismo inconveniente y lo pude solucionar pidiendole a mi hosting que permitiera el uso de MultiViews.

 

Espero te sea útil esta información.

 

Saludos!

 

Rodolfitus.

Share this post


Link to post
Share on other sites

Pues a mi me pasa lo mismo de o poder acceder al backoffice.

 

Como podria activar las multiviews ??

 

Primero revisa que en Preferencias > Tráfico > SEO y URLs la opción "Desactivar la opción Apache's MultiViews" esté en "No". Si aún así no está activado se lo puedes pedir al proveedor de alojamiento que lo active.

Share this post


Link to post
Share on other sites

Primero revisa que en Preferencias > Tráfico > SEO y URLs la opción "Desactivar la opción Apache's MultiViews" esté en "No". Si aún así no está activado se lo puedes pedir al proveedor de alojamiento que lo active.

si puediese entrar en el BO podría ver si funciona, pero es imposible acceder al BO   :(

Share this post


Link to post
Share on other sites

si puediese entrar en el BO podría ver si funciona, pero es imposible acceder al BO   :(

 

Siempre puedes consultar a tu proveedor de hosting si está activado o no. 

Share this post


Link to post
Share on other sites

Buenas tardes.

Acabo de instalar el prestashop para empezar a hacer pruebas y actualizar mi tienda existente y me consegui con el mismo problema de acceso al backoffice.

 

Error 500.

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@ophirfashion.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Comunique a mi proveedor de hosting la incidencia y miren la respuesta.

 

Estimado cliente:

en relación a su consulta, los errores 500 detectados derivaban del uso de la propiedad “Option MultiViews” en el fichero .htaccess.

Esta propiedad no esta permitida en hosting compartido.

Puede proceder a comentar la línea correspondiente en el fichero .htaccess y debería cargarle correctamente.

Un cordial saludo,

Piensa Solutions

 

Me consta que si se puede instalar Prestashop 1.7 en un hosting compartido porque conosco gente que lo tiene asi.

 

Ahora lo que quisiera ver es como solucionar lo que plantea en la respuesta el especialista sobre comentar la linea. Y si esto seria en el htaccess de la raiz?

 

Ya tengo un dia con esto y ya me estoy traumatizando.

 

Gracias al que pueda ayudarme.

Share this post


Link to post
Share on other sites

Hola,

 

El proveedor se lo ha explicado bastante claro. Tiene que editar el fichero .htaccess de la raíz de su instalación de Prestashop y verá una línea así:

Options -Multiviews

añádele un # al principio para comentarla:

# Options -Multiviews

Después intente cargar de nuevo el panel de control, no debería tener problemas.

 

Saludos.

  • Like 1

Share this post


Link to post
Share on other sites

Hola a todos:

 

Perdonad la pregunta pero no sé acceder al fichero .htaccess de la raíz de la instalación de Prestashop, tal y como sugiere w3bsolutions. ¿Me podéis indicar? Muchas gracias.

Share this post


Link to post
Share on other sites

Hola, 

en la versión 1.7 los menus desplegables no me aparecen de forma correcta, aparecen las opciones desplegadas pero no me deja seleccionar y por otro lado cuando realizo modificaciones en las paginas SEO y URL no se me guardan ni aparecen mensaje de erro.

Share this post


Link to post
Share on other sites
On 4/22/2020 at 3:06 PM, jorgecp said:

Hola, 

en la versión 1.7 los menus desplegables no me aparecen de forma correcta, aparecen las opciones desplegadas pero no me deja seleccionar y por otro lado cuando realizo modificaciones en las paginas SEO y URL no se me guardan ni aparecen mensaje de erro.

Hola a todos!! Mismo problema que JorgeCP. Alguna solución?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More