Jump to content
Helen58

Bijwerken Prestashop van 1.52 naar 1.6.1

Recommended Posts

Hallo iedereen,

 

Ik wil graag een 1- click upgrade gaan doen, maar zie dat je PHP 5.4 nodigt hebt.

Nu kan mijn webhosting mijn account verplaatsen naar een server met php 7/ mysql 5.6 

 

Mijn vraag is nu of ik eerst Presta moet bijwerken of eerst zorgen dat ik op php 7/mysql 5.6 draai.

 

 

Alvast bedankt,

 

Helen

 

p.s. heb nu presta 1.52 / php 5.3.29

 

 

 

 

Share this post


Link to post
Share on other sites

Dat is een hele logische vraag, ik weet niet of 1.52 draait op php 7. Bij de meeste hosters kan je echter in je PHP admin de versie tijdelijk op bv PHP 5.6 zetten, en na de upgrade naar php 7.

 

Ik zou zelf het zekere voor het onzekere nemen en de upgrade uitvoeren op php 5.6, en daarna naar 7. Ik draai zelf al een poosje op php 7 en zodra ik dat naar een lagere versie zet merk ik dat gelijk in snelheid in de webwinkel, dus het is sowieso een goed plan om die kant op te gaan.

 

Bij presta 1.52 blijven is geen optie, dan is het vragen om problemen ivm veiligheid etc.

  • Like 1

Share this post


Link to post
Share on other sites

Bedankt voor het meedenken.

 

Inmiddels heeft mijn hoster de webste naar een server met php 6.5 gezet. http://www.hotspotfishing.nl/

 

Helaas kan ik niet inloggen bij prestabeheer en al is de webshop wel zichtbaar er kunnen geen bestellingen worden gedaan. http://www.hotspotfishing.nl/shop/nl/  ( externe link).

 

Enig idee hoe ik dit kan oplossen?

 

 

Ik heb nog geen update gedaan dus zit draai nog op 1.5.2

 

Krijg zojuist bericht dat ze de site weer terug gaan zetten naar de php 5.3 server totdat we alles up to date hebben en daarna weer een poging wagen.

 

Hoofdpijn krijg ik hiervan, ik weet het niet meer. Ben een leek.

Edited by Helen58 (see edit history)

Share this post


Link to post
Share on other sites

1.5.2 werkt inderdaad niet op php 6.5 en 7.

 

Ik zou wel adviseren om een kopie te draaien. Overigens is het bijv. via plesk mogelijk om meerdere php versies te draaien, je kan dan selecteren welke je wilt gebruiken.
Bij een 1 click upgrade kan je dan als je problemen onder vind een php versie selecteren in Plesk om te kijken of dit werkt.

 

Het is verstandig om op en server te gaan zitten met een php versie van 6.5 of 7 ivm veiligheid.

Share this post


Link to post
Share on other sites

@ Qualityangel

 

Dat was dus al wat ik dacht, naar welke versie moet Helen58 hem terug laten zetten om eerst een upgrade te gaan doen dan? 5.6?

 

Dus even concreet de stappen:

 

1. Terugzetten naar PHP 5.6

2. Reservekopie maken

3. Upgraden

4. Checken of alles draait

5. Naar Php 7 zetten of laten zetten

 

Klopt dat zo?

Edited by Curious (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More