Jump to content
Antoine F

PrestaShop 1.7 is now available!

Recommended Posts

Dear members,
It’s been 495 days since the release of 1.6.1.0, the last major version of PrestaShop. And boy have we kept ourselves busy since then!

We are happy to finally release the start of a now path for PrestaShop: version 1.7.0.0 opens the way to a new way of selling, creating and developing with your favorite Open Source e-commerce platform!

Indeed, version 1.7 is a major step forward for PrestaShop, with a number of major features and forward-looking changes: the introduction of the Symfony2 framework, a rebuilt Theme system which brings a new default theme along with a Starter Theme, a brand new Product Creation page, a reworked Modules page, a reorganized main menu, … and all this while having a look at performances! This is what we mean when we say “major version” :)

Read all about this new version of PrestaShop on the official 1.7.0.0 announcement post!

Thank you to all the contributors who submitted pull requests and commits, both from within PrestaShop and from the whole community! A huge thanks to those 128 PrestaShop lovers:
@123monsite-regis, @aleeks, @alexdee2007, @alexeven, @alfakom-mk, @antho-girard, @antiseptikk, @antoinemille, @antoin-m, @axometeam, @cava89, @christianverardi, @clairemeuriot, @cocoweb94, @connemb, @crugnac, @dave-lp, @davideapvd, @desarrolloscuado, @dh42, @djbuch, @djfm, @dzianis-yurevich, @ecomm360, @e-gaulue, @eolia, @eric-rouvier, @fabienserny, @fatmabouchekoua, @firstred, @flooris, @fojtcz, @fojtcz, @frederic-benoist, @freedayko, @gaillafr, @ginkosama, @gleseur, @grezlikowski, @groussac, @gskema, @guestisp, @gwarnants, @hubiktomas, @ianfunghk, @idnovate, @inem0o, @ishcherbakov, @jaumesala, @jeromenadaud, @jguix, @jherry, @jnadaud, @jocel1, @jonijnm, @jorgevrgs, @jtabet, @julienbourdeau, @julvernois, @kelu95, @kermes, @kioob, @kpodemski, @leadesign, @m03g, @macroy, @maidmaid, @makoso, @manuelbcd, @martinfojtik, @maximebiloe, @mcdado, @mekki78, @mgui95, @mickaelandrieu, @monsty, @mrmanchot, @newman101, @nihco2, @nobodaddy, @n-wouda, @oleacorner, @paeddl, @panploenes, @phpmadman, @pifyz, @pirkoa, @pkshetlie, @pranid, @prestaedit, @prestamodule, @prestancedesign, @prestanesia, @prestarocket, @prestashop, @pronux, @quetzacoalt91, @raphael-homann, @remiq, @rgaillard, @rolige, @saycile, @sfroment42, @shaffe-fr, @shagshag, @shepherdv8, @shine-neko, @shopmonauten, @shudrum, @soullivaneuh, @spaze, @studiokiwik, @tchauviere, @thierrymarianne, @thoma202, @tomcyr, @true0r, @tucoinfo, @turtl3, @txmodxoops, @unlocomqx, @vaugagneur, @venditdevs, @vincentbz, @xborderie, @xgouley, @zizuu-store, and @zuzul.

Thank you for your contributions!

 

Download PrestaShop 1.7.00

Share this post


Link to post
Share on other sites

hard work is beginnig for me :( update all my modules..

i don't understand why beta versions not shared ? only rc versions shared ? This was the first time ..

it was in a hurry , now a lot users will be try update and come a lot errors , modules / themes / custom works...

Share this post


Link to post
Share on other sites

Too fast, no?. I did not expect the release until nearly the end of the year. :wacko:

There is no official documentation.
Hopefully not find bugs.
 
Cheers!!!
Edited by jesusruiz

Share this post


Link to post
Share on other sites

oooooh how i hate this.. LOL.

Been workin on 1.6.1.7 for over two months making custom stuff to the default theme and othet stuff, planing on release in the end of November and now this.. hehe

Ahhh  what to do..  ???????    :blush: 

Anyhow.. thnx for all the hard work :) but thought you guys wouldent be done for atleast 6 months... probably the first time im disappointed at a early release :P  

Share this post


Link to post
Share on other sites

oooooh how i hate this.. LOL.

 

Been workin on 1.6.1.7 for over two months making custom stuff to the default theme and othet stuff, planing on release in the end of November and now this.. hehe

 

Ahhh  what to do..  ???????    :blush: 

 

Anyhow.. thnx for all the hard work :) but thought you guys wouldent be done for atleast 6 months... probably the first time im disappointed at a early release :P

 

Highly recommend you not to update now. Wait for 6 months or so. Also keep in mind that things like custom colors and fonts in 1.7 classic theme is gone.

Share this post


Link to post
Share on other sites

oooooh how i hate this.. LOL.

 

Been workin on 1.6.1.7 for over two months making custom stuff to the default theme and othet stuff, planing on release in the end of November and now this.. hehe

 

Ahhh what to do.. ??????? :blush:

 

Anyhow.. thnx for all the hard work :) but thought you guys wouldent be done for atleast 6 months... probably the first time im disappointed at a early release :P

If I were you I wouldn't change anything. PS 1.6.x will be supported until October 18. And you are more likely to find plenty modules compatible with ps 1.6.1.7

Share this post


Link to post
Share on other sites

Also guys, keep in mind that with DB backup currently there is an error and you can't restore the DB in 1.7   keep it in mind, and test, test, test before using new major versions on live servers.

Share this post


Link to post
Share on other sites

Fresh Install… OVH PERFORMANCE 1 (shared server)

  • Admin tutorial VERY SLOW
  • Install OK but after few steps of the admin tutorial (57%) : 
504 Gateway Time-out

Share this post


Link to post
Share on other sites

I installed a fresh copy of 1.7 and I got a server error.  Went to me ISP and they upgraded php to 5.6 but no help there.  I still have a 500 error.  Any advice other than reinstall?  It finally came up.  My isp must have done something.

Edited by roban

Share this post


Link to post
Share on other sites

I installed a fresh copy of 1.7 and I got a server error.  Went to me ISP and they upgraded php to 5.6 but no help there.  I still have a 500 error.  Any advice other than reinstall?  It finally came up.  My isp must have done something.

Did you turned on the dev mode to see the errors?

Share this post


Link to post
Share on other sites

Also, what's the point in linking the 1.6 use guide during the 1.7 installation? Not to mention all the broken images and the unbearable slowness of the installation script.
Seriously, no cart drop down?
How much should we step back, since we also lost the opc?

Share this post


Link to post
Share on other sites

Did you turned on the dev mode to see the errors?

That's the least of the problems.  A lot doesn't work like changing logos.  Click the upload file link and nothing happens and I can't add an item to the top menu.  This version is NOT ready for prime time and I am really pissed that it was presented as though it was.

Edited by roban

Share this post


Link to post
Share on other sites

Fresh Install Prestashop 1.7 (OVH Performance 1 / Shared Server).

 

Install ok BUT :

 

- Admin tutorial is SLOW

- at 57% of admin tutorial »»» 504 Gateway Time-out - Nginx

- unable to clic on Carriers »»»  504 Gateway Time-out - Nginx

- unable to clic on Payment »»»  504 Gateway Time-out - Nginx

- color switcher is very slow (no ajax » whole page is loaded…)

Share this post


Link to post
Share on other sites

one more think.

when try edit product price (tax inculed) not changing product price :( only working before tax price ..

Share this post


Link to post
Share on other sites

Manage to install after few dificulties.

But realy...this is not ready for stable release. Not to mention speed.

With default setup is so slow, you can drink coffe before next page loads in admin.

If this is final version, im moving to Magento. 

Share this post


Link to post
Share on other sites

hard work is beginnig for me :( update all my modules..

i don't understand why beta versions not shared ? only rc versions shared ? This was the first time ..

it was in a hurry , now a lot users will be try update and come a lot errors , modules / themes / custom works...

don't be afraid, it's impossible to migrate to this version.

Share this post


Link to post
Share on other sites

Despite knowing a major issue impacting php prior version 7 and, nevertheless publishing when it is a 2 lines change into a vendor library

Having 1/2 of the native modules not integrated within the solution and major mess within the addons flow and broken update mechanism

Thumbnails not present/regenerted on install

Still evidence of no decent test on the business centric features (stock, product return, ... to name a few)

Not even patched to cope with latest Chrome release that suppress synchronous ajax call (deprecated since 2012)

Not to mention the still existing performance issues due 37 ajax call on product admin page

 

That is not what I call a mature release or any kind of achievement.

That is yet again a "shame" a not to be used version not even to be planned on a yet to start project.

Roadmap 2019 for some usable?

Share this post


Link to post
Share on other sites

Installed as a test store without any hiccups. (using firefox)

 

Problems so far...

 

F.O:

- Quickview doesnt work on MS Edge yet works fine on firefox

- Adding another menu item (with just 1 child category level ) and in the F.O its not aligned correctly ( see Tops and Dresses on my site below )

- When updating personal info in account, you need to enter password to save ? (bug or feature)

 

B.O:

- Try adding new store ( with debug turned on ) and get error

Warning on line 296 in file /newshop/controllers/admin/AdminStoresController.php
[2] Invalid argument supplied for foreach()

- If side menu is minimised, the bottom sections cannot be seen when hovering over them... They vanish off bottom of screen.

- Disabled guest checkout, yet it is still an option in F.O

 

Fresh install can be seen on my site at no-match.co.uk/newshop

Feel free to make blag accounts, and test on there whilst waiting for an official demo

Edited by MerseyRay

Share this post


Link to post
Share on other sites

This debacle has cost me hours of work for nothing.  If the developers think so little of the end user as to release this without warnings, I will go back to Cs-Cart in a hurry and say goodbye to Prestashop.

Share this post


Link to post
Share on other sites

Hi,

 

I was able to install Prestashop 1.7 without errors. I really like the new look its so fresh. Overall I think everything is more intuitive than before.

 

I'm starting a new shop so I will be using this version (although there still are some errors as mentioned above). Hopefully there will be updates soon.

 

 

Share this post


Link to post
Share on other sites

Hi,

 

Would like to make compatible with 1.7 one of my module which is using a class extend from AdminTab class to display a form in a new tab in the admin (in catalog).  Get refused:

Attempted to load class "AdminTab" from the global namespace.
Did you forget a "use" statement?

I guess this is the wrong way to do now, but there is no doc. No clue what to do...  Any idea, anyone ?

 

Other point, cannot find the way to activate the advanced Stock management and warehouses. Is this went away with the water bath ?

 

Regards

Franck

Share this post


Link to post
Share on other sites

Slow as hell, come on guys :( Total disappointment.

 

 

Also, what's the point in linking the 1.6 use guide during the 1.7 installation? Not to mention all the broken images and the unbearable slowness of the installation script.

Seriously, no cart drop down?

How much should we step back, since we also lost the opc?

 

Unfortunately, This is what I predicted for PS 1.7 see https://www.prestashop.com/forums/topic/480580-want-to-know-more-about-17/?p=2414443. It is really a shame that so many working hours are lost...

Share this post


Link to post
Share on other sites

Unfortunately, This is what I predicted for PS 1.7 see https://www.prestashop.com/forums/topic/480580-want-to-know-more-about-17/?p=2414443. It is really a shame that so many working hours are lost...

 

If you are not part of the solution you are part of the problem.  Where were you when others giving their time and efforts to test betas/release candidates?  How with your 2 posts would you even have opinion?  Or are you just a troll?  Your predicted?  lol  You are the type of community member that made me retire from US/Global moderator, so I can respond freely now....your opinion is 'biased' and 'inflammatory' and 'uninformed'.  You and others that have knew jerk reactions show you only read he negative bs I've seen on 'blogs' which are inaccurate and certainly do not add to spirit of positive debate or add anything to the conversation.  For me, especially for those that make a good living with PS, to degrade what they obliviously cannot understand is shameful, and  I  lost a lot of respect for them.  As for you dpat,  you don't fit into that category, I think you are just a troll.

Edited by El Patron

Share this post


Link to post
Share on other sites

If you are not part of the solution you are part of the problem.  Where were you when others giving their time and efforts to test betas/release candidates?  How with your 2 posts would you even have opinion?  Or are you just a troll?  Your predicted?  lol  You are the type of community member that made me retire from US/Global moderator, so I can respond freely now....your opinion is 'biased' and 'inflammatory' and 'uninformed'.  You and others that have knew jerk reactions show you only read he negative bs I've seen on 'blogs' which are inaccurate and certainly do not add to spirit of positive debate or add anything to the conversation.  For me, especially for those that make a good living with PS, to degrade what they obliviously cannot understand is shameful, and  I  lost a lot of respect for them.  As for you dpat,  you don't fit into that category, I think you are just a troll.

 

Hi El Patron, I don't agree with you on this one; i have done no testing on this version either. The main reason is in my opinion, it is once again a new "great and improves" version that is very buggy, while the current 1.6 version needs just a bit more attention to get really up to standards. Also see al the comments in the "What do you want for PS 1.7" forum (we want a 1.6 that works...) In my opinion, PS should never have abandoned 1.6 like they have. 

 

PS forces us to migrate to a buggy new version that is even slower than the 1.6 version. I think if we have a vote for an improved 1.6 or a new 1.7, the results are not as close as Trump vs Clinton :)

 

So now what; we have a few months of "support" left for 1.6, and a very buggy 1.7 that won't be stable for months to come. Not to mention that multistore etc. is not even included yet.

 

If someone decides to fork PS 1.6 and work from there to an improved version, i am with them!

Share this post


Link to post
Share on other sites

If you are not part of the solution you are part of the problem.  Where were you when others giving their time and efforts to test betas/release candidates?  How with your 2 posts would you even have opinion?  Or are you just a troll?  Your predicted?  lol  You are the type of community member that made me retire from US/Global moderator, so I can respond freely now....your opinion is 'biased' and 'inflammatory' and 'uninformed'.  You and others that have knew jerk reactions show you only read he negative bs I've seen on 'blogs' which are inaccurate and certainly do not add to spirit of positive debate or add anything to the conversation.  For me, especially for those that make a good living with PS, to degrade what they obliviously cannot understand is shameful, and  I  lost a lot of respect for them.  As for you dpat,  you don't fit into that category, I think you are just a troll.

I didn't want to offend someone or disrespect their work, I am sorry if someone had that impression.

 

What I basically meant: I know there are very capable guys out there, but often the priorities have not been set right (in my opinion). I did not try the betas, rcs of PS 1.7 because I do not have plans to make an upgrade in the near future.

Share this post


Link to post
Share on other sites

In earlier years I was an initial member of both Cube Cart and CS-Cart.  I still hold moderator status for both solutions.  We made the mistake of releasing beta versions in the hopes that the membership would help by using the software, reporting issues and suggesting fixes.  That's fair enough however the difference here is this was sent as a solution, not an incomplete solution without warnings to not use it as a production cart.

 

I don't mind helping the developers.  In fact it is a great way to develop software and those that do it should be given credit for their service.  But I urge the developers to make it clear that this is the purpose and not advertise a major release unless it has most of the bugs resolved.

Edited by roban

Share this post


Link to post
Share on other sites

Hello,

 

I'm having trouble upgrading my modules. Anyone else has the same problems? I get following error message: Cannot store module content in temporary folder !

 

If anyone can help me to find which folder to adjust please let me know!

 

Thx!

Share this post


Link to post
Share on other sites

new install ....

HTTP ERROR 500

 

what can i do ???????

 

i edit defines.inc.php

define('_PS_MODE_DEV_', true);

 

now i have

Fatal error: Call to undefined function openssl_random_pseudo_bytes() in      classes/Tools.php on line 113

 

 

 

yes ... resolved :)

i edit my php.ini

;extension=openssl.so     

to

extension=openssl.so
Edited by jeromecollection

Share this post


Link to post
Share on other sites

No usable payment methods such as PayPal in this new 1.7 - What is prestashop thinking to say this is a NEW release without providing as a minimum the SAME modules as previous versions. Seriously glad I did not invest too much energy in this project I have running.

 

Time to middle finger PrestaShop for a FAILED 1.7! This is F**ing ridiculous guys!

Share this post


Link to post
Share on other sites

Unfortunately, there's no more word about Prestashop and team and what they do 

 

Just leave ... 

 

THAT'S ALL FOLKS ! 

Share this post


Link to post
Share on other sites

Hi friends I am aware that PrestaShop 1.7 is very popular with you as I am. I've been working for 3 hours for 45 minutes but I'm still not able to build it.

 

When I look at my php, I see that there are exactly 229 tables, but come back to the line of the installation.

 

I received this error. I talked to the hosting service and communicated the situation and changed a lot of settings. I made an optimization but I did not get the result. I am glad if friends who have knowledge about it are informed.

 

http://image.prntscr.com/image/54119e75876e47f29d0818c0acb343ca.png

Share this post


Link to post
Share on other sites

×