Jump to content
Sign in to follow this  
nielo

You don't have permission to access - v admin rozhraní

Recommended Posts

Mám problém v administrační části. Hostuji na forpsi.cz. Předem říkám, že localhostu vše funguje.

Problém je tedy následující:
V administračním rozhraní v části Catalog, kde je dole výpis zboží, tak mi nefunguje stránování produktů (tzn. přechod na další stránku) a funkce Filtr a Reset. Také nefunguje změna počtu zobrazených produktů na stránku. U kategorií to funguje. Chyba se projevuje hláškou serveru:

Forbidden

You don't have permission to access /prestashop/adminXXX/index.php on this server.

Z uvedené chybové hlášky jsem odvodil, že půjde zřejmě o práva a tak jsem v různých kombinacích pro soubory a adresáře zkusil nastavit práva 777 a 757. Bez výsledku. Pří úpravě práv už admin rozhraní nefungovalo vůbec a skončilo hláškou:


Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, postmaster@xxx.xxx and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


Další domněkou bylo použití serverem nepovolených direktiv v souboru .htaccess. Vymazání tohoto souboru také nepomohlo. Na technické podpoře mi zatím nejsou schopni poradit, tak to zkouším zde, zda jste takový problém neřešili nebo vás nenapadá nějaké řešení (např. úpravou zdrojáku).

Díky za nápady

2021_h4Hc34rQhletNRJbeL1q_t

Share this post


Link to post
Share on other sites

Ještě bych doplnil můj problém. Výše popisovaná chyba se neprojevuje jen u zboží, ale v celém admin rozhraní, kde je potřeba přecházet na další stránky - např. zákazníci, objednávky, countries atd. Musím říct, že je to dost nepříjemné. Prosím poraďte.

Share this post


Link to post
Share on other sites

zdravim,
kdyz zadate do prohlizece www.vasedomena.cz/prestashop/adminXXX/index.php tak to funguje?
to ze vam ho hlasi internal server error muze byt skutecne kvuli .htaccessu, po dobu ladeni bych jej uplne odmazal.
nastavenim prav na 777 z hlediska testovani nemuzete nic zkazit.
kdyztak mi poslete PM s url adresou, zkusim se na to podivat.
os

Share this post


Link to post
Share on other sites

Nakonec jsem to vyresil. Byla to nepovolena direktiva safe_mode na hostingu Dynamic u Forpsi. Bylo nutne prejit na hosting Normal, kde je tato vlastnost povolena.

Duvod proc to nefungovalo, bylo, ze v admin rozhrani pri funkci strankovani a filtrovani se pomoci POST predavaji hodnoty, ktere obsahuji !, coz je zastupny znak pro vykricnik "!" . Pokud neni povolena vlastnost safe_mode na serveru, tak neni mozne zpracovavat dotazy obsahujici znak "%".

Snad nekomu pomuze.

Share this post


Link to post
Share on other sites

zdravim,
tohle reseni se mi moc nezda, protoze ja ten shop provozuji taky se zapnutym safe_mode a nevadi mu to. ja si spis myslim jestli to neni nejakou konfiguraci toho safe_modu, kterou na hostingu pouzivaji.
kazdopadne PS se zapnutym safe_mode funguje v poradku, dulezite je, ze to funguje uz i vam :)
os

Share this post


Link to post
Share on other sites
zdravim,
tohle reseni se mi moc nezda, protoze ja ten shop provozuji taky se zapnutym safe_mode a nevadi mu to. ja si spis myslim jestli to neni nejakou konfiguraci toho safe_modu, kterou na hostingu pouzivaji.
kazdopadne PS se zapnutym safe_mode funguje v poradku, dulezite je, ze to funguje uz i vam :)
os


zdravim,
asi jste spatne pochopil muj prispevek. Muj prestashop nefungoval na hostingu s vypnutym safe_mode. Musel jsem prejit na hosting se ZAPNUTYM safe_mode - zde to funguje v poradku.

Share this post


Link to post
Share on other sites

tak to jsem nepochopil teda vubec :)
kazdopadne mi to nedalo a zkusil jsem to a funguje to jak se safe_mode off, tak se safe_mode on, tak to by me zajimalo kde ten pes byl zakopanej.
ondrej

Share this post


Link to post
Share on other sites
tak to jsem nepochopil teda vubec :)
kazdopadne mi to nedalo a zkusil jsem to a funguje to jak se safe_mode off, tak se safe_mode on, tak to by me zajimalo kde ten pes byl zakopanej.
ondrej


Tak to je opravdu zajimave... Ovsem je zajimave, ze mate moznost na hostingu manipulovat se safe_mode. Mi bylo receno, ze safe_mode je otazka celeho serveru a tak neni mozne nastavit vyjimku jen pro jeden web. A tak je tedy nutne prejit na jiny hosting, ktery je na jinem serveru s povolenym safe_mode. Rika tedy Forpsi ;-)

Share this post


Link to post
Share on other sites

safemode vypnete/zapnete jednotlive pro kazdou domenou pomoci
php_admin_flag safe_mode on/off
v konfiguraci apache.
spis ty jejich servery tak maji nakonfigurovane, aby se to nepletlo do hromady.
ondrej

Share this post


Link to post
Share on other sites
safemode vypnete/zapnete jednotlive pro kazdou domenou pomoci
php_admin_flag safe_mode on/off
v konfiguraci apache.
spis ty jejich servery tak maji nakonfigurovane, aby se to nepletlo do hromady.
ondrej


Jasne rozumim, znam... Ale tak oni maji jeden Apache pro vice domen... Ale verim tomu, ze by to slo naskriptovat a udelat nejakou vyjimku pro dany hosting...

Share this post


Link to post
Share on other sites
safemode vypnete/zapnete jednotlive pro kazdou domenou pomoci
php_admin_flag safe_mode on/off
v konfiguraci apache.
spis ty jejich servery tak maji nakonfigurovane, aby se to nepletlo do hromady.
ondrej


Jasne rozumim, znam... Ale tak oni maji jeden Apache pro vice domen... Ale verim tomu, ze by to slo naskriptovat a udelat nejakou vyjimku pro dany hosting...


Bohužel mám tentýž problém ...vyzkoušel jsem vše výše uvedené, safe_mode mám aktivní, práva jsem zkušebně nastavil na 777, zkusil jsem i vymazat .htaccess ...a stále žádná změna.

Chyba pri vyrizovani pozadavku

Server nevratil zadnou webovou stranku, kterou by bylo mozne zobrazit.
Pravdepodobna pricina teto chyby je ve scriptu, ktery webovou stranku generuje.
Error while serving request

Server didn't return any web site which can be shown.
Probable cause of problem is in script which generates this web page.


Poradíte prosím někdo, jak problém řešit?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More