Jump to content

Link zu zzgl. Versandkosten verändern


Recommended Posts

Hallo,

 

ich habe gerade das modul advancedeucompliance installiert und konfiguriert.

Soweit so gut.

 

Bei den einzelnen Produkten wird jetzt auch inkl. Mwst. zzgl. Versandkosten angezeit.

Wenn ich jedoch auf zzgl. Versandkosten klicke erscheint die blanke weiße Seite mit meiner Tabelle in denen ich die Preise hinterlegt habe.

Hier ist nichts mehr vom Shop zu erkennen. Ich hätte die Tabelle lieber nur als Pop-up (wenn ich das so richtig benenne) ich meine aber eine art vorschaufenster.

Ist das möglich? 

Oder muss ich was an meiner verlinkten CMS-Seite ändern?

 

Vorab schon vielen Dank

Share this post


Link to post
Share on other sites

Servus fima,

 

dann hat das wohl mit der Installation geklappt :huh:

 advancedeucompliance öffnet die verlinkten CMS-Seiten standardmäßig in der fancybox (deine weiße Seite) und stellt diese dar.

Dies zu ändern zu versuchen empfehle ich dir nicht unbedingt, da man sich hierfür doch recht gut mit Prestashop und dessen Programmierung auskennen sollte.

Share this post


Link to post
Share on other sites

advancedeucompliance öffnet die verlinkten CMS-Seiten standardmäßig in der fancybox (deine weiße Seite)

Gerade das scheint nicht der Fall zu sein, die Fancybox, also ein Layer, der sich nur über einen Teil der Seite legt, ist ja das, was er will, gesteuert wird das über class="iframe", scheint hier aber nicht zu funktionieren.

Share this post


Link to post
Share on other sites

danke für die tips. habe die einstellung iframes jetzt erlaubt.

Muss ich nochetwas machen? 

Momentan sieht es noch nicht anders aus.

Welche auswirkung sollte diese einstellung denn haben?

Share this post


Link to post
Share on other sites

Momentan sieht es noch nicht anders aus.

Normalerweise müßte die Seite eben als Layer angezeigt werden, warum das bei dir nicht so ist, keine Ahnung, mußt du halt mal in den Quellcode schauen ob da class="iframe" steht oder hier mehr Infos posten (Link zum Shop, Template, Module ...). Werden denn Bilder im Layer angezeigt?

Share this post


Link to post
Share on other sites

da ich mich nicht all zu gut aukenne traue ich mich nicht an den quellcode ran. ich will da nichts kaputt machen.

Bestimmt kann das mein webdesigner.

Produktbilder werden als layer angezeigt.

 

bitte nicht erschrecken. der shop ist noch eine ziemliche baustelle  :blush:

http://www.fima-racingparts.de/de/

 

template 1250 von monster (motorcycle)

 

prestashop 1.6.1.7

Share this post


Link to post
Share on other sites

Also wenn ich in deinem Shop - dessen Adresse ich jetzt ja kenne - auf einer Produktseite "zzgl. Versandkosten" klicke, wird die Versandkosteninfo völlig richtig als Layer angezeigt. Vielleicht mußt du mal deinen Browsercache löschen.

Share this post


Link to post
Share on other sites

Hallo,

 

wir haben ein ähnliches Problem:
Bei Klick auf "zzgl. Versandkosten" auf der Produkt Page öffnet sich kein neues Fenster bzw. Iframe PopUp, sondern die Versandkosten werden im selben Fenster geöffnet. Das Problem besteht nicht auf allen Endgeräten.

 

Der Tip von "eleazar" bewirkt keine Änderung. Browser Cache gelöscht.

 

Bspw. hier:

Prestashop 1.6.1.5

Template Warehouse

Edited by OBCOBC (see edit history)

Share this post


Link to post
Share on other sites

Bei Klick auf "zzgl. Versandkosten" auf der Produkt Page öffnet sich kein neues Fenster bzw. Iframe PopUp, sondern die Versandkosten werden im selben Fenster geöffnet.

Sieht so weit OK aus, warum es nicht funktioniert, kann ich nicht erkennen, liegt wahrscheinlich am Template. Aber den Text der Versandkostenseite und auch die AGB würde ich unbedingt von einem Anwalt prüfen lassen!

Edited by rictools (see edit history)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Dieses Problem tritt bei jedem Presta auf, den ich jetzt auf die schnelle mal ausprobieren konnte. Getestet mit drei Browsern. Immer das gleiche Ergebnis. Keine Fancybox.

Es wird nur korrekt dargestellt, wenn man die Versandkosten von der Artikelliste auf der Startseite aus ausruft.

 

Auch im Rictools-Shop das gleiche Verhalten. ;)

 

Irgendwelche Lösungsvorschläge?

Share this post


Link to post
Share on other sites

hm...

nach langem ringen habe ich nun auf das Standardtemplate umgestellt.

Bei uns geht die Fancybox.

hoffentlich bleibt das so.

 

wird sich bei dir bestimmt auch wieder zurückstellen rictools.

wenn es sich auch selbst verstellt hat

Share this post


Link to post
Share on other sites

Hab gerade nachgeschaut, unser update hat da alles etwas durcheinandergewürfelt.

das template heißt  

default-bootstrap version 1.0

 

unser bo ist aktuell 1.6.1.7 und so schnell werde ich auch kein update mehr mitmachen...

Share this post


Link to post
Share on other sites

bei mir hat sich die Rechnungsvorlage verändert als ich paypal installiert habe...

auch ganz komisch.

was hast du da geändert an den Rechnungen.

Damit bin ich bei uns auch noch nicht ganz zufrieden.

Vielleicht hast du da einen Tipp für mich.

Share this post


Link to post
Share on other sites

Bei den Rechnungen passt ja standardmäßig nicht viel. Erst mal Bruttopreise rein. MwSt. vernünftig ausweisen. Die Kleinigkeiten, die das Leben mit Presta manchmal schwer machen. ;)

Gefällt mir aber alles noch nicht. Da fließen auch noch ein paar Stunden rein....

 

Allerdings hat sich nach der Paypal-Installation hier nichts verändert... :P

Share this post


Link to post
Share on other sites

beim rechnungen abändern kenne ich mich noch garnicht aus. wie mache ich das?

Brauche ich dafür ein modul oder ist das in den einstellungen?

 

Presta und ich haben so eine hass-liebe.

Ich bin froh das ich es habe aber ganz einfach ist es nicht immer....

vorallem als anfänger

Share this post


Link to post
Share on other sites
  • 4 months later...

Hallo!

gibt es eine Lösung für die Anzeige der Versandkosten in einem neuen Fenster oder Fancybox?

Ich habe die Version 1.6.1.11

Und die fancybox öffnet sich nur von der Startseite. Wenn zzgl. Versandkosten aus der Artikelbeschreibung angeklickt werden, dann wird es im gleichen Fenster dargestellt und man sieht nichts mehr vom Shop oder Artikel :( .

Share this post


Link to post
Share on other sites

Der Abschnitt sollte in der product-price-blck.tpl in etwa so aussehen:

    {* "Shipping CMS content" Price Hook templating *}
    {if isset($smartyVars.ship) && isset($smartyVars.ship.link_ship_pay) &&
    isset($smartyVars.ship.ship_str_i18n)}
        <div class="aeuc_shipping_label">
            <a href="{$smartyVars.ship.link_ship_pay}" class="iframe">
                {$smartyVars.ship.ship_str_i18n|escape:'htmlall'}
            </a>
            <script type="text/javascript">
                $(document).ready(function(){
                    if (!!$.prototype.fancybox)
                        $("a.iframe").fancybox({
                            "type": "iframe",
                            "width": 600,
                            "height": 600
                        });
                })
            </script>
        </div>
    {/if}
  • Like 1

Share this post


Link to post
Share on other sites
  • 1 month later...

Frage hierzu: ich habe das Modul "Ausgewähle Artikel auf der Startseite" aktiv - dort gibt es den Versandkostenlink ja leider. Der macht bei mir kein Fancybox ebenso wieder die Kategorieansicht. Nur auf der direkten Produktseite funktioniert das. Shopadresse ist loewenblume.de - vlt kann man jmd schauen? LG

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More