Jump to content

errno 11 "Resource temporarily unavailable"


Recommended Posts

Hi, I run into this issue today many times :

"Link to database cannot be established: SQLSTATE[HY000] [1135] Can't create a new thread (errno 11 "Resource temporarily unavailable"); if you are not out of available memory, you can consult the manual for a possible OS-dependent bug"


This does not seem to happen to any specified page, it happens to both front-end and back-end pages or tabs. The resource seems to be temporarily unavailable or Mysql out of memory for a sec but if I refresh the page right after it will load no problem.


I tried to disable non PrestaShop modules and disable all overrides in debug mode but it still occurs. I also contacted my hosting provider, they don't think it's a server side issue and everything looks OK on their side. I did a bit googling and found this happen to someone else before here and some similar issue with Mysql . Some suggested it will fix it by change PHP to 5.3 but no luck in my case, I am using PHP7 by the way.


There is also suggest of changing this /etc/security/limits.conf will work but I can't connect to my host via SSH for some reason. I will keep on trying this next.


If anyone knows what's happening or seen it before please let me know.


Any help would be much appreciated.

Edited by KenYe (see edit history)
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...