Jump to content

Recommended Posts

Bonjour,

J'ai suivi à la lettre la procédure de mise à jour du WIKI, tout c'est bien passé sans aucun message d'erreur.

Sauf que en découvrant ma boutique :

- Au centre de la page d'accueil, les produits, la photo et les textes sont ceux de prestashop, la boutique initiale. Les produits sont là, et c'est le plus important !

- Plus de page Back office (le dossier BO de shop-old ne s'est pas copié dans shop). Faut-il le copier manuellement ?

Share this post


Link to post
Share on other sites

Pour la page d'accueil, si vous avez fait une mise à jour du module éditorial, remettez la sauvegarde du fichier editorial.xml de votre module avant migration

et pour le back office, vue que vous avez renommé le répertoire admin, le script n'a pas la possibilité de le retrouver tout seul, faut donc recopier le contenu de admin de la mise à jour dans votre répertoire admin

cdt

Share this post


Link to post
Share on other sites

Pour la page d'acceuil et la photo, effectivement j'ai tout retrouvé dans le module "editorial".

Par contre concernant le BO, en grattant pour retrouver mon dossier "Admin-v1.2.5" j'ai vu que la mise à jour avait créé un dossier "admin".

J'ai donc un doute :
je renomme le nouveau dossier admin ou je le remplace par mon ancien dossier admin, comme tu me l'indiques ?

Share this post


Link to post
Share on other sites

C'est ce que je viens de faire et ça fonctionne.

Le wiki de mise à jour a donc oublié cette étape, le résultat donc parfait à 99%.
:-)

Je vais parcourir maintenant le BO pour découvrir les nouveautés et ça sera le lancement de la boutique au public (j'attendais cette mise à jour).

:-)

Share this post


Link to post
Share on other sites
C'est ce que je viens de faire et ça fonctionne.

Le wiki de mise à jour a donc oublié cette étape, le résultat donc parfait à 99%.
:-)

Je vais parcourir maintenant le BO pour découvrir les nouveautés et ça sera le lancement de la boutique au public (j'attendais cette mise à jour).

:-)

bonjour moi j'ai d'autres problemes
1) a l'install je dois creer une autre base de donnée ok
2) apres install je change dans prestashop le nom de ma base pour reprendre l'ancienne et la je retrouve tout
3) par contre dans prederence pour le mode arrondi rien ne marche aucun des choix ne fonctionne j'ai le message "champ mode arrondi invalide" et cela meme avant de reprendre mon ancienne base.

qui a la solution ?
merci

Share this post


Link to post
Share on other sites
C'est ce que je viens de faire et ça fonctionne.

Le wiki de mise à jour a donc oublié cette étape, le résultat donc parfait à 99%.
:-)

Je vais parcourir maintenant le BO pour découvrir les nouveautés et ça sera le lancement de la boutique au public (j'attendais cette mise à jour).

:-)

bonjour moi j'ai d'autres problemes
1) a l'install je dois creer une autre base de donnée ok
2) apres install je change dans prestashop le nom de ma base pour reprendre l'ancienne et la je retrouve tout
3) par contre dans prederence pour le mode arrondi rien ne marche aucun des choix ne fonctionne j'ai le message "champ mode arrondi invalide" et cela meme avant de reprendre mon ancienne base.

qui a la solution ?
merci


bon j'abandonne la MAJ je reste avec 1.2.5

Share this post


Link to post
Share on other sites
Bonjour,
même problème pour le mode arrondi,
1 erreur
1. champ Mode d'arrondi: invalide


bonjour

nous sommes deja deux a avoir ce probleme, moi j'ai viré 1.3 et je remet 1.2.5.0 j'abandonne

Share this post


Link to post
Share on other sites

J'ai commencé à développer la boutique prestashop Lundi dernier avec la version 1.2.5, je en connaissais pas avant, donc je me suis dit que passer à la version 1.3 avant de de mettre la boutique en ligne serait un gain de temps ^^

mise à part cette histoire de mode arrondi et l'impossibilité de valider une commande chèque ou virement... je n'ai eu trop de difficultés à upgrader prestashop.

pour du gratuit, je me dit que c'est pas si mal ^^

Share this post


Link to post
Share on other sites

il ne faut pas reprendre l'ancienne base tel quel mais passer par une mise à jour, la structure de la base en 1.2 et 1.3 n'étant pas la même.

Par exemple en local :

1 - dézipper une copie de prestashop 1.3 et la placer sur votre espace web (en local)
2 - importer votre base 1.2 à migrer en 1.3
3 - copier le fichier settings.inc.php du dossier /config de la version 1.2 à la version 1.3
4 - lancer l'install de la 1.3 (doit vous proposer une mise à jour)
5 - une fois la mise à jour effectuée c'est cette base mise à jour qu'il faut utiliser dans votre version en prod migrée (1.3)

Share this post


Link to post
Share on other sites
J'ai commencé à développer la boutique prestashop Lundi dernier avec la version 1.2.5, je en connaissais pas avant, donc je me suis dit que passer à la version 1.3 avant de de mettre la boutique en ligne serait un gain de temps ^^

mise à part cette histoire de mode arrondi et l'impossibilité de valider une commande chèque ou virement... je n'ai eu trop de difficultés à upgrader prestashop.

pour du gratuit, je me dit que c'est pas si mal ^^

je suis d'accord prestashop fonctionne tres tres bien bravo a toute l'equipe de prestashop, mais moi, ma boutique est prete a etre mise en ligne, j'attends uniquement la validation de la banque pour paiement CB tout le reste marche, mais je n'aipas envie de tout refaire et je me debrouille peut etre mal mais impossible de recuperer tout mon travail avec la 1.3 et ce maudit bug d'arrondi donc je reste avec la 1.2.5.0 pour le moment

Share this post


Link to post
Share on other sites
il ne faut pas reprendre l'ancienne base tel quel mais passer par une mise à jour, la structure de la base en 1.2 et 1.3 n'étant pas la même.

Par exemple en local :

1 - dézipper une copie de prestashop 1.3 et la placer sur votre espace web (en local)
2 - copier le fichier settings.inc.php du dossier /config de la version 1.2 à la version 1.3
3 - lancer l'install de la 1.3 (doit vous proposer une mise à jour)
4 - une fois la mise à jour effectuée c'est cette base mise à jour qu'il faut utiliser dans votre version en prod migrée

bonjour nos messages ce sont croisés, ça personne ne le l'avait dit, mais cela ne regle pas le probleme de l'arrondi sur la page preference.
En plus je n'ai fais aucune install en local juste au debut avec xamp, mais je suis sur le serveur depuis 1 mois et plus rien en local
a bientot

Share this post


Link to post
Share on other sites
il ne faut pas reprendre l'ancienne base tel quel mais passer par une mise à jour, la structure de la base en 1.2 et 1.3 n'étant pas la même.

Par exemple en local :

1 - dézipper une copie de prestashop 1.3 et la placer sur votre espace web (en local)
2 - copier le fichier settings.inc.php du dossier /config de la version 1.2 à la version 1.3
3 - lancer l'install de la 1.3 (doit vous proposer une mise à jour)
4 - une fois la mise à jour effectuée c'est cette base mise à jour qu'il faut utiliser dans votre version en prod migrée


OKKK :D

Je me demandais aussi si il y avait une difference de structure de la base avec la version 1.3, et je viens de tilter qu'il y avait un problème en voyant : Powered by PrestaShop™ [ forum & contact ] - Version 1.2.5.0 - 0.154s dans l'espace admin :P

je vais régler ça en essayant de ne pas tout péter !

Merci

Share this post


Link to post
Share on other sites

Bonjour,

je ne dit pas que cela changerai votre problème mais il est probable que la 1.3 cherche à utiliser des champs qui n'existent pas dans la base de la 1.2

Share this post


Link to post
Share on other sites
Bonjour,

je ne dit pas que cela changerai votre problème mais il est probable que la 1.3 cherche à utiliser des champs qui n'existent pas dans la base de la 1.2

je me suis mal exprimé.
j'install presta 1.3 je creer une nouvelle base ps1_ a la pla ce de ps_ meme en utilisant ps1_ cela ne fonctionne pas pour les arrondis.

bonne reception

Share this post


Link to post
Share on other sites

Mon problème de validation de paiement par chèque et virement est résolu, neanmois, j'ai comme jp77 toujours le problème de mode d'arrondi (ce qui m'empêche de valider les modifs dans les préférences de l'admin).

merci pour la précision sur la mise à jour marty69 !

Share this post


Link to post
Share on other sites

j'install presta 1.3 je creer une nouvelle base ps1_ a la pla ce de ps_ meme en utilisant ps1_ cela ne fonctionne pas pour les arrondis.


Il faut vraiment faire une mise à jour de ta base 1.2 pas créer une nouvelle base. Il faut lancer l'install de la 1.3 avec les parametres de connexion sur la base 1.2 dans le fichier /config/settings.inc.php
Ceci dit je ne comprend pas bien... tu veux dire que ta base ps1_ est la base d'exemple créée par l'install de presta ? elle est inclue dans ta base 1.2 ?

Share this post


Link to post
Share on other sites

j'install presta 1.3 je creer une nouvelle base ps1_ a la pla ce de ps_ meme en utilisant ps1_ cela ne fonctionne pas pour les arrondis.


Il faut vraiment faire une mise à jour de ta base 1.2 pas créer une nouvelle base. Il faut lancer l'install de la 1.3 avec les parametres de connexion sur la base 1.2 dans le fichier /config/settings.inc.php
Ceci dit je ne comprend pas bien... tu veux dire que ta base ps1_ est la base d'exemple créée par l'install de presta ? elle est inclue dans ta base 1.2 ?

re

non pas du tout. a linstall de prestashop il y a un moment ou le non de la base ce met seul (PS_) si je garde de nom, prestashop me dit que cette base existe deja donc impossible de faire une install complete avec cette base, donc je lui donne un nouveau nom (PS1_) mais cela ne marche pas mieux, toujours ce maudit probleme de blocage avec les arrondis.
De plus, ans le forum ou le Wiki je n'ais vu nul part que l'on devait faire une mise a jour en local avant de la mettre en ligne.
voila resultat 5 heures de perdus.
a bientot

Share this post


Link to post
Share on other sites

j'install presta 1.3 je creer une nouvelle base ps1_ a la pla ce de ps_ meme en utilisant ps1_ cela ne fonctionne pas pour les arrondis.


Il faut vraiment faire une mise à jour de ta base 1.2 pas créer une nouvelle base. Il faut lancer l'install de la 1.3 avec les parametres de connexion sur la base 1.2 dans le fichier /config/settings.inc.php
Ceci dit je ne comprend pas bien... tu veux dire que ta base ps1_ est la base d'exemple créée par l'install de presta ? elle est inclue dans ta base 1.2 ?

re

non pas du tout. a linstall de prestashop il y a un moment ou le non de la base ce met seul (PS_) si je garde de nom, prestashop me dit que cette base existe deja donc impossible de faire une install complete avec cette base, donc je lui donne un nouveau nom (PS1_) mais cela ne marche pas mieux, toujours ce maudit probleme de blocage avec les arrondis.
De plus, ans le forum ou le Wiki je n'ais vu nul part que l'on devait faire une mise a jour en local avant de la mettre en ligne.
voila resultat 5 heures de perdus.
a bientot


Non en fait cette manipulation est tout aussi valable en ligne, je te dis juste de le faire en local avec une copie de ta base pour ne pas faire de boulettes. Mais tu as du sauter une étape car quand tu lance l'install tu as 2 options : installer ou mettre à jour une ancienne version. Si l'option "mise à jour" n'est pas accessible c'est qu'il ne détecte pas l'ancienne version.

je vais essayer d'expliquer le plus clairement possible :

déja partons du principe que l'on est en local (mais en ligne c'est la même chose, faut juste etre sur que tu aies fait les sauvegardes adéquates)
Imaginons que tu aies ta version 1.2 en prod chez ton hébergeur.

tu as donc d'un côté ton install 1.2 actuelle (sur hébergement) que dont tu veux migrer la base vers une 1.3
de l'autre côté une version 1.3 fraichement dézippée (en local)

- Tu récupère ta base 1.2 chez ton hébergeur.

- Tu récupère ton fichier /config/settings.inc.php de ta boutique 1.2 chez ton hébergeur

- Tu importe ta base 1.2 en local

- Tu copie le fichier /config/settings.inc.php dans ta version 1.3 en local prète à être installée

- Tu édites ton fichier /config/settings.inc.php en local pour y changer les paramètres de connexion à ta base locale (celle que tu viens d'importer)

- tu lance l'install de la 1.3 locale


La si tout se passe bien, en bas de ta première page d'install il va te mettre par défaut "mise à jour de 1.2 vers 1.3"
A la fin de la mise à jour ta base 1.2 locale a bien les mêmes données d'origine mais à la structure d'une base 1.3

Après ce n'est que l'étape de mise à jour de la base de données, mais si tu veux faire une migration complète n'oublie pas de recopier ensuite tes dossiers images, mails etc... de ta 1.2

Share this post


Link to post
Share on other sites
- Tu récupère ta base 1.2 chez ton hébergeur.

- Tu récupère ton fichier /config/settings.inc.php de ta boutique 1.2 chez ton hébergeur

- Tu importe ta base 1.2 en local

- Tu copie le fichier /config/settings.inc.php dans ta version 1.3 en local prète à être installée

- Tu édites ton fichier /config/settings.inc.php en local pour y changer les paramètres de connexion à ta base locale (celle que tu viens d'importer)

- tu lance l'install de la 1.3 locale


J’avoue que pour aujourd'hui j'en ais plein la tête, mais je viens de contrôler les étapes que j’ai faite.

J’ai bien copié mon fichier settings.inc.php de ma version 1.2 dans la 1.3, par contre il est vrai que je n’ai pas édité mon fichier settings.inc.php pour changer mes paramètres de connexion, car je n’ai vu cette info nulle part.
Si j’ai le courage je le ferais peut être demain.

voici les intructions que j'ai suivis :
1. Via FTP, dans le dossier prestashop de votre espace web (ex: http://www.mysite.com/prestashop/), créez une sauvegarde de votre dossier courant prestashop en le renommant (ex : http://www.mysite.com/prestashop_old/).
2. Effectuez également une sauvegarde de votre base de données SQL
3. Télécharger la dernière version de la solution e-commerce PrestaShop.
4. Dézipper la nouvelle archive ZIP n’importe où sur votre disque dur.
5. Via FTP, placez dans un nouveau dossier prestashop les nouveaux fichiers prestashop situés dans le dossier prestashop dézippé (et non pas le dossier lui-même) (ex : http://www.mysite.com/prestashop/).
6. Si vous avez précédemment modifié le contenu du dossier /mails, copier le contenu de votre copie de sauvegarde de /mails dans le dossier /mails nouvellement créé.
7. Copiez le contenu de votre copie de sauvegarde du dossier /img dans le dossier /img nouvellement créé.
8. Si vous avez ajouté des modules supplémentaires à la version par défaut de PrestaShop, copiez les modules ajoutés de votre copie de sauvegarde de /modules dans le nouveau dossier /module.
9. Si vous avez modifié le fichier .htaccess, fusionnez le contenu de l’ancien et du nouveau fichier .htaccess, en supprimant toute duplication d’information. Ne remplacez pas un fichier par un autre.
10. Si le cas s’y prête, copiez le sous-dossier de vos thèmes personnalisés (ex : /themes/mythemes) du dossier de sauvegarde /themes dans le dossier parent /themes nouvellement construit.
11. Copiez le fichier settings.inc.php à partir du dossier de sauvegarde /config dans le nouveau dossier /config.
12. Dans un navigateur web, lancez l’installeur en ajoutant /install à l’URL de votre boutique (ex : http://www.mysite.com/prestashop/install).

Share this post


Link to post
Share on other sites
oui le commerce de nos jours ça fait mal à la tête !
Courage tu vas y arriver :)

je suis dans le commerce depuis 20 ans et dans le meme domaine mais je developpe le site avec un ami.
c'est surtout que il y a encore 1 mois je n'avais pas toucher au php et mysql.

je vais essayer demain je viens de faire une sauvegarde totale de ma base et de mon install sur mon disque dur.

merci de ton aide

Share this post


Link to post
Share on other sites
oui le commerce de nos jours ça fait mal à la tête !
Courage tu vas y arriver :)

bonjour
bon mise a jour reussi apparemment j'arrive sur la page maintenance.
pour plus de securité j'ai fait une autre boutique( ex : ancienne BOUTIQUE et la nouvelle BOUTIQUE2)
par contre j'ai la page du back office mais impossible de rentrer dedans.
aurais tu une idée ?
car il accepte mes codes mai j'arrive sur rien
a bientot

Share this post


Link to post
Share on other sites
tu remplace ton ancien dossier d'admin par le contenu du nouveau répertoire admin


bonjour
je viens de voir qu'un autre que moi avait ce probleme de back office.
pour ma part impossible de rentrer dans mon BO mes codes sont accepter mais je tourne en boucle.
Dans votre explication vous dites de recopier admin de la mise a jour dans admin ?
si je comprend bien je dois copier ma sauvegarde de admin dans le nouveau admin ?
merci d'avance de votre aide

Share this post


Link to post
Share on other sites

Je ne pense pas que le problème d'arrondi soit du à l'install :

J'ai supprimé tous les fichiers du FTP, uploadé les fichiers de la version 1.3 en ayant bien sur remplacé les fichiers settings.inc.php, mails etc ...
et j'ai ensuite fait la mise à jour via /install

mais le problème d'arrondi est toujours là :(

Share this post


Link to post
Share on other sites
Je suis preneur de toute modification, je n'ai pas réussi pour l'instant à mettre la version 1.3 en fonctionnement.
Merci d'avance à toutes et tous


bonjour peut tu en dire plus, ou en est tu exactement ?

a+

Share this post


Link to post
Share on other sites
oui le commerce de nos jours ça fait mal à la tête !
Courage tu vas y arriver :)

bonjour
bon mise a jour reussi apparemment j'arrive sur la page maintenance.
pour plus de securité j'ai fait une autre boutique( ex : ancienne BOUTIQUE et la nouvelle BOUTIQUE2)
par contre j'ai la page du back office mais impossible de rentrer dedans.
aurais tu une idée ?
car il accepte mes codes mai j'arrive sur rien
a bientot


Salut,

Content que tu avances...
Peux tu préciser le problème ? message d'erreur ?

Share this post


Link to post
Share on other sites
oui le commerce de nos jours ça fait mal à la tête !
Courage tu vas y arriver :)

bonjour
bon mise a jour reussi apparemment j'arrive sur la page maintenance.
pour plus de securité j'ai fait une autre boutique( ex : ancienne BOUTIQUE et la nouvelle BOUTIQUE2)
par contre j'ai la page du back office mais impossible de rentrer dedans.
aurais tu une idée ?
car il accepte mes codes mai j'arrive sur rien
a bientot


Salut,

Content que tu avances...
Peux tu préciser le problème ? message d'erreur ?


bonjour

sur la page preference toujour ce maudit message erreur des arrondis

Share this post


Link to post
Share on other sites

Salut, MAJ correctement déroulée, mis à part le petit "soucis" du editorial.xml, penser à le remettre. Je vais voir pour JP77 si soucis d'arrondie.

Par contre sur toute mes pages rubriques / sous-rubriques et produits message d'erreur au dessus des titres : => intval($stop)); $smarty->assign($pagination_infos); ?>

Une idée ?

Share this post


Link to post
Share on other sites

De mon côté mise à jour depuis une version 1.2.5 sans aucun soucis. Je vais voir avec le temps si des problèmes se déclarent mais en tout cas pas de pb sur l'option d'arrondi...

Share this post


Link to post
Share on other sites

ReBonjour,
Je viens de découvrir un truc concernant le "field round mode : invalid" :

désolé par avance si je pars dans une direction qui n'est pas forcement la bonne, mais je ne suis très familier avec prestashop !

dans AdminPreferences.php il y à cette ligne :
'PS_PRICE_ROUND_MODE' => array('title' => $this->l('Round mode:'), 'desc' => $this->l('You can choose the rounding of prices, rounding always superior, inferior or classical rounding.'), 'validation' => 'isInt', 'cast' => 'intval', 'type' => 'select', 'list' => $round_mode, 'identifier' => 'value'),

Ce qui me fait penser que le champs mode d'arrondi doit renvoyer un nombre.

Dans le code source de la page preference dans le backoffice, le champ Select du mode d'arrondi est :
superiorinferiorclassical

Avec le plugin firefox "developer toolbar" j'ai transformé ce champ en "input" et entré le chiffre "2" dans le champ...
et la ça roule, pas d'erreur.

Ce que je viens de dire ne sert peut être à rien, ou aider les gens compétents à mieux cibler le problème.

visiblement, les valeurs "value="PS_ROUND_UP, DOWN, HALF" etc ... ne sont pas bien restranscrites en chiffre

Share this post


Link to post
Share on other sites
De mon côté mise à jour depuis une version 1.2.5 sans aucun soucis. Je vais voir avec le temps si des problèmes se déclarent mais en tout cas pas de pb sur l'option d'arrondi...


re

avez vous deja rempli les prix et produits cela vient peut etre de la ?

Share this post


Link to post
Share on other sites

Quelques remarques :

Dans la partie Back Office, gestion des commandes, les boutons sont mal placés, la calculatrice et le camion se chevauchent, et je n'ai plus (mais c'est normal) le bouton suppression commande. Les modifs sont compatibles avec la V1.3 ?

Share this post


Link to post
Share on other sites

re bonjour a tous

je sais pas si c'est une idée mais je trouver la 1.3 plus lente que la 1..2

avez vous le meme avis que moi ?

Share this post


Link to post
Share on other sites
@ JP77 : nan au contraire...

@ Tous : pas d'idée pour mon erreur smarty ? merci


alors là j'avoue que cela depasse mes competences

désolé

Share this post


Link to post
Share on other sites

Je n'en suis pas sur, mais pour afficher les prix HT, il faut aller dans Préférences > Produits et cocher quelque chose non ?

soit je l'ai rêvé dans la version précédente, soit il a disparu, soit prestashop m'abime le cerveau :( sniff

Share this post


Link to post
Share on other sites
Je n'en suis pas sur, mais pour afficher les prix HT, il faut aller dans Préférences > Produits et cocher quelque chose non ?

soit je l'ai rêvé dans la version précédente, soit il a disparu, soit prestashop m'abime le cerveau :( sniff


oui dans preference==> produit ==> et c'est en debut de page

Slt

Share this post


Link to post
Share on other sites

Serieux, je crois que ma mise à jour a foiré, j'ai ça en début de page :

Autoriser la commande de produits hors stock :
Oui Non

Activer la gestion des stocks :
Oui non

etc ...

je n'ai aucun choix pour les prix HT !

ça en plus du mode d'arrondi, je commence à me poser des questions :(

je n'ai pas encore mis en production, mais ça m'embête de refaire une install vierge...sachant qu'à la prochaine mise à jour ça risque de foirer encore :/

Share this post


Link to post
Share on other sites
Serieux, je crois que ma mise à jour a foiré, j'ai ça en début de page :

Autoriser la commande de produits hors stock :
Oui Non

Activer la gestion des stocks :
Oui non

etc ...

je n'ai aucun choix pour les prix HT !

ça en plus du mode d'arrondi, je commence à me poser des questions :(

je n'ai pas encore mis en production, mais ça m'embête de refaire une install vierge...sachant qu'à la prochaine mise à jour ça risque de foirer encore :/


moi je parle de la version 1.2.5.0 pas de la 1.3, pour ma part j'abandonne la 1.3 pour le moment et laisse ma 1.2.5.0 qui est prete et vas etre mise en ligne d'ici peu

a bientot

Share this post


Link to post
Share on other sites
Ok Ok, je pense que je vais revenir en 1.2.5.0 aussi... arf, quelle perte de temps !


je suis allé sur la partie essais de prestashop et dans preference ==> produits il y a bien ce que tu dis
je pense que PRESTASHOP a fait cela serieusement et que la version 1.3 fonctionne, mais cela peut provenir des hergeurs aussi.
pour ma part ayant deja realisé toute la boutique sur 1.2.5.0 et cette boutique etant complete et fonctionnant apres plusieurs test, je n'ais pas envie de tout refaire.
Et puis ce probleme d'arrondi ne me plait pas dans le sens ou je ne sais pas ce que cela vas donner en compta.
je prefere resté prudnet et attendre de voir ça plus tard voir si d'autre on des soucis aussi, meme si cela ne me plais guere de faire une mise a jour sur une boutique en ligne, plutot que de demarrer directement avec la bonne version.
Et puis de mon coté la 1.2.5.0 me suffit car si j'arrive a 100 produits ce seras le bout du monde, et les paiements ne m'interesse pas puisque nous allons mettre un paiement directement avec notre banque paypal est trop casse pieds et trop cher.
bon week-end

Share this post


Link to post
Share on other sites

Je vais refaire une install complète de la V1.3 pour tester, et si j'ai toujours les mêmes bugs..je downgrade en 1.2.5.0.

bonne Week end.

Share this post


Link to post
Share on other sites
Je vais refaire une install complète de la V1.3 pour tester, et si j'ai toujours les mêmes bugs..je downgrade en 1.2.5.0.

bonne Week end.


attends un peu de voir si d'autre on le meme probleme et une solution !
sauf si le temps presse pour la mise en route.

Share this post


Link to post
Share on other sites

C'est pas que je suis pressé, mais je dois aussi mettre à jour Ciel GesCom pour faire la syncho avec Atoo-Sync... donc je préfère faire des test sur une base saine de prestashop, car je suis sur que je vais avoir d'autre soucis de compatibilité entre Atoo-Sync et PS1.3.

j'attendrai d'avoir plus de retours utilisateur pour passer en 1.3.X

Merci, bon Week

Share this post


Link to post
Share on other sites
C'est pas que je suis pressé, mais je dois aussi mettre à jour Ciel GesCom pour faire la syncho avec Atoo-Sync... donc je préfère faire des test sur une base saine de prestashop, car je suis sur que je vais avoir d'autre soucis de compatibilité entre Atoo-Sync et PS1.3.

j'attendrai d'avoir plus de retours utilisateur pour passer en 1.3.X

Merci, bon Week

bon week end aussi

Share this post


Link to post
Share on other sites

Bonjour yoya

oui oui je l'ais vu ce matin c'est donc pour ça que je finalise 1.2.5.0 pour passer en prod j'attends juste le VAD de la banque donc pour 100 produits max 1.2.5.0 devrait tres bien marcher.
merci et bon week-end

Share this post


Link to post
Share on other sites

Je suis d'accord avec toi : si tout va bien en 1.1x 1.2x, pourquoi migrer ? :)

A bientot et bon week-end a toi également.
Pierre.

Share this post


Link to post
Share on other sites

pour ma part, upgrade OK en suivant la procédure préconisée. (ps 1.2.5 -> 1.3.10 stable)
Toutefois, impossible de créer de nouveaux comptes depuis ...
j'obtiens le code d'erreur : "une erreur s'est produite pendant la création de votre compte"
pas génial....

Share this post


Link to post
Share on other sites

Site upgradé de PS 1.25 en PS 1.3 Stable
Je simule la création d'un nouveau compte
Je renseigne le formulaire et je soumets la création de compte
j'obtiens :
01. “une erreur s’est produite pendant la création de votre compte”

Si je regarde ensuite dans le backoffice, le compte a tout de même été créé mais aucun mail n'a été envoyé
j'ai vérifié la messagerie : elle marche

Share this post


Link to post
Share on other sites
  • 2 weeks later...
3ème tentative de mise à jour (V3.1) toujours la page blanche (accueil) mais l'admin -BO- est là, tout semble en marche... sauf la page d'accueil


bonjour
la version 1.3.1 vient deja de sortir, moi j'attends que cela tourne sans probleme, je reste an 1.2.5.0 avec les modification de securité.

a bientot

Share this post


Link to post
Share on other sites
3ème tentative de mise à jour (V3.1) toujours la page blanche (accueil) mais l'admin -BO- est là, tout semble en marche... sauf la page d'accueil


As tu vérifié la mémoire dispo pour les scripts sur ton serveur ? 16M sont recommandés.

Share this post


Link to post
Share on other sites
  • 2 weeks later...
Bonjour,
même problème pour le mode arrondi,
1 erreur
1. champ Mode d'arrondi: invalide


Bonjour à tous.

J'utilise Prestashop depuis peu, malgré tout je crois avoir trouvé la réponse pour le problème d'arrondi.
J'étais également en 1.2.5 et j'ai effectué la mise à jour vers 1.3.1. Tout c'est bien passé sauf cette fichue erreur au niveau de l'arrondi dans préférence.
Je viens de me rendre compte ce matin que j'avais fait une erreur. En effet lors de ma mise à jour j'ai été reprendre le settings.inc.php de mon backup pour le remettre sur la mise à jour comme expliqué sur le wiki mais par mégarde j'ai dû remettre également config.inc.php.
J'ai donc ce matin retelecharger la version 1.3.1 et j'ai remis tel quel le fichier config.inc.php sur mon site en production et bingo plus d'erreur d'arrondi dans les préférences et je peux tous régler comme je veut.

Voilà j'espère que ça résoudra votre erreur. Tenez moi au courant.

Share this post


Link to post
Share on other sites
  • 4 months later...

As-tu remis ton ancien dossier images au complet à la place de l'ancien?
Sinon vire celui qui est sur ton serveur et re-upoad l'ancien (tu es censé avoir fait une sauvegarde de TOUT ton ancien dossier) ... de plus vérifie les droits du dossier.
Bonne manip

Share this post


Link to post
Share on other sites

C'est ballot.
Faire des sauvegardes de ton site via ftp de tes dossiers et par l'admin de ta banque de donnée.
Pense Y Et fait ça régulièrement.
Moi je le fais dès que j'ajoute ou retire des vêtements (cela peut-être quotidiennement)
Bon courage

Share this post


Link to post
Share on other sites

Bonjour les amis,

j'ai sorti un module qui vous permet de comparer 2 répertoires (par exemple 2 versions de prestashop), et d'en afficher toutes les différences.
Fini les galères de la mise à jour et les oublis de vos modifs.

Vous pouvez par exemple trouver toutes les modifications faites sur les modules entre les 2 versions, et donc débugguer beaucoup plus facilement si vous rencontrez des soucis.

C'est par ici si ça vous intéresse : MONTRE MOI LES DIFFERENCES

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More