Jump to content
CV1

Update 1.6.0.9 auf 1.6.1.7 -> Bestellbestätigung dauert eine Minute

Recommended Posts

Hallo!

 

Ich will von 1.6.0.9 auf 1.6.1.7 updaten. Viele Probleme habe ich dabei schon behoben. Z.B. MySql 5.6 statt 5.7 verwenden!!!

 

Allerdings habe ich derzeit noch ein Problem, dass mir schon den gesammten Tag gekostet hat: Die Bestellbestätigung im Frontend dauert ca. eine Minute!!! Obwohl im Backoffice die Bestellung gleich zu sehen ist.

 

Browser-Konsole: POST http://192.168.220.113:8080/shop/de/module/bankwire/validation [HTTP/1.1 302 Found 61129ms]

 

Im folgenden Kontext findet das ganze statt:

- Mit der MySql Version 5.6 verläuft die Migration erfolgreich - also ohne SQL-Fehler und andere Fehler

- Als Thema wurde wieder zurück auf das default Thema gewechselt.

- ich habe schon soviele Module wie möglich deaktiviert oder sogar gelöscht

- Es ist unabhängig davon, ob ich das advancedeucompliance module aktiviere oder deaktiviere

- Cache an/aus - Komplilieren immer/nie -> egal welche Konstellation, es hilft nichts

- auch an sämtlichen anderen Optionen, wie OPC usw. habe ich schon herumgestellt, aber gleiches Ergebnis

- Zum offline Test nehme ich die Banküberweisung oder Scheck als Zahlungsmittel

- Ich habe auch schon ein manuelles Update versucht - hat aber das gleiche Ergebnis gebracht.

 

- Mache ich eine 1.6.1.7 clean Installation dauert die Bestätigung ca. 3 Sekunden.

- Mache ich auf der 1.6.0.9er Version eine Bestellung dauert die Bestätigung ca. 3 Sekunden

(ist also ein Hinweis darauf, dass es nicht an meiner WAMP Konfiguration liegen sollte)

Edited by CV1 (see edit history)

Share this post


Link to post
Share on other sites

Habe mittlerweile herausgefunden dass es am versenden der Emails liegt. Schalte ich die Emails ab, funktioniert es. Die Test Email kann ich mit den SMPT Einstellungen aber dennoch verschicken.

 

Betreffende Zeile in validation.php vom Bankwire Modul:

$this->module->validateOrder($cart->id, Configuration::get('PS_OS_BANKWIRE'), $total, $this->module->displayName, NULL, $mailVars, (int)$currency->id, false, $customer->secure_key);

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More