Jump to content
Fashionresidenz

Sprachen im Frontoffice deaktivieren?

Recommended Posts

Hey Leute,

 

ich stehe vor einer kleinen Frage und zwar wie kann ich die Sprachen im Frontoffice deaktivieren?
Also nicht nur einfach dass der Kunde nicht verschiedene Sprachen aussuchen kann, sondern dass ich auch über Google nicht auf Seiten mit einer anderen Sprache komme. Dass der ganze Shop nur in deusch exisitert.

Ich aber trotzdem im Backoffice die verschiedenen Sprachen aktiviert und verfügbar habe, da ich diese für Amazon brauche aber nicht im Frontoffice. Ist das möglich? :)


Viele Grüße
Lucas

Share this post


Link to post
Share on other sites

Einfach, indem du das Modul Block Sprachauswahl, das du dafür eigens installiert hast, wieder deinstallierst oder zumindest deaktiviert. :)

Share this post


Link to post
Share on other sites

Hey eleazar,

 

das habe ich natürlich schon getan, damit ist aber, wie der Modulename schon sagt, nur die Auswahlmöglichkeit deaktiviert oder deinstalliert. Aber nicht die Sprache im Frontoffice an sich, guck das Module ist deinstalliert, trotzdem komme ich auf Seiten in einer anderen Sprache, über Google zum Bespiel:

 

https://www.fashionresidenz.de/en/sneaker/426-aircrew-sneaker-herren-schwarz-nobrand.html

Und da ich nicht vorhabe das komplette Frontoffice in 5 Sprachen zu übersetzen, würde ich gerne vermeiden dass man auf solche Seiten einer anderen Sprache als deutsch, überhaupt kommen kann.

Ich hoffe es ist einigermaßen verständlich was ich meine.

Viele Grüße
Lucas

Edited by Fashionresidenz (see edit history)

Share this post


Link to post
Share on other sites

Hallo Lucas,

bist du sicher, dasss dieses Kauderwelsch nicht vielleicht etwas mit deinem Template zu tun hat? Google ruft doch bei einer deutschen Seite nicht von sich aus die englische Version auf:

https://www.fashionresidenz.de/en/login? ....
... wenn auch die deutsche offenkundig verfügbar ist:
https://www.fashionresidenz.de/de/login? ...
Oder es liegt an den Einstellungen in PrestaShop, denn es scheint so, als hätte bei euch die englische Version Priorität. Ist vielleicht als Standard-Sprache Englisch eingestellt?

 

Übrigens akzeptiert Firefox wohl euer SSL nicht, weil die Seite als unsicher angezeigt wird. Es sind nämlich noch http-Links drin, z.B. hier:

<a class="has-category waves-effect waves-light" target="_self" href="http://www.fashionresidenz.de/de/">

Share this post


Link to post
Share on other sites

Hey eleazar,

so genau kann ich das selber nicht erklären, als Standartsprache ist Deutsch hinterlegt, aber mir ist es selber schon aufgefallen dass wenn ich bei google zum Beispiel nach einem expliziten Produkt suche, ich teilweise drei Ergebnisse von unserer Seite bekomme, weil die gleich Seite in 3 verschiedenen Sprachen bei Google gelistet ist.
Und wenn dann ein Kunde auf eine nicht zu 100% übersetzte Seite kommt, also alles was nicht deutsch ist, sieht das schon irgendwie bescheiden aus :/

 

Wenn du zum Beispiel hier mal guckst, dort wird der ein und der selbe Schuhe in schwarz drei mal angezeigt:

https://www.google.de/search?q=fashionresidenz+karnaby&ie=utf-8&oe=utf-8&client=firefox-b&gfe_rd=cr&ei=-IEDWJniH-SP8Qe3no6ACg#q=fashionresidenz+don+yuta

 

Und dass will ich eben abschalten ...

 

 

Ja, da bin ich zur Zeit dran, alle eingebundenen http Links in https umzuändern. Bei mir zeigt Firefox aber meistens nur einen http Link von Google an den ich einfach nicht finde im Quellcode ... gibt es eine schneller Methode als alle Datein per FTP durch zu gehen, weißt du das zufällig? :)

 

Wenn ich fragen darf, auf welcher Seite wird es bei dir explizit als nicht sicher angezeigt? Weil ich sehe überall nur Sicher Verbindung und Firefox hat Links blockiert, eben genannte http Links von Google Font ...

Edited by Fashionresidenz (see edit history)

Share this post


Link to post
Share on other sites

 

Und das will ich eben abschalten ...

 

Bist du sicher, dass es nicht an deinem Template liegt? Denn irgendwo müssen ja dem Crawler die verschiedenen Sprachversionen präsentiert werden. Google übersetzt doch hier nicht selbst!

 

Den einen Link habe ich doch von der Frontseite zitiert. Du findest solche Links, wenn du beispielsweise im Firefox mit dem Addon Firebug arbeitest und als Suchbegriff "http:" eingibst (im vorliegenden Fall könntest du auch nach der CSS-Class "has-category waves-effect waves-light"  suchen). Ansonsten wäre die schnellste Methode, das komplete Template-Verzeichnis auf den PC zu kopieren und über den Explorer zu suchen. (Ich bevorzuge allerdings den Total Commander, weil der mir ebenso wie beispielsweise Notepad++ eine Bulk-Änderung über alle Dateien erlaubt).

 

Der neue Microsoft-Browser Edge ist da übrigens nachlässiger und ignoriert solche Fehler wie schon sein Vorgänger IE.

Share this post


Link to post
Share on other sites

Also ich kann mir nicht vorstellen dass es am Template liegt, aber zur Sicherheit wie kann ich dass denn raus finden?

Ich hab die Sprachen natürlich im Backoffice aktiviert und dadurch erscheinen bei jedem Produkt etc. natürlich auch die Option für jede Sprache einen separaten Text einzugeben, aber wenn ich dann nur den Text für Deutsch eingebe wird der in die anderen Sprachen übernommen, aber das ist halt bei Bildern und Buttonbeschriftung halt nicht so ... vielleicht genügt dieses Aktivierung im Backoffice Google schon um diese zu crawln?

 

Der Tipp mot Total Commander war sehr gut, vielen Dank dafür schon mal :)
Habe das ganze mit Firebug auch versucht, da wird mir auch alles angezeigt, aber irgendwie bekomme ich es nicht über Firebug heraus zu finden in welcher Datei auf dem Server dieser Code steht ... da stelle ich mich zu blöd an -.-

 

Na okay, aber wenn dann soll das SSl Zertifikat auch zu 100% richtig laufen ;)

Share this post


Link to post
Share on other sites

Hast du die zusätzlichen Sprachen denn unter Lokalisierung -> Sprachen deaktiviert?

 

Was Google angeht, könntest du sicher auch eine Regel in die robots.txt einbauen, Besucher könnten per htaccess von einer fremdsprachigen Seite auf die entsprechende deutsche Seite umgeleitet werden.

Share this post


Link to post
Share on other sites

Nein, genau darum geht es mir ja, wenn ich die Sprachen unter Lokalisierung deaktiviere, können wir das Amazon Module für diese Länder nicht mehr nutzen, da dies erfordert dass für Italien, Frankreich etc. die jeweiligen Sprachen aktiviert sind im Shop.

Deshalb soll das Ganze im Hintergrund für eben Amazon bestehen bleiben, aber halt im Frontoffice deaktivert werden, weil wir unseren eigentlichen Shop erstmal nur in deutsch anbieten wollen.

 

Die verschiedenen Sprachen definieren sich ja über folgenden "link" fashionresidenz.de/fr ... /it .... /es .... und so weiter. Wäre es da möglich dass jegliche Aufrufe so einer Seite auf fashionresidenz.de/de umgeleitet wird? Genau nach so einer Lösung suche ich :)

Share this post


Link to post
Share on other sites

Wäre es da möglich dass jegliche Aufrufe so einer Seite auf fashionresidenz.de/de umgeleitet wird? Genau nach so einer Lösung suche ich :)

So etwas geht über eine Regel in der htaccess, du findest da massig Anleitungen im Internet.

Share this post


Link to post
Share on other sites

Hey rictools,

vielen vielen Dank für deinen Tipp :)
Das war ja eine Sache von 1 Minute, nun werden alle Seiten einer anderen Sprache auf die deutsche umgeleitet. Perfekt :)

 

Viele Grüße
Lucas

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More