Jump to content
tcschiavi

[RESOLVIDO] Não consigo inserir produtos na loja - "Salvar" inacessível VS 1.6.X - Hosp. compartilha

Recommended Posts

Olá

 

Minha versão do PrestaShop é 1.6.1.6 e estou usando o tema padrão.

 

Comecei a subir produtos na minha loja e acontece que os botões "Salvar e Permanecer" e "Salvar" ficam inacessíveis (imagem abaixo).

 

post-754806-0-12041700-1476447366_thumb.jpg

 

Alguém sabe como resolver?

 

Edited by tcschiavi (see edit history)

Share this post


Link to post
Share on other sites

Nao tem solucao. Um problema bem antigo, que em servidores compartilhados e mal configurados nao tem solucao. Em versoes antigas havia algumas indicacoes para alterar alguns scripts, no entanto o problema sao servidores mal configurados. Talvez vc. tenha sorte com uma das dicas.

 

Procure no fórum por spinning buttons.

 

https://www.google.at/search?q=spinning+buttons&ie=utf-8&oe=utf-8&gws_rd=cr&ei=I9YAWL2WDorTU7_YgpAM#q=spinning+buttons+prestashop+site:www.prestashop.com

  • Like 1

Share this post


Link to post
Share on other sites

Juro que não esperava isso!  :unsure:  :unsure:  :unsure:

 

A hospedagem onde estou com a loja preenche todos os requisitos da documentação do presta.  :unsure:  :unsure:  :unsure:

 

Vou seguir sua orientação e ver se acho alguma solução.

Share this post


Link to post
Share on other sites

Uma dúvida.

 

Em Parâmetros Avançados > Desempenho há uma opção que por padrão é desativada CCC (COMBINAÇÃO, COMPRESSÃO E CACHE).

 

O tema padrão é compatível com esse recurso?

 

Pergunto isso porque, me pareceu, que pode ajudar com o problema dos "spinning buttons".

Share this post


Link to post
Share on other sites

CCC serve primeiramente para o tema do front-office. O tema do back (administrativo) em segundo lógicamente tmb. é compatível com este recurso. Vc. desativando ou ativando a compressao, isto somente afeta o front.

  • Like 1

Share this post


Link to post
Share on other sites

Só uma dúvida.
Estou com o problema bem semelhante.
Eu tento criar um Novo Produto mais não aceita.

Quando eu tento editar um produto existente ele também não aceita.

 

Os botões (Salvar)  e (Salvar e Permanecer) estão habilitados normalmente.

Alguém sabe se isso é culpa do servidor também?

Estou utilizando a versão 1.6.1.7

Share this post


Link to post
Share on other sites

Ao que tudo indica sim! Parece que é um problema relacionado a hospedagem compartilhada.

 

Eu ainda estou aguardando retorno de um chamado que abri junto a minha hospedagem.

Share this post


Link to post
Share on other sites

No servidor dedicado sim... Na compartilhada da alguns "paus"... Mas acho que vou resolver... Resolvendo na compartilhado vou postar aqui!

Share this post


Link to post
Share on other sites

Olá!

 

A hospedagem sugeriu a troca de servidor, porém ainda compartilhado.

 

Fiz os testes incluindo novos produtos e rodou bem.

 

Vou encerrar esse tópico... 

 

Se alguém tiver alguma duvida, ou até mesmo saber mais sobre a hospedagem mande mensagem privada. 

 

Abraço!

Share this post


Link to post
Share on other sites

Encerra não, eu estou com problemas similares, porém eu uso VPS próprio, habilitei 512MB para scripts php, não sei o que poderia ser má configuração na hospedagem, uso ISP config, se alguém tiver uma sugestão...

No meu caso é bem raro as vezes que os botão ficam inacessíveis, mais é rotineiro eu tentar efetuar uma alteração nos produtos e não entrar de primeira, as vezes tenho que fazer umas 4 vezes pra funcionar.

 

Nas tags isso é terrível pois não tem como copiar elas

Share this post


Link to post
Share on other sites

Encerra não, eu estou com problemas similares, porém eu uso VPS próprio, habilitei 512MB para scripts php, não sei o que poderia ser má configuração na hospedagem, uso ISP config, se alguém tiver uma sugestão...

No meu caso é bem raro as vezes que os botão ficam inacessíveis, mais é rotineiro eu tentar efetuar uma alteração nos produtos e não entrar de primeira, as vezes tenho que fazer umas 4 vezes pra funcionar.

 

Nas tags isso é terrível pois não tem como copiar elas

Está usando qual versao php ? opcache instalado ? Se usa um VPS, porque nao instala ngnix over apache ? NA versao PS 1.6.1.6 infelizmente mesmo com ngnix tenho alguns segundos os botoes rodando na página dos produtos. Sinal que tmb. é problema do Prestashop em si e nao somente de servidores mal configurados. Já pensei em voltar para 1.6.1.5, que nao tinha este problema no ngnix.

 

Para ser sincera eu já faz tempo que nao mais uso o back-office do Prestashop para manusear os meus produtos, pedidos, clientes, etc. Estou usando o Presta Store MAnager. Este se loga diretamente no banco de dados e possue scripts próprios que funcionam sem problemas ;-)

  • Like 1

Share this post


Link to post
Share on other sites

Está usando qual versao php ? opcache instalado ? Se usa um VPS, porque nao instala ngnix over apache ? NA versao PS 1.6.1.6 infelizmente mesmo com ngnix tenho alguns segundos os botoes rodando na página dos produtos. Sinal que tmb. é problema do Prestashop em si e nao somente de servidores mal configurados. Já pensei em voltar para 1.6.1.5, que nao tinha este problema no ngnix.

 

Para ser sincera eu já faz tempo que nao mais uso o back-office do Prestashop para manusear os meus produtos, pedidos, clientes, etc. Estou usando o Presta Store MAnager. Este se loga diretamente no banco de dados e possue scripts próprios que funcionam sem problemas ;-)

 

Olá select,

 

Estou usando a versão do apache2 2.4.10 no Debian 8, pensei que esse ngnix era mais pra ser usado em windows (o pouco que eu li a muito tempo) vou pesquisar mais sobre ele e sobre esse Presta Store Manager.

 

Obrigado pela atenção :)

Share this post


Link to post
Share on other sites

Aykou, o meu continua do mesmo jeito, mas com um pequeno detalhe, esse problema só ocorre no Navegador Google Chrome, tenta fazer o mesmo procedimento de cadastrar ou alterar um Produto utilizando o Mozilla Firefox.

No meu caso, foi só trocar o navegador, e "problema resolvido".

Edited by felixhenrique (see edit history)

Share this post


Link to post
Share on other sites

Obrigado pela dica Felix.

Hoje quando acordei e pensei em passar para o fire fox, mas fiquei estudando sobre como fazer o nginx e o apache funcionarem juntos.

Eu sou muito apegado ao Chrome pois uso muitas coisas do google além de ser mais comodo para traduzir paginas, mas as vezes esse Chrome me faz passar tanta raiva... Mesmo com 8Gb de ramm e um processamento descente eu só trabalho na casa das 20 abas abertas com autocad, excel e outras coisas, e dependendo da pagina as vezes para de responder... coisa que não acontece com edger e firefox.

Share this post


Link to post
Share on other sites

Prezados, estou com o mesmo problema. Seja em localhost ou em hospedagem compartilhada. Se o problema é no servidor, será que alguém teria algum norte a ser seguido, pois se a solução é apenas trocar de servidor, posso ter que fazer isso centenas de vezes.

Share this post


Link to post
Share on other sites

Prezados, estou com o mesmo problema. Seja em localhost ou em hospedagem compartilhada. Se o problema é no servidor, será que alguém teria algum norte a ser seguido, pois se a solução é apenas trocar de servidor, posso ter que fazer isso centenas de vezes.

Servidor é um bicho complicado mesmo... Depois de décadas "mexendo" com isso, ainda sofro um pouco.

Eu não sou fã do Nginx pela dificuldade de configurar e por não ter um .htaccess automático.

 

Existem alguns servidores compartilhados (infelizmente não no Brasil) que funcionam bem.

Já trabalhamos com a A2Hosting / InMotion e Bluehost sem problemas, mas são todos lá fora e a latência pode atrapalhar bastante a performance.

E existem mais alguns recomendados pelo PrestaShop: https://www.prestashop.com/pt/ecommerce-hosting

 

No Brasil, VPS normalmente atendem a maioria das lojas. Basta saber configurar corretamente.

Para facilitar, nós recomendamos o cPanel, que facilita muito a vida de quem não é expert em servidores.

 

E existem também os servidores de alta performance como AWS e Jelastic, que têm um custo mais elevado.

Este ano começamos a utilizar o Jelastic em nossos projetos e é, sem dúvida, a melhor solução em termos de performance e custo x benefício x usabilidade.

Share this post


Link to post
Share on other sites

Eu estava falando do ngnix over Apache. Aí nada é compoicado pois o Apache serve como proxy e nao é necessario fazer nenhuma adaptacao em .htaccess.

Share this post


Link to post
Share on other sites

KingHost... O diferencial deles é o suporte (na minha opinião)

 

O meu sistema está na King Host, e além do site estar ultra hiper lento os produtos demoram séculos para salvarem, isso quando salva. Estou saindo de lá e não indico para ninguém, estou há semanas relatando o problema e o suporte é péssimo, sempre a culpa é do sistema e já fiz várias mudanças no meu, inclusive até ativei o Varnish por aconselhamento deles. 

Share this post


Link to post
Share on other sites

Galera desculpa a demora pro feedback.

 

Troquei o navegador e resolveu. No Chrome o erro era constante, no fire fox alterei mais de 200 produtos e só ocorreu um erro onde tive que atualizar a página que acredito que foi problema com a internet aqui.

Trabalhei junto com minha noiva na loja, ela usando chrome e eu firefox... vira e volta escutava ela revoltada.

Logo quem entende melhor disso poderia já ter uma noção do possível erro.

 

Conclusão, usem o firefox para trabalhar na loja.

 

Ah sim, eu uso vps da ovh que eu configurei com ISPConfig que é gratuito e eu achei tutorial dele aqui no forum (francês)

Edited by aykou (see edit history)

Share this post


Link to post
Share on other sites

A solução para mim foi trocar de navegador.

Como havia me acostumado com o Chrome não queria partir para outro, mas foi a solução.

Usando o Mozilla Firefox resolveu o problema. 

Uso uma hospedagem compartilhada em minha revenda e funciona normal, as vezes são esses navegadores mesmo...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More