Jump to content

[RESOLU] Migration 1.2.5 à 1.3.10 problème de panier


Recommended Posts

Bonjour,

Pour un client sur une version de dev (donc pas en production) j'ai fait une migration de 1.2.5 à 1.3.10, aucune problème ou message d'erreur lors de la migration ! aucun module qui touche aux produits d'installé.

Lors de l'ajout d'un produit au panier, l'appel ajax cart.php renvoie le produit à un prix de 0 ! sur le panier il affiche le produit avec un prix à 0, les frais de port et le total qui est bon !

Après sur "commander" message comme quoi le panier est vide.

quelqu'un a t-il eu se problème ? j'ai rien trouvé ce sur ce problème.

toute aide est bienvenu, sinon j'analyserai cart.php pour trouver le bug

Cordialement

Share this post


Link to post
Share on other sites

Bon apparemment j'aurai pas de réponse ou de piste donc je me débrouille seul (j'ai l'habitude), j'ai commencé à cerné le problème c'est une incompatibilité entre le thème qui focntion bien sur la 1.2.5 mais pas avec la 1.3.7 reste à déterminer maintenant ou se situe cette incompatibilité dans le thème !

Share this post


Link to post
Share on other sites

Un peux le même problème, je ne vois aucun frais de port s'ajouter au panier lors de l'ajout d'un article dans le caddie.
Que la personne soit enregistrer ou non rien n'apparait comme frais de port, y compris en fin de commende.
Avec la 1.2.5 j'avais pas ce soucis, est il encore possible de re télécharger la 1.25?

Share this post


Link to post
Share on other sites

Bonjour,

Est ce que le problème concerne aussi une nouvelle installation sur 1.3 stable ?

Olivier, la 1.3.7 n'est ce pas la RC7 et non la finale ? ( je viens de tilter la dessus , la final étant la 1.3.10 ... )

Tu ne pense pas qu'une maj vers la version finale te prendrai moins de temps que de chercher a corriger la version RC ? ou alors le problème concerne aussi la 1.3.10 et la je n'ai rien dis :P

Share this post


Link to post
Share on other sites

Bon la migration est faite voici les problèmes rencontré :

- Bug sur le module newsproducts ! Si pas de nouveau produit, le module n'affichage pas la phrase disant qu'il n'y a pas de nouveau produit mais affiche une image avec un ? ! suis repassé sur le module blocknewproducts de la 1.2.5
- Bug sur blockcart-json.tpl :
Ligne 23 :

{foreach from=$customizedDatas.$productId.$productAttributeId key='id_customization' item='customization'}{ldelim}


a changer par:

{foreach from=$customizedDatas.$productId.$productAttributeId key='id_customization' item='customization' name='customizedData'}{ldelim}




Ligne 29 :

{foreach from=$customization.datas key='type' item='datas'}


a changer par :

{foreach from=$customization.datas key='type' item='datas' name='customizations'}



Ligne 42: modifier la ligne comme ci dessous

{if !$smarty.foreach.customizations.last},{/if}


ligne 45 : modifier la ligne comme ci dessous

{rdelim}{if !$smarty.foreach.customizedData.last},{/if}



En fait $smarty.foreach.customizedData.last fait référence à la boucle de name customizedData mais celui ci n'est pas renseigné ! Donc quand on ajoutais plsu d'un produit au panier il y avait une erreur JS !

Ce bug ne c'est pas produit sur oboutique.fr mais sur le site que je suis en train de migrer oui.

Pour mon problème de panier remplie avec des prix à 0, le problème venait que j'appelais les tpl de cart dans un répertoire lié au thème et que je n'avais pas mis à jour ses tpl.

Voila plus qu'a passé en revu tous les sites.

Share this post


Link to post
Share on other sites
  • 3 months later...

Salut !!

J'ai le même problème que Olecorre pour le Panier.
Le total est bon mais dans la liste des produits tous sont a zéro euro !

Olecorre tu as trouvé la solution car tu avais apparament le modules "blockcart" dans ton thème.

Je me suis donc dis chez moi ça doit être cela aussi. je regarde dans mon theme et la ben non j'ai pas le module "blockcart". J'ai donc basculer sur le thème d'origine la la version 1.3.10 voir si cela fonctionnait normalement. Et la surprise ben non ca fonctionne pas mieux !!

Etonnant non ?

Alors pas con le Nexus je me suis dis, ben qu'est qu'il se passe si je copie le module "blockcart" dans mon theme ?

Et ben ca fonctionne ??????? J'y comprend plus rien surtout que sur mon serveur de Dev j'ai installer la version 1.3.10 avec mon vieux thème développer pour la version 1.2.5 et la ca marche impec.

Il ya bien donc eu un problème dans la migration !! Mais quoi ?? Mystere.

Remarque si il y avait que celui comme problème ca serait le bonheur !! Je commence a me demander si je vais pas repasser sur la version 1.2.5 tellement la migration génère des problèmes en cascade. J'ai pas encore tester la boutique avec un achat ; je redoute le pire !!!!

Share this post


Link to post
Share on other sites
  • 2 weeks later...

...Pour mon problème de panier remplie avec des prix à 0, le problème venait que j'appelais les tpl de cart dans un répertoire lié au thème et que je n'avais pas mis à jour ses tpl.


Je suis dans le même cas de figure ! Pourriez-vous me détailler comment réorienter les bons tpl de cart ?

Merci d'avance !

Mon POST traitant de mon problème: ici

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More