Jump to content
Sign in to follow this  
Guest Vega Networks

Problema após atualizar de 1.6.1.6 para 1.6.1.7

Recommended Posts

Guest Vega Networks

Após realizar o procedimento de atualização através do módulo 1-Click Update, ao tentar acessar minha (back e front office) tenho o seguinte erro (dev mode):

 

Parse error: syntax error, unexpected 'public' (T_PUBLIC) in /home/vegaprintcom/public_html/classes/Tools.php on line 424

 

 

E no arquivo informado no erro, exatamente no trecho informado, tenho o seguinte:

 

   /**
    * Get the current url prefix protocol (https/http)
    *
    * @return string protocol
    */
    public static function getCurrentUrlProtocolPrefix()
    {
        if (Tools::usingSecureMode()) {
 
        } else {
 
        }
    }
 
OBS: Sem estar com o "dev mode" habilitado, a loja apresenta erro 500 (HTTP ERROR 500 não consegue atender a esta solicitação no momento.) no Front Office, e no Back Office sempre o mesmo erro (informado no inicio).
 
Prestahop 1.6.1.7 (estava rodando norma no 1.6.1.6)
PHP 7
SSL CloudFlare (Estava normal no 1.6.1.6)
Estou usando as informações desse tutorial pra conseguir rodar sem problema o SSL da CloudFlare: https://nishantarora.in/prestashop-enable-cloudflare-flexible-ssl.naml
 
Alguém pode ajudar?
Edited by vegabusiness (see edit history)

Share this post


Link to post
Share on other sites

Faca um roll-back para a versao 1.6.1.6. A versao 1.6.1.7 está dando muitos problemas (inclusive com php7, que já foi otimizado).

Share this post


Link to post
Share on other sites
Guest Vega Networks

Faca um roll-back para a versao 1.6.1.6. A versao 1.6.1.7 está dando muitos problemas (inclusive com php7, que já foi otimizado).

Problema que nem consigo mais acessar o Back Office pra fazer o Roll-Back... vou mexer aqui, remover os ajustes específicos do CloudFlare e posto o resultado.

 

Obrigado!

Share this post


Link to post
Share on other sites
Guest Vega Networks

Problema que nem consigo mais acessar o Back Office pra fazer o Roll-Back... vou mexer aqui, remover os ajustes específicos do CloudFlare e posto o resultado.

 

Obrigado!

Conseguir reverter o erro e acessar o backoffice e tentei realizar o rollback da versão, mas houve erro, sinceramente desanimador, sorte que como sempre tenho backups físicos de tudo, então apaguei tudo, e restaurei o backu (arquivos e banco de dado)...Voltou ao normal para a versão 1.6.1.6.

 

PODE FECHAR O TÓPICO, NÃO TENHO MAIS INTERESSEM EM ATUALIZAR, OU IREI CONSEGUIR CONCERTAR (DEIXAR SEM FALAHAS) ESSA VERSÃO 1.6, SE NAO CONSEGUIR IREI DESISTIR DO PRESTASHOP, TEM SE MOSTRADO MUITO INSTÁVEL, DIFICIL TRABALHAR ASSIM.

 

OBRIGADO A TODOS!

Share this post


Link to post
Share on other sites

Infelizmente nao posso seguir nenhum dos seus erros. Pode ser um override mal feito, servidor mal configurado, ou problema mesmo com o cloudflare. Sinto nao ter sorte com o seu Prestashop, mas afinal das contas muitas coisas poderao estar acontecendo para que nao consiga rodar sem problemas.

 

Ler os logs de erro do servidor e também ativar o modo debug sempre é uma boa dica para ver o que anda errado. ;)

 

mod_security no seu servidor está em OFF?

 

Veja aqui a configuracao do servidor que sugerimos para rodar o Prestashop sem problemas: http://www.prestashop.com/forums/topic/236128-tutorial-servidor-configuracao-minima-para-ps-15/

Share this post


Link to post
Share on other sites
Guest Vega Networks

Host, host...

Sempre que for um servidor ruim, a experiência será ruim.

Ola Daniel, primeiramente lhe pergunto, você ao menos sabe qual servidor estou usando, para poder dizer que o mesmo é ruim? Creio que não néh, para defender sua bandeira Prestashop, é mais fácil jogar o problema para o servidor... Por isso, nem irei dar continuidade nessa resposta, inclusive nem sei porque esse tópico ainda está aberto, tendo em vista que já pedi para que o mesmo fosse fechado a dias, uma clara demonstração de desorganização...

Share this post


Link to post
Share on other sites

Ola Daniel, primeiramente lhe pergunto, você ao menos sabe qual servidor estou usando, para poder dizer que o mesmo é ruim? Creio que não néh, para defender sua bandeira Prestashop, é mais fácil jogar o problema para o servidor... Por isso, nem irei dar continuidade nessa resposta, inclusive nem sei porque esse tópico ainda está aberto, tendo em vista que já pedi para que o mesmo fosse fechado a dias, uma clara demonstração de desorganização...

Olá, colega

 

Não precisa ficar nervoso.

 

Não sei qual o host que utiliza, mas o comentário não foi especificamente para você. É apenas uma constatação geral.

Mesmo se sua loja estiver na maior instância da AWS, com load balancer, etc... se não for configurada adequadamente, a loja não vai funcionar corretamente. É fato.

 

Boa sorte.

Share this post


Link to post
Share on other sites

 Por isso, nem irei dar continuidade nessa resposta, inclusive nem sei porque esse tópico ainda está aberto, tendo em vista que já pedi para que o mesmo fosse fechado a dias, uma clara demonstração de desorganização...

Neste fórum nao fechamos tópicos, a nao ser por questado de moderacao (off-topic, nao permitir posts, etc...). Se o seu problema estiver resolvido, edite o seu primeiro tópico com o botao "more reply options" e acrescente ao título [solved] ou [resolvido].

Share this post


Link to post
Share on other sites
Guest Vega Networks

Neste fórum nao fechamos tópicos, a nao ser por questado de moderacao (off-topic, nao permitir posts, etc...). Se o seu problema estiver resolvido, edite o seu primeiro tópico com o botao "more reply options" e acrescente ao título [solved] ou [resolvido].

Olá selectshop.at... tentei realizar a edição do título conforme sugerido, seguindo suas informações, mas pra mim o título não está editável...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More