Jump to content
Sign in to follow this  
Guest Vega Networks

Erro de login no back office Prestashop 1.6.1.6

Recommended Posts

Guest Vega Networks

Olá amigo, estou passando um problema bem estranho com minha loja, que confesso que estou até pensado de migrar para outra plataforma, minha última tentativa de continuar usando o Prestashop é com esse tópico, bom, estava tudo normal, sem nenhum problema, ai instalei um "desgramado" de um módulo chamado mobassistantconnector, que serve pra conectar em um app para android para ver informações de pedidos, clientes e etc... fiz todos os ajustes, e funcionou normal, vi os dados no celular, porém depois que fiz logout no back office e posteriormente tentei fazer login, já não funcionou mais, com isso ficou claro que isso ocorreu depois de usar essa porcaria de módulo, o erro é o seguinte, tento fazer login com os dados certos, e não consigo, não recebo msg de erro nenhum, porém não entra, a tela vai como se fosse logar, e volto pro mesmo lugar, se eu colocar um usuário inexistente. apresenta mensagem que o funcionário não existe, à partir dai tentei varias coisas que li aqui no fórum e em outros lugares e tudo sem sucesso... quando vi que tiha dado algo realmente errado, resolvi restaurar um backup recente que eu tinha, e ai que minha preocupação começou, pois peguei os arquivos, restaurei tudo, peguei o banco de dados bom, restaurei etc etc, tentei fazer login (crente que iria dar tudo certo, afinal estava usando o backup da loja quando estava funcional) porém para o meu espanto, o problema persiste, mesmo estando usando os arquivos e banco de dados "bons"... ativei o modo developer, e não tenho nenhum erro apresentado... já fiz muitas coisas, inclusive os procedimentos de limpeza de cache, cookies etc etc...

 

Alguém tem alguma ideia pra me dar antes que eu apague essa loja toda, abandone o Prestashop e parta para uma próxima???

 

Muito obrigado desde já à todos que ajudar.

 

Informações Técnicas

Prestahop 1.6.1.6

PHP 7

SSL CloudFlare (que sempre funcionou sem problemas)

Share this post


Link to post
Share on other sites

O erro que descreve é um erro do cache. Vc. deveria deletar o cache do browser do seu dispositivo móvel e tmb. o cache do servidor. Eu por minha vez nao conheco nínguem que usando CloudFlare conseguiu implementar o Prestashop sem problemas. A maioria acabou desistindo mesmo e mudou para um servidor VPS (com ou sem ngnix) ou entao para servidores e uso de servidores mídia para deslocar grandes dados (imagens e videos).

Share this post


Link to post
Share on other sites
Guest Vega Networks

O erro que descreve é um erro do cache. Vc. deveria deletar o cache do browser do seu dispositivo móvel e tmb. o cache do servidor. Eu por minha vez nao conheco nínguem que usando CloudFlare conseguiu implementar o Prestashop sem problemas. A maioria acabou desistindo mesmo e mudou para um servidor VPS (com ou sem ngnix) ou entao para servidores e uso de servidores mídia para deslocar grandes dados (imagens e videos).

Olá,

Comigo estava super normal, SSL ativo, sem erros, muito rápido tudo normal, mas foi só instalar esse módulo que informei que minha loja parou... Para rodar CloudFlare no Prestashop sem problema, depende apenas de ter um bom servidor (que é o meu caso) e realizar alguns ajustes específicos para CloudFlare, no banco de dados e em alguns arquivos do Prestashop que funcionará super bem, o problema foi apenas esse módulo que de alguma forma "bugou'' alguma coisa no login da minha loja e não estou conseguindo solucionar. Já limpei cache do smartphone e do notebook que uso pra gerenciar a loja, agora quando você se refere cache do servidor, de qual cache está se referindo, pois servidores tem pelo menos uns 4 caches que podem ser liberados (memoria, armazenamento, dns e apache/ngnix)... de qual você de fato se refere?

 

Obrigado pelo retorno!

Share this post


Link to post
Share on other sites
Guest Vega Networks

O erro que descreve é um erro do cache. Vc. deveria deletar o cache do browser do seu dispositivo móvel e tmb. o cache do servidor. Eu por minha vez nao conheco nínguem que usando CloudFlare conseguiu implementar o Prestashop sem problemas. A maioria acabou desistindo mesmo e mudou para um servidor VPS (com ou sem ngnix) ou entao para servidores e uso de servidores mídia para deslocar grandes dados (imagens e videos).

ATUALIZAÇÃO:

 

Ou no caso você se refere à esses caches do próprio Prestashop?

 

/public_html/cache/smarty/cache

/public_html/cache/smarty/compile

Share this post


Link to post
Share on other sites
Guest Vega Networks

RESOLVIDO:

 

Acessei o PHPAdmin, cliquei em psxl_configuration e localizei dentro dele o PS_COOKIE_LIFETIME_BO e alterei ele para 5... PROBLEMA RESOLVIDO!

 

100% FUNCIONANDO COM CLOUDFLARE... SE ALGUÉM PRECISA DE AJUDA PRA CONFIGURAR O CLOUDFLARE NO SEU PRESTASHOP, É SÓ ME AVISAR.

 

OBS: MODERADORES, PODE FECHAR O TÓPICO.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More