Jump to content

Błąd 500 - problem ze Smartami


madnessr
 Share

Recommended Posts

Witam,

 

dotychczas sklep (Prestashop 1.6.1.4) działał jak należy, ale pojawił się spory problem z błędem 500. 

 

Jest on spowodowany prawdopodobnie przez cache. Po usunięciu zawartości z folderu cache/smarty/complite sklep zaczyna działać, ale tylko na chwile do momentu gdy zostaną wygenerowane kolejny raz pliki.

 

Nie mogę wyłączyć działania cache. Próbowałem już przez bazę danych i w panelu administracyjnym - pliki ciągle pojawiają się w tej lokalizacji. 

 

Screenshot_1.png

 

Przykłady wyświetlanych komunikatów po uruchomieniu wyświetlana błędów:

Fatal error: Uncaught --> Smarty: Invalid compiled template for './elements/options_input.tpl' <-- thrown in /mnt/web021/a2/43/53481943/htdocs/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 182
faultCode0faultStringFatal error:Uncaught --> Smarty: Invalid compiled template for '/mnt/web021/a2/43/53481943/htdocs/admin816bkcfhk/themes/default/template/controllers/dashboard/helpers/view/view.tpl' <-- thrown in /mnt/web021/a2/43/53481943/htdocs/tools/smarty/sysplugins/smarty_internal_templatebase.php on line 182
faultCode0faultStringFatal error:Uncaught --> Smarty: unable to write file /mnt/web021/a2/43/53481943/htdocs/cache/smarty/compile/d9/c2/4b/wrt57aba1806f7ab5_98521203 <-- thrown in /mnt/web021/a2/43/53481943/htdocs/tools/smarty/sysplugins/smarty_internal_write_file.php on line 46[PrestaShop] Fatal error in module file :/mnt/web021/a2/43/53481943/htdocs/tools/smarty/sysplugins/smarty_internal_write_file.php:
Uncaught --> Smarty: unable to write file /mnt/web021/a2/43/53481943/htdocs/cache/smarty/compile/d9/c2/4b/wrt57aba1806f7ab5_98521203 <-- thrown

Uprawnienia 777 nadane folderowi cache.

 

Czy spotkaliście się z czymś takim? Jak można to rozwiązać?

 

Share this post


Link to post
Share on other sites

Jakiś moduł ostatnio instalowałeś, lub robiłeś ręczne poprawki w kodzie zaplecza?

Nie ma templatki options_input.tpl lub jest błędna ścieżka do niej.

A pozostałe błędy są pochodną pierwszego błędu.

Jak nie ma templatki to nie może jej skompilować, jak nie może skompilować to i nie może zapisać.

Share this post


Link to post
Share on other sites

Jakiś moduł ostatnio instalowałeś, lub robiłeś ręczne poprawki w kodzie zaplecza?

Nie ma templatki options_input.tpl lub jest błędna ścieżka do niej.

A pozostałe błędy są pochodną pierwszego błędu.

Jak nie ma templatki to nie może jej skompilować, jak nie może skompilować to i nie może zapisać.

Dzięki za odpowiedź. Problem zaistniał z błahego powodu. Okazało się, że skończyło się miejsce przeznaczone na stronę. Było wolne około 100 KB i smarty źle się generowały. Po powiększeniu FTP i wyczyszczeniu cache wszystko działa jak należy.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More