Jump to content
Sign in to follow this  
nagneau

le détail du panier ne s'affiche pas

Recommended Posts

Bonjour,

En local tous marche bien, mais dans mon site en ligne, le détail des commandes ne s'affiche pas au niveau du panier, il s'affiche dans le petit résumé à droite mais rien lorsque je clique sur panier et je n'arrive pas à trouver d'où vient le problème d'autant qu'en local tout marche bien.
Pour voir et tester l'anomalie : http://www.parfumsdecouleur.com
Merci de votre aide, je ne sais plus quoi faire, j'ai vérifié les fichiers mais je ne trouve rien.

Share this post


Link to post
Share on other sites

Hello,

En essayant d'accéder à ton site j'ai eu un gros plantage Firefox, alors je laisse la main à ceux qui arriveront à y accéder :P

Share this post


Link to post
Share on other sites

J'ai hier eu un petit plantage du serveur, tu as du mal tomber.
Ce matin, tout va bien, sur firefox, googlechrome et ie.
Pour mon bug sur le détail des commandes, as tu une idée du fichier qui peut être en anomalie ? J'ai remplacé mon modèle de thème par celui de prestashop et je garde la même erreur, j'ai donc vérifié le dossier classes et rien de nouveau, j'ai commencé à recharger aussi le dossier tools, mais toujours rien.
si quelqu'un a une idée, merci de votre aide.

Agnès H.

Share this post


Link to post
Share on other sites

Je ne sais plus quoi faire, je suis même prête à payer pour que l'on me trouve la solution, j'ai rechargé toute les pages de mon site du local vers le site en ligne et pourtant, dans la page order.php, lien du Panier, impossible d'afficher le détail de la commande.

Pourtant en local tous marche, personne ne sait où je dois chercher ?, Quelqu'un peut il m'aider ? je sais bien que tous le monde est très occupé mais je ne sais vraiment plus quoi faire alors merci de votre aide.

Pour le reste tous semble marcher puisque nous avons quand même eu 2 commandes ce week-end, mais certaines personnes bloque sur la difficulté à modifier le contenu du panier, j'ai vraiment besoin d'aide et c'est vraiment urgent.

Agnès H.

Share this post


Link to post
Share on other sites

Je t'ai répondu en MP suite au message que tu m'as envoyé.

C'est juste que le lien du bouton de ton panier ne renvoie pas à la bonne page ;)

Share this post


Link to post
Share on other sites

Merci beaucoup de ton aide, savoir que quelqu'un d'autre se penche sur la question, cela m'aide beaucoup. Pour le bouton, malheureusement, cela ne résous pas le problème, je cherche du côté d'une incompatibilité avec un des modules que j'ai mis en place pour gérer la BO mais je ne comprend pas bien comment cela pourrais empêcher l'affichage du détail du récapitulatif de la commande, et malheureusement, après cela, je ne saurais vraiment plus quoi faire, puisque j'ai déjà réinstallé tous mes modules, les classes, le tools, vérifié l'url canonique,... etc et pour l'instant rien à faire, ce fichu détail de la commande refuse de s'afficher en ligne alors qu'en local tous va bien.
Bonne journée,

Agnès H.

Share this post


Link to post
Share on other sites

Bonjour nagneau,
si tous va bien en local essaye de pencher au niveau de votre .htaccess et surtout cote environnement de ton serveur d'hebergement et desactive ton registre global bon courage.

Share this post


Link to post
Share on other sites

Bonjour,
et vraiment merci de votre aide.
Pour le .htaccess, j'utilise le même que pour cet autre site : http://www.huiles-rares.com et pour ce site là qui est hébergé sur le même serveur VPS de LWS, je n'ai aucun problème. J'ai essayé de vérifier les différents fichiers de ces deux sites pour voir d'où pouvais venir le problème, mais pour l'instant je n'ai rien trouvé qui puisse expliquer ce problème.
Il y a malgré tous quelques chose, mais je ne vois pas trop comment cela pourrait intervenir à ce niveau là, c'est que j'ai mis la base de donnée de prestashop, sur la même base de donnée que joomla avec lequel je gère la partie institutionnelle du site pour autant, le préfixe de mes tables n'est pas le même donc cela ne devrait pas poser de problème.
Je vais refaire mes comparaisons fichier par fichier en espérant trouver d'où ça vient, si en attendant quelqu'un a une autre idée je suis à l'écoute, je peut même vous donner en MP les accès au ftp si cela peut vous permettre de m'aider.

Bonne journée à tous et merci à la communauté.

Agnès H.

Share this post


Link to post
Share on other sites

Bin pourtant ça a l'air de marcher maintenant. Si je clique su ton panier j'arrive bien sur le récapitulatif de la commande...

Share this post


Link to post
Share on other sites

Le problème ne vient pas de l'accès au récapitulatif de la commande, mais au fait que sur ce récapitulatif, on ne voit pas apparaitre les produits contenus dans cette commande soit toute les lignes de détail mais aussi la ligne avec le dernier produit commandé.
pour montrer le problème exacte, voir l'image du récapitulatif de la commande en ligne. si on regarde le résumé du menu de droite, on voit qu'il devrait y avoir une ligne fesant apparaitre l'eau de couleur rouge qui a été commandé.

Merci encore de ton aide,

Agnès H.

23731_vPwiSP6EMh0U6mkevqbw_t

Share this post


Link to post
Share on other sites

Ah oui effectivement je n'avais pas remarqué ça...
Je vais voir si je trouve la source du problème.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More