Jump to content
koskimaa

301 -> 302 -> redirect loop/chain [SOLVED]

Recommended Posts

 

Site: supergangu.com

 

There is a multi-step redirect chain that significantly slows down my store page load time when a client tries to the shop. It jumps couple of times (19 times (!) according to https://varvy.com/tools/redirects/) and then finally ends up on the front page.

 

It also seems to redirect anyone that visits the site for the first time through a suburl (Example: supergangu.com/famicom) to the root page (supergangu.com).

 

Config:

- SSL on all pages activated in Prestashop back office

- Valid AlphaSSL certificate

Under SEO & URLs my setting looks like follows :

Shop domain : supergangu.com
SSL domain : supergangu.com
Base Url : /

 

I have tried:

- Regenerating the .htaccess file

- Forcing only https by adding this in my .htaccess file:

RewriteCond %{HTTPS} off 
RewriteCond %{HTTPS_HOST} !^supergangu.com$ [NC]
RewriteRule ^(.*)$ https://supergangu.com/$1 [L,R=301]

- Activating HSTS by adding this in my .htaccess file:

Header always set Strict-Transport-Security "max-age=63072000; includeSubdomains;"

- Changing "Redirect to the canonical URL" under SEO & URLs in backoffice to "No redirection". 

- Disabling Apache Multiviews.

- Asking my host (siteground.com), they can't see any problem with my server config

 

Nothing of what I've tried have solved the problem!

 

What in the name of the Prestashop god can be wrong!?! All I can think of is that some module I'm using is causing the problem, but how could I know which one? And if that's wrong too, how can I fix the problem?

 

I need help, bad! I've been working on building my store for 4 months and want to launch as soon as the last bugs on my site are fixed.

 

Thanks in advance to any kind soul that tries to help!

 

/ Koskimaa

 

Edited by koskimaa (see edit history)

Share this post


Link to post
Share on other sites

I figured it out.

 

A module called "Auto detect language and currency" by idnovate was causing the problem. Disabling the module instantly fixed the problem.

 

I'm going to contact the developer tomorrow to have the issue fixed.

 

Lesson learned: Always check if modules can be the cause of a problem!!

Edited by koskimaa (see edit history)
  • Like 2

Share this post


Link to post
Share on other sites
On 7/23/2016 at 6:33 PM, koskimaa said:

I figured it out.

 

A module called "Auto detect language and currency" by idnovate was causing the problem. Disabling the module instantly fixed the problem.

 

I'm going to contact the developer tomorrow to have the issue fixed.

 

Lesson learned: Always check if modules can be the cause of a problem!!

Thanks for help Man! I`ve been looking for the solution for over 5 days... I haven`t relised that this module can couse the problem.. On the other hand did developer of module resolve the redirection problem?

 

Share this post


Link to post
Share on other sites
On 1/7/2019 at 9:00 PM, bardock86 said:

Thanks for help Man! I`ve been looking for the solution for over 5 days... I haven`t relised that this module can couse the problem.. On the other hand did developer of module resolve the redirection problem?

 

 

On 7/23/2016 at 5:33 PM, koskimaa said:

I figured it out.

 

A module called "Auto detect language and currency" by idnovate was causing the problem. Disabling the module instantly fixed the problem.

 

I'm going to contact the developer tomorrow to have the issue fixed.

 

Lesson learned: Always check if modules can be the cause of a problem!!

Thanks for this. You really saved a life and some bucks. I have been battling with mine for 5 days before I stumbled on your post. Mine was caused by Auto Switch Language and Currency by Knowband.

Anyone having such issues should simply disable any Language and Currency switch Module or any related Module, no matter the Developer of the Module.

Share this post


Link to post
Share on other sites
On 7/23/2016 at 6:33 PM, koskimaa said:

I figured it out.

 

A module called "Auto detect language and currency" by idnovate was causing the problem. Disabling the module instantly fixed the problem.

 

I'm going to contact the developer tomorrow to have the issue fixed.

 

Lesson learned: Always check if modules can be the cause of a problem!!

Apologies for the delay. Did you contact us? Did we resolve the problem?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More