Jump to content

allow_url_fopen глюк, белый экран админки


Recommended Posts

Доброго всем.

 

Prestashop 1.6.0.14

 

Без видимой причины белый экран админки.

Отображение ошибок включено - пусто. В логах сервера тоже пусто.

Протоколирование скриптом возвращает только предупреждения

334","(Warning) Cannot modify header information - headers already sent by (output started at admin_folder/index.php:34)"

Но при этом всё должно работать.

 

Пермиссии проверял, ставил 0777 на весь корень, не влияет, белый экран.

Кэш (/cache/smarty/cache & cache/smarty/compile) чистил

Ради эксперимента, залил сайт на вирт. машину, там всё работает ОК.

 

Вывод - проблема в настройках хостинга.

 

Если отключить allow_url_fopen, админка загружается, но  полноценно не работает ( и не должна без allow_url_fopen).

 

php.ini в системе один. Рекурсия и клетки не используются.

SecFilterEngine и SecFilterScanPOST в .htaccess отключены.

 

 

Прилагаю php.ini и вывод info()

 

Какие зависимости у allow_url_fopen? 

 

Нужна помощь сообщества, тупичёкс.......

php.ini.txt

phpinfo().html

Edited by BSD-shnik (see edit history)

Share this post


Link to post
Share on other sites

Prestashop разработчик активный режим, чтобы увидеть, который дает сбой. Не говорят на русском языке написано с переводчиком. Чтобы включить этот режим необходимо получить доступ к папке Prestashop конфигурации и изменить файл и положить defines.inc.php режим разработчика истина.

Share this post


Link to post
Share on other sites

Prestashop разработчик активный режим, чтобы увидеть, который дает сбой. Не говорят на русском языке написано с переводчиком. Чтобы включить этот режим необходимо получить доступ к папке Prestashop конфигурации и изменить файл и положить defines.inc.php режим разработчика истина.

Gracias, puede escribir español aqui, entiendo sin problemas. Pero todos parametros de ajustación estan insertando ya, se vuelve nada, la pagina esta blanco.

 

 

wagood 

Смотрел, мало информативно.

$timer_start = microtime(true);
if (!defined('_PS_ADMIN_DIR_'))
        define('_PS_ADMIN_DIR_', getcwd());

if (!defined('PS_ADMIN_DIR'))
        define('PS_ADMIN_DIR', _PS_ADMIN_DIR_);

require(_PS_ADMIN_DIR_.'/../config/config.inc.php');   (строка 34)!
require(_PS_ADMIN_DIR_.'/functions.php');

Но с такого рода варнингами всё должно работать. А вообще, впечатление, что Prestashop неможет законнектиться куда то. online ecosystem и всё такое.....

 

Edited by BSD-shnik (see edit history)

Share this post


Link to post
Share on other sites

Перезапишите файл index.php из установочного архива или ещё откуда, похоже у вас какой-то "левый" символ в строках затесался к примеру пробел перед <?php или ещё чего

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More