Jump to content

301 redirect : j'y comprends rien


Recommended Posts

Bonjour,

 

Mon site (PS 1.6) est accessible par 4 noms de domaine :

 

barking-king-com

www.barking-king.com

 

+ les meme en .fr.

 

Dans mon back-office l'URL du site est mise sur barking-king.com.

Un test realise avec http://www.ragepank.com/redirect-check/ indique :

http://barking-king.com returns a 301 (permanent) redirect
http://www.barking-king.com returns a 302 (temporary) redirect
http://barking-king.fr returns a 302 (temporary) redirect
http://www.barking-king.fr returns a 302 (temporary) redirect

Apres des recherches sur le forum et d'autre sites, j'ai ajoute dans mon .htaccess les lignes suivantes :

RewriteCond %{HTTP_HOST} ^www\.barking-king\.com [NC]
RewriteRule ^(.*)$ http://barking-king.com/$1 [L,R=301]

(avant le ~~start).

 

Re-test avec l'outil cite, et exactement le meme resultat : le www .com retourne un 302 alors que, si je me suis pas goure bien sur, je declare explicitement un 301 dans mon .htaccess...

 

Je suis sur que cette question a deja ete posee, resolue, discutee... J'ai cherche, je n'ai pas trouve. Je m'excuse donc en avance si c'est un doublon....

 

Merci pour votre aide.

Share this post


Link to post
Share on other sites

Salut,

 

Si les redirections sont effectives AVANT ta redirection en htaccess il est clair qu'il s'agit d'une redirection serveur faite par ton hébergeur ou ton registrar (voire ton prestataire si tu en as un).

 

La redirection serveur passe donc sans doute avant celle faite dans ton htaccess...

 

Regarde du côté de ton hébregeur/registrar pour changer cette 302 en 301, bien que le résultat soit le même dans ton cas, surtout que tu rajoutes une surcouche en redirigeant encore vers le /fr !

Share this post


Link to post
Share on other sites

Salut et merci de ta reponse!

 

Evidemment.... j'etais sur d'avoir fait ca proprement et du coup je me suis meme pas pose la question, mais cote OVH j'avais configure ca en 302 comme un cretin....

Merci de m'avoir mis le nez dedans, c'est reconfigure et une fois propage ca devrait marcher (du coup j'attend 24 h pour marquer resolu ;) ).

 

Merci encore!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More