Jump to content

Recommended Posts

bonjour.

j'ouvre un nouveau topic pour mon problème pour ne pas polluer les ancien.

 

pour résumer j'ai créer mon site en local sous wamp, j'ai suivis les tuto pour migrer sur mon serveur 1and1 et mon problème est que je me retrouve avec une page blanche.

suite à des échange avec PrestaShop Legend, dans ma base de donnée je n'ai pas la ligne PS_shop_url.

 

je suis sous prestashop 1.6.1.5 

 

merci d'avance.

Share this post


Link to post
Share on other sites
Guest

première question : est-ce que le site fonctionne bien en local ?

et avez-vous essayé de réinjecter la base SQL sur votre hébergement 1&1, si oui est-ce qu'il y a des messages d'erreur dans phpmyadmin ?

 

Sinon, donnez moi les accès en privé et je vais regarder ce qui cloche, mettez bien l'archive de votre export SQL local sur le répertoire racine au format compressé afin de pouvoir débloquer (peut-être) la situation.

 

sinon j'ai une 3eme question  : pourquoi avoir choisi 1&1 qui est un des pires hébergeurs du net ?

Edited by Guest (see edit history)

Share this post


Link to post
Share on other sites

dans ma base de donnée je n'ai pas la ligne PS_shop_url.

Donc ton backup est incomplet.

Tu as la table ps_zone? elle contient des enregistrements?

Share this post


Link to post
Share on other sites

première question : est-ce que le site fonctionne bien en local ?

et avez-vous essayé de réinjecter la base SQL sur votre hébergement 1&1, si oui est-ce qu'il y a des messages d'erreur dans phpmyadmin ?

 

Sinon, donnez moi les accès en privé et je vais regarder ce qui cloche, mettez bien l'archive de votre export SQL local sur le répertoire racine au format compressé afin de pouvoir débloquer (peut-être) la situation.

 

sinon j'ai une 3eme question  : pourquoi avoir choisi 1&1 qui est un des pires hébergeurs du net ?

bonjour,

j'ai réinjecté la base sql comme elle était, j'ai un message d'erreur

Erreur

Requête SQL :

 

 

--

-- Contenu de la table `ps_address_format`

--

 

INSERT INTO `ps_address_format` (`id_country`, `format`) VALUES

(1, 'firstname lastname\ncompany\nvat_number\naddress1\naddress2\npostcode city\nCountry:name\nphone\nphone_mobile'),

(2, 'firstname lastname\ncompany\nvat_number\naddress1\naddress2\npostcode city\nCountry:name\nphone\nphone_mobile'),

(3, 'firstname lastname\ncompany\nvat_number\naddress1\naddress2\npostcode city\nCountry:name\nphone\nphone_mobile'),

(4, 'firstname lastname\ncompany\naddress1\naddress2\ncity State:name postcode\nCountry:name\nphone\nphone_mobile'),

(5, 'firstname lastname\ncompany\nvat_number\naddress1\naddress2\npostcode city\nCountry:name\nphone\nphone_mobile'),

(6, 'firstname lastname\ncompany\nvat_number\naddress1\naddress2\npostcode city\nCountry:name\nphone\nphone_mobile'),

(7, 'firstname lastname\ncompany\nvat_number\naddress1\naddress2\npostcode city\nCountry:name\nphone\nphone_mobile'),

(8, 'firstname lastname\ncompany\nvat_number\naddress1\nadd[...]

 

MySQL a répondu: dot.gif

#1062 - Duplicate entry '1' for key 'PRIMARY' 

 

j'ai choisi 1and1 il y a 3 ans quand j'avais un simple besoin. je ne connaissais encore pas grand chose, quel est le mieux aujourd'hui pour un prestashop?

 

 

 

Donc ton backup est incomplet.

Tu as la table ps_zone? elle contient des enregistrements?

j'ai une table ps_timezone mais pas simplement ps_zone. elle contient que des nom de pays et région

Share this post


Link to post
Share on other sites

Donc backup ou ton transfert est complètement vérolé.

 

Export (backup):

mysqldump -u<user> -p<password> <database> > fichier.sql

Share this post


Link to post
Share on other sites

merci pour votre retour rapide.

je ne suis pas encore super calé donc j'ai pas bien compris Export (backup):

mysqldump -u<user> -p<password> <database> > fichier.sql

 

 

pardon j'avais pas vu la 2eme page, suis un peu long a comprendre. il y a bien la table ps_zone avec europe, asia etc....

Edited by ludovic mantion (see edit history)

Share this post


Link to post
Share on other sites
Guest

Si vous voulez de l'aide il faut communiquer les informations concernant votre hébergement à quelqu'un.

 

Quand vous dites mon serveur 1&1, est-ce que vous avez vraiment loué un serveur dédié ou bien alors simplement un hébergement mutualisé chez eux ?

Share this post


Link to post
Share on other sites

C'est un serveur mutualisé. J'ai prévu de passer sur un dédier dès que j'ai fini mon site. Il faut que je vous donne mes acces chez 1and1??

Share this post


Link to post
Share on other sites
Guest

C'est un serveur mutualisé. J'ai prévu de passer sur un dédier dès que j'ai fini mon site. Il faut que je vous donne mes acces chez 1and1??

 

Si vous voulez de l'aide oui :)

Share this post


Link to post
Share on other sites

Bonjour.

Non je n'ai pas cette table

Donc le backup (export) que tu as mis en place chez 1and1 est foireux.

La commande mysqldump c'est la manière depuis la ligne de commande de générer un backup parfait - car quand tu parles de duplicate key, de table manquantes,  ce que tu utilises semble très approximatif en qualité compte tenu des symptômes

Share this post


Link to post
Share on other sites

Justement si ton hébergement à des limites, ce type de backup peut très facilement être partiel.

Share this post


Link to post
Share on other sites

bon j'ai éssayé le dump et j'ai ça MySQL a répondu: dot.gif

#1064 - You have an error in your SQL syntax

j'ai changer utilisateur mpd et le nom de la base de donné mais ça veux pas.

de plus j'ai regardé dans les table sur mysql localhost et je n'ai pas la table ps_shop_url non plus

Share this post


Link to post
Share on other sites
Guest

bon j'ai éssayé le dump et j'ai ça MySQL a répondu: dot.gif

#1064 - You have an error in your SQL syntax

j'ai changer utilisateur mpd et le nom de la base de donné mais ça veux pas.

de plus j'ai regardé dans les table sur mysql localhost et je n'ai pas la table ps_shop_url non plus

 

quelle est la version que vous utilisez en local ? car la 1.4 n'utilisait pas cette table encore...

Share this post


Link to post
Share on other sites

pardon mais tu as bien remplacé <user> par ton nom de user, <password> par ton password et <database> par le nom de ta bdd?

 

parce que j'utilise ça tous les jours sur toutes sortes de système et c'est bullet-proof - ça marche partout

 

Enfin

Share this post


Link to post
Share on other sites

Bin comme je suis en local j'ai pas changé grand chose. J'ai laissé root pas de mdp et le nom de base comme donné plus haut.

 

J'ai bin remplacé ce qu'il faut et meme resultat c'est vraiment bizzare

Share this post


Link to post
Share on other sites
Guest

Si tu lances le dump sql depuis phpmyadmin ça ne fonctionnera pas effectivement car c'est destiné à être utilisé dans l'interface de commandes.

Edited by Guest (see edit history)

Share this post


Link to post
Share on other sites

bon, dans l'invite de commande il me dit que mysqldump n'est pas reconnue en tant que commande interne et externe, un programme exécutable ou un fichier de commande

Share this post


Link to post
Share on other sites

Et quand tu mets ton chat dans ton micro-onde tu espères en sortir un cake?

Share this post


Link to post
Share on other sites

c'est pour ça que je laisse ma femme faire la cuisine.

si j'ai demandé de l'aide c'est que je ne sais pas ou faire, le plus simple aurais pu être aussi de me dire ou mettre la commande et je l'aurais fais de suite.

Share this post


Link to post
Share on other sites

Ok,

 

Je me place dans le cas où je ne connais pas et que l'on me parle d'une commande mysqldump.

Je fais Google mysqldump, Et là un multitude de réponse.

 

T'imagines bien que je ne peux pas moi trouver sur Google le niveau d'inexpérience que tu as. Et que je ne peux pas te fournir là sur le forum une explication exhaustive, d'autant que si tu avais su, tu l'aurais mal pris que je te dises:

Touche ⊞ + R

CMD [ENTREE]

CD C:\wamp\bin\mysql [ENTREE]

CD MYSQL*

BIN\MYSQLDUMP -u<user> -p<password> <database> > c:\fichier.sql [ENTREE]

 

Et que ça n'aurait pas plus marché si tu ne l'avais pas mal pris puisqu'il fallait virer le paramètre -p<password> vu ton cas

Share this post


Link to post
Share on other sites

tkt je ne prend rien de mal, un texte sur un écran ne montre pas la façon dont sont éxprimé les mot.

je suis pas très doué et j'assume totalement, vous pouvez dire que je suis nul je le prendrais pas mal puisque c'est vrai  :)

Share this post


Link to post
Share on other sites

CQFD, maintenant c'est a moi de devoir comprendre ... désolé mais je vais pas reconstruire écrire une trilogie pour expliquer comment faire un backup

Share this post


Link to post
Share on other sites

la dernière commande j'ai ecris BIN\MYSQLDUMP -uroot allconnectingpresta > c:\fichier.sql

j'ai aussi essayé avec un espace entre u et root mais tjrs pareil

Share this post


Link to post
Share on other sites

bon comme on dit qui cherche trouve, il fallait mettre l'adresse complete pour dire a la cmd ou enregistrer le fichier

du coup j'ai mis BIN\MYSQLDUMP -uroot allconnectingpresta > C:\wamp\bin\mysql\fichier.sql

 

et j'ai bien mon fichier.sql

Share this post


Link to post
Share on other sites

si je vais sur le site j'ai Warning: Cannot modify header information - headers already sent by (output started at /homepages/30/d471721640/htdocs/all-connectingpresta/config/settings.inc.php:1) in /homepages/30/d471721640/htdocs/all-connectingpresta/classes/shop/Shop.php on line 428

Warning: Cannot modify header information - headers already sent by (output started at /homepages/30/d471721640/htdocs/all-connectingpresta/config/settings.inc.php:1) in /homepages/30/d471721640/htdocs/all-connectingpresta/classes/shop/Shop.php on line 429

Share this post


Link to post
Share on other sites

bonjour,

j'ai enfin acces à mon back-office et au front office mais les problemes sont:

ça me dit souvent qu'il manque des table dans la BDD donc je les copie depuis une BDD presta vierge que j'ai en local et transfert. bizzare que àa fonctionne en local et pas en ligne.

le front office ne prend en compte aucune des modifications que j'ai fait. je me retrouve avec le template d'origine comme quand je l'ai acheté. La je sais pas.

 

une idée??

 

merci d'avance.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More