Jump to content
pascal jouillat

probleme inscription sur ma boutique

Recommended Posts

Bonjour  à tous,

 

Depuis hier alors que je n'ai rien changé, des personnes ne peuvent pas s'inscrire sur ma boutique en ligne.

Apres avoir rempli leur nom prénom adresse email ils arrivent sur cette page et :

 

http://lespoteauxcetb.fr/boutique/index.php?controller=authentication

 

ils ont cette erreur:

 

Fatal error: Uncaught Error: Access to undeclared static property: Validate::$data in /home/lespoteauo/www/boutique/classes/ObjectModel.php:1061 Stack trace: #0 /home/lespoteauo/www/boutique/controllers/front/AuthController.php(407): ObjectModelCore->validateController() #1 /home/lespoteauo/www/boutique/controllers/front/AuthController.php(240): AuthControllerCore->processSubmitAccount() #2 /home/lespoteauo/www/boutique/classes/controller/Controller.php(171): AuthControllerCore->postProcess() #3 /home/lespoteauo/www/boutique/classes/Dispatcher.php(374): ControllerCore->run() #4 /home/lespoteauo/www/boutique/index.php(28): DispatcherCore->dispatch() #5 {main} thrown in/home/lespoteauo/www/boutique/classes/ObjectModel.php on line 1061

 

J'ai crée l 'utilisateur va mon espace administration, mais quand il souhaite commander il a le même problème d'authentification..

 

Dernière précision je suis chez OVH, j'ai vérifié les droits en CHMOD mais impossible de les changer...

 

Si une bonne âme  veut bien m'aider 

Share this post


Link to post
Share on other sites

Ben pourquoi avoir passé votre php en version 7 ? Prestashop n'est pas compatible avec, redescendez en 5.6

Share this post


Link to post
Share on other sites

Merci pour le renseignement; je suis redescendu en 5.5 ( car pas de 5.6 chez ovh) et ca fonctionne de nouveau.

Pourtant ca fait un bail que j'vais changé de version PHP ( j ai un site en joomla et OVH preconisait de changer de version Php)

 

Merci en tout cas !!

Share this post


Link to post
Share on other sites

Euh... un bail... PHP7 n'est sorti qu'en Novembre et OVH la mis sur les mutus depuis février...

 

L'alerte concernant votre version php vous était affichée car vous étiez en php5.2 qui n'est plus supporté par OVH depuis 6 mois

 

Mettre à jour ne veut pas dire passer à la dernière (d'ailleurs il vaut mieux éviter vu le nombre de bugs de cette version qui ressemble plus à une béta qu'autre chose -> https://bugs.php.net/search.php?limit=30&order_by=id&direction=DESC&cmd=display&status=Open&bug_type=All&phpver=7.0 )

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More