Jump to content
jensUGX

Fejl ved opgradering

Recommended Posts

Hej Alle

 

Håber nogle her kan give mig et hint til at komme videre..

 

Jeg har forsøgt at opgrade min shop, men får nedenstående fejl når jeg kører domæne/install/upgrade/upgrade.php i min browser

 

Warning: require_once(_PS_SMARTY_DIR_Smarty.class.php) [function.require-once]: failed to open stream: No such file or directory in /var/www/web16/web/config/smarty.config.inc.php on line 3

Fatal error: require_once() [function.require]: Failed opening required '_PS_SMARTY_DIR_Smarty.class.php' (include_path='.') in /var/www/web16/web/config/smarty.config.inc.php on line 3

 

På forhånd tak for hjælpen :-)

 

//Jens

Share this post


Link to post
Share on other sites

Øhhhh.

Kører du 1click udstedt via backoffice

Eller hvad gør du?

Share this post


Link to post
Share on other sites

Vi er nødt til at have nogle flere detaljer.

Som du kan se er manuel opgradering ikke længere understøttet.

Hvilken version opgraderer du til? Har du ændret filsystem til billeder undervejs? Osv.

Det er ikke en nem opgave at lave manuel opgradering.

  • Like 1

Share this post


Link to post
Share on other sites

Vi er nødt til at have nogle flere detaljer.

Som du kan se er manuel opgradering ikke længere understøttet.

Hvilken version opgraderer du til? Har du ændret filsystem til billeder undervejs? Osv.

Det er ikke en nem opgave at lave manuel opgradering.

Jeg forsøger direkte til ver. 1.6.1.5... og har lavet gjort som foreskrevet i det link jeg skrev.

 

Downloaded nyeste version og pakken den ud i en folder... taget de foreskrevne mapper/filer og kopieret dem ind i den udpakkede. Hele dette uploader jeg til min server og forsøger at køre domæne/install/upgrade/upgrade.php

 

Her ikke ændret noget andet... så altså ikke filsystem til billeder mm.

 

skal jeg vælge en ældre version (med 1click) og tage det i 2 step ????? kan det anbefales / er det nødvendigt ??

 

På forhånd tak

 

//Jens

Share this post


Link to post
Share on other sites

Jeg forsøger direkte til ver. 1.6.1.5... og har lavet gjort som foreskrevet i det link jeg skrev.

 

Downloaded nyeste version og pakken den ud i en folder... taget de foreskrevne mapper/filer og kopieret dem ind i den udpakkede. Hele dette uploader jeg til min server og forsøger at køre domæne/install/upgrade/upgrade.php

 

Her ikke ændret noget andet... så altså ikke filsystem til billeder mm.

 

skal jeg vælge en ældre version (med 1click) og tage det i 2 step ????? kan det anbefales / er det nødvendigt ??

 

På forhånd tak

 

//Jens

Det forklarer en del.

 

Du kan ikke opgradere direkte til 1.6.

 

Start med 1.4.11 og sørg for at få skiftet filsystem til billeder. Dernæst bør du kunne opgradere til 1.6 via 1-click (det var først understøttet fra 1.3 så vidt jeg husker). Tag backup efter opgradering til 1.4 så du evt. kan rulle tilbage og opgradere til 1.5 inden 1.6 (det kan være nødvendigt afhængigt af din shop).

  • Like 1

Share this post


Link to post
Share on other sites

Det forklarer en del.

 

Du kan ikke opgradere direkte til 1.6.

 

Start med 1.4.11 og sørg for at få skiftet filsystem til billeder. Dernæst bør du kunne opgradere til 1.6 via 1-click (det var først understøttet fra 1.3 så vidt jeg husker). Tag backup efter opgradering til 1.4 så du evt. kan rulle tilbage og opgradere til 1.5 inden 1.6 (det kan være nødvendigt afhængigt af din shop).

 

Jamen det forsøger jeg så .... tak for hintet

 

Hvad betyder  sørg for at få skiftet filsystem til billeder ???? kan jeg finde info om dette noget sted ???

Share this post


Link to post
Share on other sites

I version 1.4 blev der introduceret en ny måde at strukturere billeder på. Før lå alle varebilleder i /img/p mappen direkte. Det gjorde shoppen meget tung ved mange billeder. Fra de senere versioner af 1.4 kunne man så flytte billederne til den nye struktur. Se dette link: http://doc.prestashop.com/display/PS14/Understanding+the+Preferences#UnderstandingthePreferences-Image

 

I den nye struktur er billeder splittet op i et hav af undermapper.

 

Hvis man ikke gør det, før opgradering til 1.5 får man en masse "sjov" ud af det:-) Så derfor er mellemtrinnet vigtigt. Jeg ved faktisk ikke, om 1-click upgrade nu tager højde for dette, det gjorde det i hvert fald ikke tidligere.

 

De mange trin i opgraderingerne og ting der skal huskes, er noget af det, der gør at en opgradering fra en meget gammel version hurtigt løber op i mange timer (hvilket kunder der kontakter mig for hjælp ofte har meget svært ved at forstå).

 

Held og lykke:-)

Share this post


Link to post
Share on other sites

Takker for info

 

Jeg forsøger nu med 1.4.11.1  ... og har lavet forberedelserne som før... men nu er der ingen upgrade.php fil jeg kan kalde :-( nogen idé hvordan starter opdateringen så ???

Share this post


Link to post
Share on other sites

Hej igen...

 

Tænkte lige... er det muligt at starte forfra med en ny shop, og så hente dele af den gamle ind ved at kopiere nogle mapper og database ??? lidt om en omvendt upgrade

 

Kan ikke lave en export/import af eksempelvis produkter, ordre mv... da det desværre ikke kommer ordentligt over... jeg har forsøft

Share this post


Link to post
Share on other sites

Det tror jeg ikke vil gå godt. Der er ændret virkelig meget i strukturen siden 1.2.

Opgradering er altid bedste løsning. Sekundært eksport/import. Men som sagt, det er komplekst med så gamle shops.

Share this post


Link to post
Share on other sites

Hvad vil det typisk koste at få en til at gøre det for sig... tænker på en med erfaring der kender proceduren ??

 

Jeg kan ikke få startet opgraderingen med 1.4.11.1

Share this post


Link to post
Share on other sites

Det er umuligt at sige, hvad det kommer til at koste uden at have et ret godt kendskab til din shop. Og så kan der stadig være mange ubekendte ting, som man må løse undervejs, fordi man ikke på forhånd kender til alle detaljer. 

 

Hvis der er lavet mange rettelser i kernefiler, kan det være en kæmpe - hvis ikke nærmest umulig opgave. Så selv om jeg efterhånden har lavet mange opgraderinger, har der sjældent været to, der har været ens. Med mindre der har været tale om nyere versioner uden en masse specialtilpasninger.

 

Hvis man når så vidt, at opgraderingen går ok, skal man have opgraderet evt. ikke-standard moduler, installeret nyt theme (og evt. lave rettelser til dette). Sidst men ikke mindst skal der testes virkelig grundigt (noget som mange desværre nedprioriterer, hvorefter en opgraderet shop åbnes med en masse fejl, der først opdages måske længe efter, hvorefter det er for sent at rulle tilbage uden at miste ordrehistorik osv.)

 

Som sagt: Jeg tror ikke, at det er en lille opgave. Som du allerede selv har erfaret, skal første opgradering ske manuelt, og herefter i trin - med behørig backup og test undervejs. Så et vildt gæt vil være, at det ikke er under 20 timer.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More