Jump to content

Recommended Posts

Bonjour à tous

 

aucune mise en forme html dans mes fiches produits de s'affichent.

Je n'ai même pas de saut de ligne

 

Une idée ?

merci

Share this post


Link to post
Share on other sites

Bonjour,

 

Vous êtes un professionnel du web ... croyez vous que nous serions plus performants que vous sachant que nous n'avons pas accès à la moindre donnée ?????

Share this post


Link to post
Share on other sites

Bonjour,

 

Vous êtes un professionnel du web ... croyez vous que nous serions plus performants que vous sachant que nous n'avons pas accès à la moindre donnée ?????

 

Bonjour Mediacom87

 

alors j'utilise P 1.6.1.4, theme granada, hébergement ovh

 

Avez vous besoin d'autres informations ? 

Sur une fiche produit, lorsque je mets des éléments textes en forme dans le résumé, elles n'apparaissent  pas sur le site alors que c'est le cas dans la description longue.

 

Merci

Share this post


Link to post
Share on other sites

Alors, lorsque je parle de connées c’est plus virtuelles que des données techniques factuelle.

 

Votre version de PrestaShop, ça je peux l'avoir.

 

Votre thème, pfff, que dire il fait parti de la liste des milliers existants.

 

OVH, bon ce point n'a pas vraiment d'incidence sur le moindre affichage d'un site mais pourquoi pas, peut être que quelqu’un avec ces informations pourra retrouver ce qui est vraiment utile.

Share this post


Link to post
Share on other sites

dès que nous aurons l'URL du site, nous pourrons vous en dire plus

Share this post


Link to post
Share on other sites
Guest

Oui Oui, bien sûr !

 

3...2...1.. je branche ma boule de crystal et attention ça va chauffer !

 

dès que le brouillard se dispersera je viendrai vous donner des conseils de l'au delà !

Share this post


Link to post
Share on other sites

ChDUP l'url est http://atipikat.com mais le site est bien sûr en maintenance, dîtes-moi quelles sont les infos dont vous auriez besoin. Merci

 

Mediacom87 je ne suis pas devin donc désolé de vous faire perdre votre temps mais je ne connais pas les données dont vous aviez besoin. Merci tout de même pour vos deux réponses

 

Tweb vous passerez le bonjour à David Bowie de ma part, merci.

Share this post


Link to post
Share on other sites

Ok, je crois marcher sur la tête.

 

vous avez un soucis d'affichage et ... seul vous pouvez le constater et seul vous avez accès au code, aux données numériques au contenu.

 

alors pourquoi venir nous demander de l'aide si vous n'êtes pas capable de fournir spontanément ces accès ?

Share this post


Link to post
Share on other sites
Guest

attendez.. j'ai un signe là !! ça vient ^^

 

Ground Control to Major Tom
Ground Control to Major Tom
Take your protein pills and put your helmet on
Ground Control to Major Tom (Ten, Nine, Eight, Seven, Six)
Commencing countdown, engines on (Five, Four, Three)
Check ignition and may God's love be with you (Two, One, Liftoff)

Share this post


Link to post
Share on other sites

il faut que vous ajoutiez un ; à la ligne 2432 colonne 65 du fichier /pacorabanne/irma.php

 

autrement dit : à plus.

Share this post


Link to post
Share on other sites

Merci David Bowie pour tes éclairages ;-)

 

donc pour ceux qui auraient un soucis équivalent (tout du moins cela a fonctionné chez moi)

dans theme/votretheme/product.pl

 

changer {strip_tags($product->description_short)|escape:'html':'UTF-8'}

par {$product->description_short}

Share this post


Link to post
Share on other sites

Donc on va donner la bonne solution au soucis puisque ce template semble proposer des choses étranges.

 

il faut utiliser

{$product->description_short|escape:'html':'UTF-8'}

et ne retirer que le strip_tags() qui est fonction PHP connue de tout développeur PHP, comme son nom l'indique clairement, retire les tags html d'un texte.

 

Mais bon on va aussi expliquer la bonne façon d'utiliser ce principe de retrait des tags sur smarty.

{$product->description_short|strip_tags|escape:'html':'UTF-8'}

Share this post


Link to post
Share on other sites

Merci pour la précision mais dans mon cas et mon template 

si je laisse escape:'html':'UTF-8' les balises html apparaissent et ne mettent pas le texte en forme

Share this post


Link to post
Share on other sites

En même temps sur le template de base ce n'est pas échappé :

{$product->description_short}

donc faites comme ce qui est de base.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More