Jump to content
Chris0075

Problème de base de données après mise à jour

Recommended Posts

Bonjour à tous,

 

j'ai fais la mise à jour (vers la 1.6.0.9) de mon magasin ce mercredi. Je viens de remarquer que je n'ai plus accès aux commandes sur le tableau de bord :

 

  • Mauvaise requête SQL
    Table '4581826-1.pss_address' doesn't exist

 

Je décide donc d'aller voir dans phpmyadmin et trouve le pss_address vide ! Je récupère donc les anciennes adresses du backup et les importe dans la table. 

 

Le problème est toujours présent. En fait, ma base de données ne s'appelle pas "4581826-1", je ne sais pas comment changer cela (et ça ne m'affiche l'erreur que pour les commandes, les autres menus fonctionnent correctement).

 

Pourriez-vous m'aider?

Merci :)

Share this post


Link to post
Share on other sites

Vous avez peut être un override mal fait qui appel la bdd en dure (ce serait étrange).

Essayez aussi de supprimer le fichier class_index.php qui se trouve dans le dossier cache

Share this post


Link to post
Share on other sites

Salut !

 

Merci de ton intérêt :) 

 

Comment vérifier que ce soit (ou pas) un override et comment y remédier? Je ne m'y connais pas trop avec prestashop ...

J'ai supprimé le fichier class_index.php mais ça ne change rien, même après avoir déco / reco du tableau de bord

Share this post


Link to post
Share on other sites

La réponse est dans la question ...

En fait, ma base de données ne s'appelle pas "4581826-1"

 

 

D'ailleurs le message disait que la table n'existait pas, pas quelle était vide

Share this post


Link to post
Share on other sites

Salut,

 

ce n'est pas la réponse que j'attends en tout cas :P 

 

Après quelques tests, j'ai modifié le fichier "settings.inc.php" qui se connectait bien à la base de données "4581826-1" (qui sort de ne je sais où du coup ... ) afin de le rediriger  vers la base de données hébergées chez OVH. Ceci a pour effet un beau "hôte introuvable" et j'ai vérifié un nombre incalculable de fois mes infos (db_name, db_server et db_user et db_passwd sont copiés collés ...) 

 

Même en installant un prestashop tout neuf, il ne veut se connecter à aucune des deux bases lors de la tentative de connexion à la BD ...

Share this post


Link to post
Share on other sites

Au lieu de tatonner et reinstaller, regarde quelles sont les bases de données associées à ton/tes hébergement

hote, base de donnée

Share this post


Link to post
Share on other sites

C'est ce que j'ai fais : j'ai mis dans settings.inc.php les données liées à ma base de données. Résultat : hôte introuvable :/

Share this post


Link to post
Share on other sites
Guest

C'est ce que j'ai fais : j'ai mis dans settings.inc.php les données liées à ma base de données. Résultat : hôte introuvable :/

 

Ce ne sont pas les bonnes informations qui ont été renseignées, tu trouveras les infos correctes dans ton panel d'administration de l'hébergement.

Edited by Guest (see edit history)

Share this post


Link to post
Share on other sites

Comme dit plus haut, je les ai copiées du panel d'administration de OVH, d'où mon incompréhension ...

Share this post


Link to post
Share on other sites
Guest

remettez plutot votre nom de base qui fonctionnait au début : "4581826-1"

Share this post


Link to post
Share on other sites

Elle fonctionne mais je n'y ai pas accès, je ne sais pas d'où elle vient et je n'ai plus accès aux commandes car il manque la table pss_adress 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More