Jump to content
soufsouf

Traductions Module > Problème synchronisation entre Backoffice & Fichiers

Recommended Posts

Bonjour, 

J'ai un problème assez curieux. 

 

Dernièrement, j'ai rajouté quelques nouveaux mots (strings) dans le fichier TPL de l'un de mes modules. 

Une fois sur le backoffice, je vois bien le nouveau mot rajouté sur la liste des mots à traduire, mais le problème c'est que dès que je choisis une autre langue, je découvre que TOUS les mots sont redevenus en Français !!! 

 

Avant de cliquer sur quoi que ce soit, je pars m'assurer que les fichiers de langue du module (les fichiers en.php etc..) sont toujours intacts, effectivement ils contiennent toujours les mots traduits dans leur langues respectifs. 

 

Bien, je reviens sur le backoffice, je choisis anglais, les mots sont en français... Je change un seul mot, je clique sur enregistrer... Je vais voir dans le fichier et je découvre que ce dernier a été écrasé et contient maintenant des mots en français (au lieu de Anglais). 

 

Je remplace mon fichier de langue écrasé par l'original (qui contient bien les mots en anglais)... Je reviens sur le backoffice, anglais, toujours les mots en français. 

 

Je ne comprends pas pourquoi mon backoffice affiche les mots en français sur toutes les langues alors que mes fichiers sont bien en leur langues correspondantes... 

 

Help Please

Share this post


Link to post
Share on other sites

Très probablement ton navigateur qui fait ce qui s'appelle auto-fill.

Tu veux traduire en anglais alors traduit tout ce qui doit l'être et ce sera parfait

Share this post


Link to post
Share on other sites

Très probablement ton navigateur qui fait ce qui s'appelle auto-fill.

Tu veux traduire en anglais alors traduit tout ce qui doit l'être et ce sera parfait

 

Sauf qu'on parle de plus de 200 strings x 5 langues :) qui étaient toutes setup avant... 

Pour le moment je continue à traduire directement les nouveaux strings sur le fichier de langues... un peu plus long mais efficace... 

En espérant trouver un moyen d'afficher les strings sur mon backoffice en leur langues correspondantes et non pas en français qu'elle que soit la langue... 

 

Merci quand même. 

Share this post


Link to post
Share on other sites

Sauf a avoir flingué tes traductions en mixant les fr.php et translations/fr.php tous les champs déjà rempli sont exclus des autofills donc ton problème vient d'ailleurs.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More