Jump to content
  • 0
Nino76

Lieferzeit falsch auf Artikelseiten mit Varianten (PS v1.6.1.5 ER v2.0.2)

Question

Die globale Einstellung der Lieferzeit des Moduls "Europäische Rechtssicherheit v2.0.2" ist bei Artikeln mit Varianten fehlerhaft.

 

Beispiel:

 

Habe ich nun einen Artikel mit 3 Größen, wobei eine Größe nicht mehr am Lager ist (also Bestand=0) dann tritt der Fehler auf. Wenn ich im Frontend zwischen den Varianten des Artikels umschalte, dann ändert sich nicht die Lieferzeit bei Auswahl einer Variante die nicht am Lager ist. In meinem Fall bleibt die Anzeige der Lieferzeit bei "Lieferzeit: 1-2 Werktage", auch wenn ich eine Variante auswähle deren Bestand 0 ist.

 

Dies verwirrt doch extrem spätere Kunden!!!

 

Generell sind in meinem Fall alle Artikel bestellbar, auch die mit Bestand=0 und es werden immer alle Varianten auf der Artikelseite angezeigt (Meine Einstellung). Ich verwende PS v1.6.1.5.

 

Hat jemand auch dieses Problem feststellen können?

 

Ansonsten habe ich bisher noch keine weiteren Probleme feststellen können.

LG Nino

post-1256208-0-16776400-1463644521_thumb.png

post-1256208-0-35508100-1463644522_thumb.png

post-1256208-0-24083100-1463644524_thumb.png

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Ja, das ist uns hier auch grad aufgestoßen. Gibt es dazu neue Infos? :(

Leider nein! Wenn ich mich nicht irre und den Quellcode des Moduls richtig verstehe, dann ist das ein nicht vermeidbarer Bug, weil die Entwickler hier zu simpel denken und Varianten zwar beim Preis, aber nicht bei der Lieferzeit berücksichtigt werden.

Das Nachfolgemodul ps_legalcompliance von Version 1.7 verhält sich genauso.

 

Es könnte sich natürlich auch um das bekannte Cache-Problem handeln, das man unter 1.7 (hoffentlich) in den Griff bekommen hat.

Hat das mal jemand in der Testversion ausprobiert? Ich muss da leider passen, weil das aktuelle Release nicht mehr unter Xampp laufen will.

Share this post


Link to post
Share on other sites
  • 0

Ich hab aktuell keine 2te Testinstanz um das Modul für 1.7 auf meinen 1.6.1.6 zu ballern im Wirkbetrieb zu heiss so wie es gerade brummt. Anyone else please? Das Problem ist echt zum Haare raufen.

 

 

Leider nein! Wenn ich mich nicht irre und den Quellcode des Moduls richtig verstehe, dann ist das ein nicht vermeidbarer Bug, weil die Entwickler hier zu simpel denken und Varianten zwar beim Preis, aber nicht bei der Lieferzeit berücksichtigt werden.
Das Nachfolgemodul ps_legalcompliance von Version 1.7 verhält sich genauso.

Es könnte sich natürlich auch um das bekannte Cache-Problem handeln, das man unter 1.7 (hoffentlich) in den Griff bekommen hat.
Hat das mal jemand in der Testversion ausprobiert? Ich muss da leider passen, weil das aktuelle Release nicht mehr unter Xampp laufen will.

Share this post


Link to post
Share on other sites
  • 0

Das würde auch nichts bringen. Prestashop 1.7 ist eine Neuentwicklung, die mit den Vorversionen nicht kompatibel ist. Das gilt auch für Templates und Module.

Share this post


Link to post
Share on other sites
  • 0

Okay, mache es jetzt erstmal so halb über das EU advancedeucompliance Modul. Wie bekomme ich die Lieferzeit Variable in meine Status Emails? Weiss das jmd? :ph34r:

Share this post


Link to post
Share on other sites
  • 0

Moin Zusammen,

habe erst vor kurzem von PS1.6.0.14 auf PS1.6.1.10 und damit leider auch auf ER v2.0.2 upgedatet und stehe vor dem selben Problem.
Gibt es hier mittlerweile einen Lösungsansatz?

In kleineren Shops, wie meinem könnte man das zur Not noch manuell lösen, indem man die Lieferzeiten im ER Modul entfernt und und manuell bei jedem Artikel unter Mengen in die Anzeigetexte einfügt.
Aber das ist ja nicht Sinn und Zweck der Sache und müsste dann irgendwann, wenn das Modul mal funktioniert wieder rückgängig gemacht werden. Für große Shops mit tausenden von Artikeln eh unmöglich...

@ eleazar 
ich habe zum reinschnuppern und dran gewöhnen mal eine neue PS1.7.0.2 installiert. Und tatsächlich: hier immer noch das gleiche Problem!
Was muss ich wo und wie einstellen, um in 1.7 zu testen, ob es das o.g. Cache-Problem ist?

Gruß
Will

Share this post


Link to post
Share on other sites
  • 0

Da ich das Problem auch hatte hier meine Lösung:
Mit dem Modul delivery time for combination kann man jeder Variante oder auch jedem Produkt eine eigene Lieferzeit geben.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More