Jump to content
Sign in to follow this  
DeRob

home.pl

Recommended Posts

Witam,

Postawiłem wersję 1.2.4 na home.pl i dzielnie walczę :)
Powiedzcie, czy komuś się udało zrobić w pełni działający sklep na home.pl ?

Aktualnie mam problem z logowaniem na konta userów. W IE i firefox 3.x mam komunikat błędna sesja / token ale potem po odświeżeniu stronki jestem zalogowany. W Firefox 2.x po prostu nic się nie dzieje jak daję połącz.

Testowałem poprawkę z plikiem tools.php ale jak to zrobię to jest jeszcze gorzej. Dostaję wtedy jeszcze inne błędy na stronce.

Rozgryzł już ktoś problem z niewysyłaniem maili z przypomnieniem hasła?

Pozdrawiam

Share this post


Link to post
Share on other sites

jak masz możliwość to zmykaj od home.pl! ten problem można uznać za nierozwiązywalny. można usunąć kilka błędów, ale i tak pozostanie kilka innych (w mojej realizacji nadal jest problem z uploadem zdjęć do produktów). polecam odwiedzić stronę polskiego wsparcia presty. jest tam kilka postów, które mogą pomóc z Twoimi problemami.
powodzenia

Share this post


Link to post
Share on other sites

Nie wiem jak u was, ale u mnie wszytko działa bez problemów na home.pl.
Co prawda musiałem trochę pokombinować i poczytać, ale dało radę :)
Używam wersji 1.2.5.

Share this post


Link to post
Share on other sites

możesz napisać co konkretnie pokombinowałeś? na forum polskiego wsparcia presty są opisane czynności jakie należy podjąć aby działało to z najmniejszą możliwą ilością błędów/niedogodności. korzystałeś z tego czy sam coś kminiłeś?

Share this post


Link to post
Share on other sites

Po pierwsze... na home.pl mają własny interpreter pliku .htaccess, więc tutaj niestety trzeba czasami kombinować. Co do maili... na nazwa.pl miałem podobny problem i udało mi się go rozwiązać (prawdopodobnie na home.pl jest identycznie).
Jeżeli konfigurujesz skrzynkę poprzez SMTP, to ustawiasz jakiś login i skrzynka ma jakiś adres, a wg. skryptu wysyłana jest poczta z adresu: no-reply@smtp-domena.pl
Sprawdź sam.
Wyedytuj plik: ajax_send_mail_test.php z folderu admin-a i zamień:

$from = 'no-reply@'.Tools::getHttpHost(false, true).'.com';


na:

$from = $_GET['smtpLogin'];


(przeważnie loginem jest email, ale jeżeli u Ciebie jest inaczej, to popraw to jeszcze do innego stopnia: "login+domena")

Jeżeli teraz wysyła Ci testowe emaile bez problemu, to możesz wyedytować plik klasy classes/Mail.php.
Metoda "static public function Send"
Zaraz po linijce:

if (!isset($from)) $from = $configuration['PS_SHOP_EMAIL'];


Dopisz pod nim:

$from = $configuration['PS_MAIL_USER'];



No i sprawdź czy działa.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More