Jump to content
djuric

Problem na froncie po przenosinach na inny serwer

Recommended Posts

Witam,
 
przenosiłem sklep oparty na Prestashop na inny serwer:
- backup plików (spakowanie na serwerze do archiwum i wypakowanie na nowym serwerze)
- backup bazy danych
- eksport do nowej bazy danych
- wgranie plików
- w bazie danych zmieniłem adresy url na nowe w tabelach ps_configuration i ps_shop_url
 
pojawiają się następujące problemy:
- nie działa front - po długim ładowaniu pojawia się błąd serwera 503 Service Unavailable
- w panelu admina mogę wprowadzać i zapisywać zmiany w każdej zakładce poza DANE URL i SEO - przy próbie zapisuj pojawia się błąd:

Fatal error:  
Uncaught Error: Access to undeclared static  property: Validate::$values in  DOMENA/public_html/classes/controller/AdminController.php:1389 
Stack  trace: 
#0  DOMENA/public_html/classes/controller/AdminController.php(903):  AdminControllerCore->processUpdateOptions() 
#1  DOMENA/public_html/controllers/admin/AdminMetaController.php(437):  AdminControllerCore->postProcess() 
#2  DOMENA/public_html/classes/controller/Controller.php(178):  AdminMetaControllerCore->postProcess() 
#3  DOMENA/public_html/classes/Dispatcher.php(367):  ControllerCore->run() 
#4 DOMENA/public_html/admin-sklep/index.php(58):  DispatcherCore->dispatch() 
#5 {main}   thrown in /... /public_html/classes/controller/AdminController.php on line 1389

- w zakładce moduły nie są zaciągane ikony modułów niepochodzących z "czystej" Presty, mimo iż obrazki są na serwerze, są podlinkowane tak jak działające grafiki i mają takie same uprawnienia. W dodatku moduły te działają, ich konfiguracja i dane (np. wpisy z bloga) są zaciągane z bazy danych i można je edytować i zapisywać lub dodawać nowe.

 

Proszę o pomoc.

Share this post


Link to post
Share on other sites

Usunięcie .htaccess nic nie zmienia, podobnie jak zmiana domeny w jego treści. Wygenerować nowego nie mogę, bo "nie działa" zakładka DANE URL I SEO.

Share this post


Link to post
Share on other sites

Spróbowałem jeszcze raz przerzucić wszystko od nowa - tym razem na opcji wyłączonego sklepu  (Preferencje/obsługa).

 

Po przerzuceniu wszystkiego na nowy serwer na stronie głównej wyświetla się info o pracach konserwacyjnych i możliwości pozostawienia maila, ale w panelu sklepu pojawiają się błędy opisane wcześniej, a ponadto nie da się także zapisać zmian w zakładce Preferencje/obsługa, przez co nie można włączyć sklepu. Pojawia się błąd z kodem jak w pierwszym poście.

Share this post


Link to post
Share on other sites

Po zmianie PHP z 7.0 na 5.x back office zaczął działać poprawnie. Strona główna nadal wygląda tak:

 

Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Share this post


Link to post
Share on other sites

powodów może być kilka, najprawdopodobniejszy:

- za mało pamięci do wygenerowania strony sklepu, w efekcie wyświetla się strona "Service Unavailable" z informacją o "capcity problen"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More