Jump to content
granpopo

Impossible de lancer install PS en local

Recommended Posts

Bonjour,

 

Version PS : 1.6.1.5

Je viens d'essayer d'installer PS en local...avec xampp.

Je copie le bon dossier dans htdocs et j'ai déjà crée ma base de données.

 

Lorsque je lance l'install,la page reste bloquée et toute blanche.

voilà l'adresse en local (je ne pense pas voir de fautes) : http://localhost/prestashop/install/

 

Et rien ne se passe. J'ai essayé de fouiller le forum et internet, mais je n'ai pas trouver grand chose à ce problème...si ce n'est le débug...mais je n'ai pas réussi.

 

Auriez vous une idée ?

 

Merci de votre aide.

 

(A noter, j'avais réussi à installer sur un serveur en ligne)

Share this post


Link to post
Share on other sites

teste sur internet explorer  :ph34r:

J'avais eu un problème et je l'ai installé en passant par IE

 

Sinon, vide le cache de ton navigateur, regarde si ton serveur xamp est bien lancé

Share this post


Link to post
Share on other sites

Merci de ta réponse. Je suis sur Mac et j'ai essayé avec Safari et Mozilla.

 

Oui oui Xampp est bien lancé. et le cache est vidé. RIEN NE CHANGE ! :blink:

 

C'est la premiere fois que je teste PS en local...

Share this post


Link to post
Share on other sites

La page blanche signifie une erreur dans ton prestashop.

Passe en mode débugger pour afficher l'erreur, pour cela édite ton fichier ''defines.inc.php''

 

Sur xampp, je crois que c'est C:/xampp/htdocs/prestashop/config/defines.inc.php

A la ligne 28, normalement, tu dois avoir define(‘_PS_MODE_DEV_’, false);

Passe le à True et rafraichit ta page

Share this post


Link to post
Share on other sites

Ah merci...je m'étais trompé de fichier define...

voici le message :
Fatal error: Class 'Tools' not found in /Applications/XAMPP/xamppfiles/htdocs/prestashop/classes/PrestaShopAutoload.php on line 168

Share this post


Link to post
Share on other sites

essaye de supprimer ce fichier 

/cache/class_index.php

 

Sinon, essaye de faire une installation toute neuve.

 

(désolé je me permet de vous tutoyer  :P )

 

Peut être que le dossier tools n'a pas les permissions nécessaires

chmod -R 777

 

et commente la ligne 178 de PrestaShopAutoload.php

Edited by smuch (see edit history)

Share this post


Link to post
Share on other sites

Pas de soucis pour le tutoiement... ;)

 

Alors j'ai modifié les droits de tools...rien ne change.

 

et je ne trouve pas /cache/class_index.php

 

j'ai cherché dans : /prestashop/cache et dans /prestashop/classes/cache/   je ne le vois pas ! :blink:

 

Et c'est déjà la 3e install que je tente !!!!!

Edited by granpopo (see edit history)

Share this post


Link to post
Share on other sites

As-tu vérifier que le dossier tools est bien présent ?

 

Sinon, tente simplement de récupérer un dossier tools neuf ou réinstalle tous les fichiers présents dans config avec des dossiers neufs 

Edited by smuch (see edit history)

Share this post


Link to post
Share on other sites

Oui oui j'ai bien tools...dans le répertoire prestashop.

 

j'ai fais manip de tout réinstaller dossiers tools et config....

Bah non se passe rien :blink:  c'est un truc de fou...

 

Il y a deux jours je l'installe nickel sur un serveur en ligne...et là je veux le faire en local ça plante...

 

Merci de ton aide...je continue aussi à chercher.

Share this post


Link to post
Share on other sites

Je n'ai jamais eu un problème de ce genre, j'explore quelques pistes et je te tiens au courant,

pareil, tiens moi au courant si tu trouves quelque chose.

 

edit : la ligne 163 est-elle commentée ?

Edited by smuch (see edit history)

Share this post


Link to post
Share on other sites

avec "texte edit" sur mac je n'ai pas de numéros de lignes

Tu peux juste me dire par quoi ça commence ?

Share this post


Link to post
Share on other sites

C'est cette ligne

Tools::error_log('Cannot write temporary file '.$filename_tmp); 

Je ne connais pas l'environnement MAC, mais normalement avec n'importe quel éditeur de texte, on peut lancer une recherche de caractère.

Edited by smuch (see edit history)

Share this post


Link to post
Share on other sites

Dans prestashopautoload j'ai la ligne : Tools::error_log('Cannot write temporary file '.$filename_tmp);

Share this post


Link to post
Share on other sites

Il n'y a pas de mal, alors ?

Si elle est commentée, alors enlève le commentaire, et sinon fait l'inverse.

J'ai vu ça sur un forum, j'espère que ça marchera

Share this post


Link to post
Share on other sites

Dans prestashopautoload j'ai la ligne : Tools::error_log('Cannot write temporary file '.$filename_tmp);

 

Oui, c'est celle là. Du coup, elle est commentée ou non ?

Share this post


Link to post
Share on other sites

voilà ce que j'ai :

 

if (!@rename($filename_tmp, $filename)) {
                unlink($filename_tmp);
            } else {
                @chmod($filename, 0666);
            }
        }
        // $filename_tmp couldn't be written. $filename should be there anyway (even if outdated), no need to die.
        else {
            Tools::error_log('Cannot write temporary file '.$filename_tmp);
        }
        $this->index = $classes;
    }
 

Share this post


Link to post
Share on other sites

Commente cette ligne et réessaye l'installation

 

Tools::error_log('Cannot write temporary file '.$filename_tmp);

Edited by smuch (see edit history)

Share this post


Link to post
Share on other sites

J'ai vu aussi des solutions qui parlaient de supprimer fichier class_index.php

 

mais je ne l'ai pas ce fichier :blink:


que veux tu dire par "commente" cette ligne ?

Share this post


Link to post
Share on other sites

ooooooohh réussi.... :)

 

Voici ce que j'ai fait :

ligne de base :

Tools::error_log('Cannot write temporary file '.$filename_tmp);

 

Ligne corrigée :

error_log('Cannot write temporary file '.$filename_tmp);

 

vu ici : http://stackoverflow.com/questions/34036048/prestashop-installation-in-mac-using-xamp

 

Merci beaucoup de ton aide Smuch !!!! Je vais installer en espérant que ça se passe bien !! lol

Edited by granpopo (see edit history)

Share this post


Link to post
Share on other sites

Génial ! essaye et met RÉSOLU si tu as réussi 

Share this post


Link to post
Share on other sites

Dak, je fais ça...là faut que je me tape tous les droits des dossiers à faire...dès que c'est fait je passe en résolu !

 

Merci bcq !!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More