Jump to content

Création de module : problème css non appliqué pour fichier tpl


Recommended Posts

Bonjour,

 

Je me lance enfin dans l'aventure Prestashop,et la création de son module.

 

J'aimerai faire un bloc qui soit fixé sur une position défini, lui appliqué un css, etc...;le problème c'est que quand je passe par un fichier tpl pour la structure, le css ne s'applique pas..

Je ne comprend pas très bien, je pense avoir tout fait, dans la structure du module, les fichiers, mais sa ne fonctionne pas. le css ne s'applique pas...

 

Je vous laisse le lien de développement : http://dev.volcano-web.fr/presta_test

 

Je vous joint la structure du module.

post-1240304-0-19211300-1461226643_thumb.png

 

 

J'ai comme qui dirai l'impression que mon fichier CSS , ne se load pas...

 

Merci pour toute vos réponses,

 

jordan

 

 

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Bonjour,

 

 

Oui j'ai enfin réussi...

Je n'ajoutais pas le fichier css sur mon module.

 

Je l'ai fait via cette instructions dans ma fonction __construct

 

$this->context->controller->addCSS($this->_path.'css/vw_conseil.css');

 

 

Et voila le travail.

Edited by Jordan_Matas (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More