Jump to content

Problems with PayPal module after upgrade to 1.6.1.5


spanishcivilwarstamps
 Share

Recommended Posts

Hello,
 
After upgrading from 1.6.1.4 to 1.6.1.5 i've seen a couple of errors involving PayPal module.
 
The first one is a message in the module configuration area:
 
Your configuration use version 1.0 to communicate with [/size]PayPal.From July, all payments will be blocked.Thank you to approach your hosting company to enable the TLS version 1.2[/size]
 
The fact is that I already use TLS 1.2 instead of 1.0.
 
Another error: the information in configuration area appears mixed in English and French. Example:
 
Use express checkout shortcut
Offer your customers a 2-click payment option
 [/size]Oui (recommanded)
 [/size]Non
 
 
And finally, from the customer end (my site is in English and Spanish), these two errors occur:
 
In the Spanish check out page, the PapPal module appears in English (Pay with your card or PayPal account), but redirects to the Spanish site of PayPal.
 
In the English check out page, the PayPal button has the image missing. When inspected with Chrome, you see this:

 

https://www.demo.com/views/img/default_logos/default_horizontal.png

Failed to load resource: the server responded with a status of 404 (Not Found)

 
When pointing the mouse on the ? lacking image, appears a caption in French: "Payez avec PayPal"
 
By the way, in the English check out, the link also works and redirects to the English PayPal payment site with no problems.
 
It seems there is a big confusion in this module. Has anyone noticed anything similar? What could I do to solve this?

Edited by spanishcivilwarstamps (see edit history)

Share this post


Link to post
Share on other sites

I think the issue is related to SSL version of your web server, since Paypal will stop SSL V3 support and switched to TLS 1.2 for API service.. 

Sandbox(testing) environment has been stopped SSL V3 support and switched to TLS 1.2  since Jany 19, 2016.

 

Please find here for more detailed information, 

https://addons-modules.com/store/en/content/96-paypal-14077410ssl-routinesssl23getserverhellosslv3-alert-handshake-failure

Share this post


Link to post
Share on other sites

It didnt have an error that I saw but this only started happening after the upgrade to 1.6.1.5.  I've had two orders come in with paypal and the transaction records are empty and there seems to be a status issue as it is recording multiple events.  It is also not sending orders confirmations via email now.post-624034-0-33910200-1461091683_thumb.jpg

Share this post


Link to post
Share on other sites

I just did and there werent any logs in there for the past couple of days.  I looked in the advanced parameters/logs section and found:

 

4493 -- 1 Frontcontroller::init - Cart cannot be loaded or an order has already been placed using this cart Cart 7998 0x 0 04/18/2016 21:56:10 4494 -- 1 Frontcontroller::init - Cart cannot be loaded or an order has already been placed using this cart Cart 8001 0x 0 04/18/2016 22:40:08

Share this post


Link to post
Share on other sites

This error seems happens when try to create an order from the same shopping cart.

 

Have you tried to clean up your database by using some tool?

 

It seems that shopping cart ID has been reused somehow.  Just a hint. maybe this can give you some information.

Share this post


Link to post
Share on other sites

The PayPal module ver. 3.10.6 is full of bugs. I've been touring the forums and I've seen they are full of complains about this module, almost with everyone having different issues with it. 

 

I've reverted to module 3.10.2 and all problems came to an end. I will wait until all bugs are fixed before updating the module to 3.10.6 again. If any of you needs PayPal v3.10.2, here it is:

 

v3.10.2-PayPal Europe - Official.zip

  • Like 2

Share this post


Link to post
Share on other sites

The PayPal module ver. 3.10.6 is full of bugs. I've been touring the forums and I've seen they are full of complains about this module, almost with everyone having different issues with it. 

 

I've reverted to module 3.10.2 and all problems came to an end. I will wait until all bugs are fixed before updating the module to 3.10.6 again. If any of you needs PayPal v3.10.2, here it is:

 

attachicon.gifv3.10.2-PayPal Europe - Official.zip

If you are UK based seller it may be a problem going forward. I am still trying to get clarifications but it seems there are changes to Paypal with regards to TLS 1.2 requirements. I do not think 3.10.2 is compliant, hence the changes. BUT the dev of the module is now saying that the module will not be compliant with UK any more and they point to a paid version for around £200

 

So it seems going forward UK sellers alone will have to pay to use a Paypal module

Share this post


Link to post
Share on other sites

@haylau

The TLS 1.2 support is depends on both on hosting server and also the module itself. Yes our module itself has been updated and it works fine. But the hosting server also needs to be upgraded so that it will support new TLS 1.2.

 

You try our demo site of the module. It works fine with paypal sandbox environment.

 

You can request demo access Live Demo tab of the module product page.

  • Like 1

Share this post


Link to post
Share on other sites

I tried editing code to re-include UK support  - no luck. All I get is error saving the configuration on setup (version 3.10.6) This is the only version usable after June as it supports TLS 1.2 - all earlier versions will fail.

 

Support for UK now removed:

 

This module is available for the following countries: France, Italy, the Netherlands, Luxembourg, Belgium, Spain, Portugal, Germany, Austria, Switzerland, Norway, Sweden, Finland, Denmark, Turkey, Israel, Bulgaria, Czech Republic, Poland, Greece, Hungary, Romania, Slovakia, Slovenia, Ukraine, Russia.
But also Asia, Oceania and Latin America, except Mexico.


For USA & Canada, please use PayPal USA & Canada module
For United Kingdom & Ireland, please use Paypal Direct Payments module
For Mexico please use Paypal Mexico module

 

 

Prestashop now want everyone in UK and Ireland to buy a Paypal module @ £134.99

Share this post


Link to post
Share on other sites

@spanishcivilwarstamps

thanks for sharing the information, it sounds like a good solution before the bugs are fixed by Prestashop.

I have also Paypal module - Agile Paypal express checkout, that should be working fine with UK. you may also consider it as candidate.

 

Thanks for the info shokinro, but I am based in Spain, so the UK module is not appropiate for my needs.

Share this post


Link to post
Share on other sites

 

This module is available for the following countries: France, Italy, the Netherlands, Luxembourg, Belgium, Spain, Portugal, Germany, Austria, Switzerland, Norway, Sweden, Finland, Denmark, Turkey, Israel, Bulgaria, Czech Republic, Poland, Greece, Hungary, Romania, Slovakia, Slovenia, Ukraine, Russia.

But also Asia, Oceania and Latin America, except Mexico.

 

 

I have an Romanian Paypal account but installed and own my shop in Moldova, so after I install the PayPal module I get the warning that I cannot use this module due to country restrictions. ( Moldova has only access to Buyer options at Paypal )

So, what should I do to make a normal use of this module? I tried to Change default country to Romania but warning still remains.

I thought this is an issue caused by the 1.6.1.5 update but now I barely believe this...

 

Share this post


Link to post
Share on other sites

I have an Romanian Paypal account but installed and own my shop in Moldova, so after I install the PayPal module I get the warning that I cannot use this module due to country restrictions. ( Moldova has only access to Buyer options at Paypal )

So, what should I do to make a normal use of this module? I tried to Change default country to Romania but warning still remains.

I thought this is an issue caused by the 1.6.1.5 update but now I barely believe this...

 

 

 

Have you checked country restrictions section at back office - Modules - Payments tab?

Make sure you have enabled the payment module for your country.

Share this post


Link to post
Share on other sites

  • 2 weeks later...

@spanishcivilwarstamps, Thank you for the link. It saves us from wasting any more transactions. For four days we have been crying for help everywhere, including at the developer's ( 202 commerce ), without any effect. We have tried in vain to search for a link to access a backward version. Somehow Prestashop has hidden them. It turns out that we are saved by a posting by a peer user.

 

Gracia

Share this post


Link to post
Share on other sites

As was reported by spanishcivilwarstamps, the latest paypal has numerous bugs. A mixture of french and english in the BO is confusing to staff that do not speak french. Plus the img path is wrong, displayed as /views/img/default_logos/default_horizontal.png

Share this post


Link to post
Share on other sites

thanks for your information @jetx.

I do not think PrestaShop has a place to disclose bugs or issues. they will fix bug reported to the bug-tracker  by users and then disclose on release note next version

Share this post


Link to post
Share on other sites

Hi

I use EU PayPal module too.

I got some bug with PayPal v3.10.7 - by PrestaShop: PayPal image missing in the order payment confirmation. Image link same like got JETX - /views/img/default_logos/default_horizontal.png but this directory not exists. I find it when beginning test ordering after upgrading Prestashop to v1.6.1.5.

Me helped downgrade PayPal to v3.10.2 (I has deleted v3.10.7 and newly installed v3.10.2). PayPal Logo came back in the order payment confirmation, but in this version (PayPal v3.10.2) it miss in the BO (Back Office). It's not good, but is better for me - customers can see correct shop.

v3.10.2-PayPal Europe - Official.zip

Looking forward for correct PayPal module for EU.

Thanks to all for information. It save many our time.

Edited by sassbar (see edit history)

Share this post


Link to post
Share on other sites

Hi,

we're also having massive issues with latest PayPal v3.10.7:

 

1) Can't save credentials at all. It always comes back with "error...you must save credentials..."

2) Getting "baseDir is not defined" in other modules

3) Img path is incorrect, so no logo displayed

 

old version v3.10.2 works fine...

 

thanks

Share this post


Link to post
Share on other sites

Hello

Just has installed last Prestashop module PayPal Europe - Official v.3.10.8 and in the configuration tab found only one string:
'Your country is not available for this module please go on Prestashop addons to see the different possibilities'.
My country is Estonia, EU (Europe Union).
I has uninstaled and deleted it (PayPal Europe - Official v.3.10.8) and then instaled old one - PayPal v3.10.2:

[v3.10.2-PayPal Europe - Official.zip]

 

It's work fine fo me!

Looking forward for correct last version of the PayPal EU module.

v3.10.2-PayPal Europe - Official.zip

Edited by sassbar (see edit history)

Share this post


Link to post
Share on other sites

Guys,

 

What about Paypal USA? I am using 1.3.9 of Paypal USA and like the OP I just upgraded from 1.6.0.9 to 1.6.1.5. I have the exact same issue in my order processing - some orders showing  "Payment Accepted" status multiple times, some orders coming in with no status at all, and the Paypal transactions details empty.

 

Is there a solution to this? Is this a module issue or an ssl issue? My 1.6.0.9 shop worked perfectly.

 

retry_issue_error.png

Edited by ajs6116 (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Despite the module has been updated twice since all bugs reported in this topic were seen, and now it has version 3.10.8, all problems persist. For PayPal Europe, the last working verstion still is 3.10.2, so DO NOT UPDATE your PayPal module. I cannot believe the problems have not been solved yet. Starting to doubt if they will ever be solved.

  • Like 1

Share this post


Link to post
Share on other sites

  • 2 weeks later...

Guys,

 

What about Paypal USA? I am using 1.3.9 of Paypal USA and like the OP I just upgraded from 1.6.0.9 to 1.6.1.5. I have the exact same issue in my order processing - some orders showing  "Payment Accepted" status multiple times, some orders coming in with no status at all, and the Paypal transactions details empty.

 

Is there a solution to this? Is this a module issue or an ssl issue? My 1.6.0.9 shop worked perfectly.

 

retry_issue_error.png

Is there a solution for the new issues with PayPal?

Share this post


Link to post
Share on other sites

So I'm assuming from this thread unless I pay I can't use Paypal in the UK now?

That kinda Sux's  I'm glad i'm having a new shop built on a different platform now.   

Share this post


Link to post
Share on other sites

  • 1 month later...

would this be why my PayPal  module has just stopped working? 

the problem im getting is with modules/paypal/express_checkout/payment.php

the incorrect url here is the url given http://www.g.com/gogojuiceshop/modules/paypal/express_checkout/payment.php

and i think the url should be http://www.gogojuice.info/gogojuiceshop/modules/paypal/express_checkout/payment.php

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More