Jump to content

[MODULE] AddThis Block


Recommended Posts

That is great module. I wrote a post that includes your "Sexy Bookmarks" in my blog. I think it will be good to add this module too. By the way thanks for sharing module for free.

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hi!!

Great module!

One thing, is possible perzonalize it with custom social networks buttons? as if i wanna insert digg or delicious for example.

Thanks!

Share this post


Link to post
Share on other sites

now AddThis comes with facebook like button......

This morning, we’re excited to announce the first phase of our support for the Facebook Like button within the AddThis sharing platform. If you’ve put the AddThis Toolbox on your page it only takes one additional line of code to display the Facebook Like button next to the rest of your service icons. (Instructions and more documentation can be found in the Facebook Like button gallery page.)......
read more


just edit the blockaddthis.tpl and put


hope i have some spare time to include this on the next release :)

Share this post


Link to post
Share on other sites
  • 2 weeks later...

hi thank you very much for this great module.

i've installed this module n activate it but nothing seems to be appear on my homepage. im using default theme is there any other setting i need to do to make it work ?

thx !

Share this post


Link to post
Share on other sites

@renjii
hmmm wierd.... nothing to set after install the module.
by default this module will hook on hookExtraLeft / {$HOOK_EXTRA_LEFT}
please give me te url so i can check it out.

Share this post


Link to post
Share on other sites
  • 2 weeks later...
several days ago ive made Sexy Bookmarks but my client said that its to much they want something small and simple.

then i decide to made this AddThis block. well ive try to made ShareThis too but the problem is ShareThis need a unique-id (got it when registered) so i choose AddThis because it can be done with or without register as a member.

already comes with 12 layout button, 10 is the default button from AddThis. just select it from the menu (see snapshot for more detail). by default will come on extra left hook (below image on product page)


WARNING:
this module is a thankyouware so say thank you is a must and send some donation is a hope


there are not images of buttom in my back office, i don't know what is wrong but it works fine in the front office thanks
  • Like 1

Share this post


Link to post
Share on other sites
@Nanuk
its very easy to do this custom button...
* edit blockaddthis.tpl and go to bottom of the page
* you see something like this
* just add a new line or

as easy like this...
for more info you can find @
* http://www.addthis.com/help/toolbox
* http://www.addthis.com/services/list



Very nice module @caparuni. Thank you for that.
Would it be possible to add clickbacks and Google Analytics Integration?

http://addthis.com/help/clickbacks
http://addthis.com/help/google-analytics-integration

Share this post


Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...
  • 1 month later...

Awesome! Nice and slimline is this mod.

Thanks a whole bunch!

He he, when I started customizing my Prestashop almost a year ago, I woulda KILLED for this mod to save me from all the code edits. :)
Muuuuuch easier now... Upload, install...done!

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 3 weeks later...

Tried to use it, but the following error is appearing on BackOffice:

Warning: getimagesize(/modules/blockaddthis//img/10.gif) [function.getimagesize]: failed to open stream: No such file or directory in /home/httpd/vhosts/brasilnabagagem.com.br/httpdocs/modules/blockaddthis/blockaddthis.php on line 68

I copied the folder from the attached .zip file to modules folder, changed the folder permissions, but haven't solved it.

My PS version is 1.3.1.1

in FrontOffice, the icons are showing and working good.


Any hint on what could be happening?

Share this post


Link to post
Share on other sites
  • 2 weeks later...

Hi,

I also get this error:

Warning: getimagesize(/modules/blockaddthis//img/10.gif) [function.getimagesize]: failed to open stream:

The permissions are correct. How would I fix it?

Thanks!

Share this post


Link to post
Share on other sites

In blockaddthis.php I commented out that getimage line and the errors went away in the admin and the icons seem to work in the front office.

//list($w, $h, $t, $a) = getimagesize($this->_path.'img/'.$file);



Is there something I'm missing?

Share this post


Link to post
Share on other sites

Melinda,

Commenting that line(s) makes all the icons of this module disappear in BackOffice, right?
I think the problem is the // right before the folder IMG (I just realized that now). Check out (first line):

Warning: getimagesize(/modules/blockaddthis//img/10.gif) [function.getimagesize]: failed to open stream: No such file or directory in /home/httpd/vhosts/brasilnabagagem.com.br/httpdocs/modules/blockaddthis/blockaddthis.php on line 68


How can we take that // out and make the code find the right path to IMG folder?

Share this post


Link to post
Share on other sites

This is the error line I get and it doesn't have 2 slash marks:

Warning: getimagesize(/modules/blockaddthis/img/10.gif) [function.getimagesize]: failed to open stream: No such file or directory in /home/mainstre/public_html/modules/blockaddthis/blockaddthis.php on line 68

Hopefully someone who programs will help out. I'm lost.

Share this post


Link to post
Share on other sites

Hi, seems to be a great module - but unzipped and then uploaded the file to modules and went to BO to configure and all it shows are tick boxes but no images?? It asks for some user id? Also it does not show in 'positioning' area of modules.

Any ideas? Or i scrap it and find something else?

Share this post


Link to post
Share on other sites

I unzipped the file, which then has the BlockAddThis folder (inside this is the image folder, tpl and php). I uploaded this BlockAddThis folder to modules. Log into BO and the module is on the list (no parse errors or anything), go to configure and there are just the round tick or selection boxes but no images of what you are ticking. On the front office it doesn't show (even if I tick something randomly) nor does it show in positions (for modules).

31064_w3ReVFwuePcEUoRowZDu_t

Share this post


Link to post
Share on other sites

You can check permissions via an ftp program or your server hosting panel like cpanel. the -R means recursive so that means every file in there needs the same permissions. I do it via my server but if you don't have access you will have to do this the other way.

Wonder why this forum has french text and at the top it says english forum ...

Share this post


Link to post
Share on other sites

Hi, thanks for the help. Checked via ftp - modules have permissions 777 (non recursive). So all should be ok. Tried deleting and reinstalling for the fifth time, same result. Guess I have to see if there is another module out there that does similar, but works for me.

Share this post


Link to post
Share on other sites

I remember when I first installed prestashop it was supposed to be non-recursive? Either way, just changed the permissions, deleted and reinstalled and still no cigar. Time to call it a day on this one unfortunately.

Share this post


Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

HI,
after installing the addthis module some translations for modules are missing and I cant save new translations. another problem is that it removed my bookmar button at the top of page. do you know how i can uninstall the module and bring back the last version of my shop?

Thanks
sascha

Share this post


Link to post
Share on other sites
Melinda,

Commenting that line(s) makes all the icons of this module disappear in BackOffice, right?
I think the problem is the // right before the folder IMG (I just realized that now). Check out (first line):

Warning: getimagesize(/modules/blockaddthis//img/10.gif) [function.getimagesize]: failed to open stream: No such file or directory in /home/httpd/vhosts/brasilnabagagem.com.br/httpdocs/modules/blockaddthis/blockaddthis.php on line 68


How can we take that // out and make the code find the right path to IMG folder?



Howdy, In need of plug and play module with addthis functionality so I installed this I was like yesh this looks like simple and fast. And it was!!! caparuni Thank you for this module! But still there is a little bug that needed a repair.

Look at the code in file blockaddthis.php line 68 (like the error says)
               list($w, $h, $t, $a) = getimagesize($this->_path.'img/'.$file);



You can see that img path is defined with $this->_path which represents path for urls but not the absolute img path.
As you can see the error: "getimagesize(/modules/blockaddthis//img/10.gif)" " failed to open stream: No such file or directory in..." . You can see that getimagesize path is not the absolute path... So we can fix this by doing little modification to the code.

Replace original line 68 with

               list($w, $h, $t, $a) = getimagesize(_PS_MODULE_DIR_.$this->name.'/img/'.$file);



But hi ho there is still one "typoed?" line left. At line 47 there is a same function calling same variable. So do the necessery changes to that line also.

Cheers to the author for a nice module.

ps. I'm using prestashop 1.3.1

Share this post


Link to post
Share on other sites

Hi thanks for this module. One thing though in the back office the images of buttons to select from do not display! The module works and you can select the type of button and that works but you just can't see what your selecting in the back offiice.
============================================
SHOP- you need to select your button, add your user name in the back office then SAVE the settings go to product page and thats it!

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 4 weeks later...

I have not tested this fully but it works in the 1.4 Beta 1 i have a test site setup. The only thing i see that is different it on 1.3 it puts the module in a Mod-Id list on the BO and in 1.4 it puts it with the Other Modules List. Look in pics below.

www.projectpb.com/presta if anyone want to play with the mod and test function they can their.

hopes this helps out

thanks
Jeff

35918_2O4L73JaRm9NvTvKghSM_t

35917_TjUzXVD5kvPTzPKIJYBN_t

Share this post


Link to post
Share on other sites

Hi,

I used this modul, but when anyone share in facebook, shared only links without product name, description and image.
I make meta tags:

<meta name="title" content="[TITLE]" />
<meta name="description" content="[DESCRIPTION]" />
<link rel="image_src" href="[iMAGE SRC]" />

...but not change anytihing.

Could you please help me?
What schould i make to share product name, description and image as in other site, when people share.

Thanks

Share this post


Link to post
Share on other sites
  • 4 weeks later...

thank you thank you thank you thank you thank you thank you
thank you thank you thank you thank you thank you
thank you thank you thank you thank you
thank you thank you thank you
thank you thank you
thank you

^_^ am so happy
was trying to add this in header footer never success
you saved me lots of time an effort

Share this post


Link to post
Share on other sites

For the people that are having trouble with the images not showing up in the backend. Change line 70 in blockaddthis.php from

$_menuButton .= '
<input type="radio" name="addthis_mode" value="'.$value.'" '.$check.'> _path.'img/'.$file.'" width="'.$w.'" height="'.$h.'">'';



to

$_menuButton .= '
<input type="radio" name="addthis_mode" value="'.$value.'" '.$check.'> _path.'img/'.$file.'">';



Just as Delite mentioned, I'm also having having trouble with links being shared as following:

http://www.website.nl/category/www.website.nl/category/product.html?sms_ss=favorites&at_xt=4d457ff702bc68ee,0

which should just be:

http://www.website.nl/category/product.html

Anyone that knows how to fix the linking issue? Thanks in advance!

Share this post


Link to post
Share on other sites

Thanks alot for this fantastic module. Its everything that i've been looking for and will be implementing it in my website!

I have just one problem, I cannot stop double linking to the website. If I try and Tweet, Facebook or email from the module in my website, the link always appears like this:

http://www.fromthatshop.com/www.fromthatshop.com/product.php?id_product=20&sms_ss=email&at_xt=4d46d14d81cf2d87,0

Is there anyway to prevent this from happening?

Your help is greatly appreciated!

Thanks a lot

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 2 weeks later...

Thanks for the module.
I'm having a problem when posting links via add this, are posting using https:// rather than http:// and I'm just wondering how i can rectify this ?

Thanks

Share this post


Link to post
Share on other sites
  • 3 weeks later...
  • 2 weeks later...

This looks great, and it seems to work fine on my site, but I am wondering if there is a module that lets you have something similar on the front page. I don't want it on each and every product - just for my website in general...

Share this post


Link to post
Share on other sites

Thanks very nice module but can somebody tell how it is possible to also share the products photo and description to the social networks?

I see many guys on facebook they share also description photos and more details...

many thanks

Share this post


Link to post
Share on other sites
several days ago ive made Sexy Bookmarks but my client said that its to much they want something small and simple.

then i decide to made this AddThis block. well ive try to made ShareThis too but the problem is ShareThis need a unique-id (got it when registered) so i choose AddThis because it can be done with or without register as a member.

already comes with 12 layout button, 10 is the default button from AddThis. just select it from the menu (see snapshot for more detail). by default will come on extra left hook (below image on product page)


WARNING:
this module is a thankyouware so say thank you is a must and send some donation is a hope


many thanks.. what a great module... works very well in PS1.4...

Share this post


Link to post
Share on other sites
  • 2 months later...
  • 2 weeks later...
  • 2 weeks later...
  • 4 weeks later...
  • 2 weeks later...
  • 1 month later...
  • 3 weeks later...
  • 2 weeks later...
  • 1 month later...

Hello all,

By uninstalling the canonical URL module in backoffice - it fixes the double linking error that you experience on alot of social networking modules.

:)

Thanks to mod developer - excellent mod

 

 

Hello,

 

I have the same issue : i have to deactivate the canonical URL module : BUT i need it...!

Everybody has the canonical URL module activated? Avec the share social module works fine ?

Share this post


Link to post
Share on other sites
  • 1 month later...

First I want to say Thank you for this module that open social newyork for ours littes shops without any complicated code ;-)

 

Then, I test it on my test evitonment from weeks, the point is that sharing works fine but nothing appear in the Dashboard page on www.addthis.com. To be complete I musts say that have works One day at the beginning but since that day no more track Info appears on addthis Dashboard.

 

Is someone knows if There is some contraintd regarding URL rewriting of something else?

 

Best regards

www.calong.fr webmaster

Share this post


Link to post
Share on other sites
  • 2 weeks later...
  • 1 month later...
  • 6 months later...
  • 2 months later...
  • 3 weeks later...