Jump to content

Recommended Posts

Estou com problemas para habilitar SSL, fiz diversos procedimento e não funciona, a loja não esta vendendo via cartão por não estar habilitado o ssl, meu certificado é próprio. se algum puder me ajudar!

 

vou em:

PREFERÊNCIAS > GERAL

 

Habilitar SSL: está aparecendo o link "Por favor clique aqui para usar protocolo HTTPS antes de usar ativar o SSL", mas quando clico nesse link, fica na mesma página, não acontece nada

 

PREFERÊNCIAS > GERAL

não encontrei a opção "forçar SSL em todas as páginas"

 

Share this post


Link to post
Share on other sites

Se vc. nao encontrou a opcao, entao o seu certificado SSL nao está funcionando corretamente.

 

Vc. possue um certificado SSL próprio para o seu domínio ? Certificado SSL do servidor nao serve. O certificado deverá atender somente á um domínio e este domínio deverá possuir IP dedicado.

Share this post


Link to post
Share on other sites

a empresa na qual eu comprei o certificado afirma que o mesmo é próprio, já a uol em uma primeira conversa disse que não era proprio que era compartilhado, depois mudou o discurso dizendo que era proprio porem teria que ser feitas algumas manutenções pra voltar a funcionar em 24h, vejo que não funcionou, vou entrar em contato com UOL novamente

Share this post


Link to post
Share on other sites

Eu comprei um certificado SSL para o domínio de uma das lojas que administro, tudo direitinho, com IP dedicado e etc ... se bem que o IP dedicado não é uma exigência, pois existe a tecnologia SNI. Mas eu preferi fazer com IP dedicado e a configuração foi feita sem problemas.

 

Abs

Share this post


Link to post
Share on other sites

Boas pessoal.

 

Tenho um domínio a redireccionar para uma máquina virtual da azure (os:linux), o prestashop tem o rewrite_mode activo e a rescrever para o mesmo nome do domínio.

Quando vou testar o HTTPS ("Por favor clique aqui para usar protocolo HTTPS antes de usar ativar o SSL"),mas vai para outra página "não encontrada".

Estou a tentar perceber isto é algo do prestashop, ou dos serviços da azure. Tive suporte deles, inclusive informaram-me que era necessário abrir uma excepção de inbound (port:443) e mesmo assim não consigo resolver.

 

Alguma ideia? Sugestão?

Muito Obrigado.

Share this post


Link to post
Share on other sites

Boas pessoal.

 

jauridias. obrigado pela dica da alteração de PS_SSL_ENABLED  na bd. Alterei, houve mudanças no backoffice mas o problema continuava lá. Descobri que o problema estava no servidor, não tinha o ssl_mod activo e por isso "Por favor clique aqui para usar protocolo HTTPS antes de usar ativar o SSL" não funcionava.

 

Deixo aqui algumas dicas de como despistar e instalar SSL:

 

Verifiquem se a porta 443 está aberta. Podem usar a linha de comandos "netstat" ou pelo browser "http://www.yougetsignal.com/tools/open-ports/" ou outro.

Para instalar/activar ssl: "https://www.digitalocean.com/community/tutorials/how-to-create-a-ssl-certificate-on-apache-for-ubuntu-14-04"

No caso do certificado, segui este guia "https://www.namecheap.com/support/knowledgebase/article.aspx/9423/0/installing-a-ssl-certificate-on-apache".

Caso o SSL funcionar no back-office mas não no front, experimentem colocar isto no htaccess do site

<Directory /var/www/>            Options Indexes FollowSymLinks MultiViews            AllowOverride all            Order allow,deny            allow from all    </Directory>

Espero que ajude.

Edited by DanielCva (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Boas pessoal.

 

jauridias. obrigado pela dica da alteração de PS_SSL_ENABLED  na bd. Alterei, houve mudanças no backoffice mas o problema continuava lá. Descobri que o problema estava no servidor, não tinha o ssl_mod activo e por isso "Por favor clique aqui para usar protocolo HTTPS antes de usar ativar o SSL" não funcionava.

 

Deixo aqui algumas dicas de como despistar e instalar SSL:

 

Verifiquem se a porta 443 está aberta. Podem usar a linha de comandos "netstat" ou pelo browser "http://www.yougetsignal.com/tools/open-ports/" ou outro.

Para instalar/activar ssl: "https://www.digitalocean.com/community/tutorials/how-to-create-a-ssl-certificate-on-apache-for-ubuntu-14-04"

No caso do certificado, segui este guia "https://www.namecheap.com/support/knowledgebase/article.aspx/9423/0/installing-a-ssl-certificate-on-apache".

Caso o SSL funcionar no back-office mas não no front, experimentem colocar isto no htaccess do site

<Directory /var/www/>            Options Indexes FollowSymLinks MultiViews            AllowOverride all            Order allow,deny            allow from all    </Directory>

Espero que ajude.

Ola DanielCva

Aonde colocar o codigo no htaccess, devo apagar alguma linha, voce poderia postar o seu arquivo htacces para vermos como ficou.

porque ssl funciona no meu back-office.

Obrigado

Edited by jauridias (see edit history)

Share this post


Link to post
Share on other sites

Olá novamente.

 

jauridias.

Deixa-me corrigir, não foi no htaccess que adicionei aquele código, peço desculpa, foi no ficheiro "default-ssl.conf" do apache em /etc/apache2/sites-available/ e tive posteriormente reiniciar o serviço: sudo service apache2 restart.

 

Não sei qual é OS/serviço que tens, mas no meu caso é apache e em /etc/apache2/sites-available/ tinha só ficheiro: "000-default.conf, que me parece que é a configuração da porta 80. Se seguiste aqueles links que coloquei anteriormente deverás obter um novo ficheiro que terá uma configuração da porta 443.

 

Dentro desse novo ficheiro tenho <VirtualHost _default_:443>, e esse excerto de código coloquei dentro da tag, no fim, antes de fechar a tag, exemplo:

 

<IfModule mod_ssl.c>
    <VirtualHost _default_:443>

 

...

 

<Directory /var/www/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride all
            Order allow,deny
            allow from all
    </Directory>
    </VirtualHost>
</IfModule>

 

Estive a comparar com o outro ficheiro da porta 80, e reparei que este, da porta 80, tem

 

<Directory /var/www/html/>
        Options FollowSymlinks
        AllowOverride All
    </Directory>

 

Depois das alterações tive que reiniciar o apache.

Boa sorte.

Edited by DanielCva (see edit history)
  • Like 1

Share this post


Link to post
Share on other sites

Olá novamente.

 

jauridias.

Deixa-me corrigir, não foi no htaccess que adicionei aquele código, peço desculpa, foi no ficheiro "default-ssl.conf" do apache em /etc/apache2/sites-available/ e tive posteriormente reiniciar o serviço: sudo service apache2 restart.

 

Não sei qual é OS/serviço que tens, mas no meu caso é apache e em /etc/apache2/sites-available/ tinha só ficheiro: "000-default.conf, que me parece que é a configuração da porta 80. Se seguiste aqueles links que coloquei anteriormente deverás obter um novo ficheiro que terá uma configuração da porta 443.

 

Dentro desse novo ficheiro tenho <VirtualHost _default_:443>, e esse excerto de código coloquei dentro da tag, no fim, antes de fechar a tag, exemplo:

 

<IfModule mod_ssl.c>

    <VirtualHost _default_:443>

 

...

 

<Directory /var/www/>

            Options Indexes FollowSymLinks MultiViews

            AllowOverride all

            Order allow,deny

            allow from all

    </Directory>

    </VirtualHost>

</IfModule>

 

Estive a comparar com o outro ficheiro da porta 80, e reparei que este, da porta 80, tem

 

<Directory /var/www/html/>

        Options FollowSymlinks

        AllowOverride All

    </Directory>

 

Depois das alterações tive que reiniciar o apache.

Boa sorte.

Ta muito complicado para mim meu conhecimento é muito basico.

Voce faria um preço camarada para instalar no meu host?

Se sim, me manda um email que eu te retorno com todos os dados de acesso ao host e PrestaShop. jauridias@hotmail.com

desde de ja muito obrigado.

Share this post


Link to post
Share on other sites

Bom dia


 


 


 


adquiri certificado ssl para instalar em www.1000ideias.com. No entanto o site continua sem o cadeado de segurança do site.


 


O que preciso fazer para ativar https no meu site. Uso o prestashop Versão do PrestaShop 1.6.0.8


Ajudem-me


Obrigado


Edited by geral@1000ideias.com (see edit history)

Share this post


Link to post
Share on other sites

 

Bom dia

 

 

adquiri certificado ssl para instalar em www.1000ideias.com. No entanto o site continua sem o cadeado de segurança do site.

 

O que preciso fazer para ativar https no meu site. Uso o prestashop Versão do PrestaShop 1.6.0.8

Ajudem-me

Obrigado

 

Você já tentou alterar a configuração no BackOffice (Menu Preferências > Geral) ?

Lá deve aparecer: Habilitar SSL "SIM", ou pode aparecer o link: "Por favor clique aqui para usar protocolo HTTPS antes de usar ativar o SSL".
 
Após ativar nesta opção, recomendo também marcar a opção "Forçar SSL em todas as páginas".
 
Ao final, recomendo Acessar o menu Preferências > SEO e URLs, desativar e ativar novamente a opção "URL amigável". Isso faz gerar um novo arquivo .htaccess.
  • Like 1

Share this post


Link to post
Share on other sites

Obrigado daniel pelas dicas. Ficou a funcionar parcialmente. Em algumas paginas como na inicial e mais duas acho, aparece o cadeado verde, mas depois desaparece:

 

Exemplo: 

https://www.1000ideias.com/pt/

https://www.1000ideias.com/pt/content/2-legal-notice

https://www.1000ideias.com/pt/content/1-delivery

 

as outras todas aparece o cadeado a verde sempre.

O que pode estar a provocar isto?

 

Obrigado

Jorge

Share this post


Link to post
Share on other sites

Jorge

 

Se você abrir o inspetor do Chrome (F12) ou o complemento Firebug no Firefox, pode visualizar no console os erros de "mixed content"

 

 

Ex: 

Após corrigir essas chamadas erradas de arquivos, deve ficar com o cadeado verde.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More