Jump to content
amz83

passage d'en ligne a local ps_shop_url

Recommended Posts

Bonjour je dispose d'un site en prestashop 1.5.x (www.desineo.fr) 

 

j'aimerais le passer en local afin de pouvoir tests de nouveau templates sans risquer de faire crash le site.

 

Pour ce faire, j'ai; téléchargé tous les dossiers via filezilla, 

-copier dans wamp/www

-exporté ma base de donnée

-importer la base de donnée dans la nouvelle base crée sur phpmyadmin du localhost.

 

et la ce pose le probleme; on me dit de changer le nom de domaine et le chemin dans ps_shop_url mais lorsque je vais sur ma base, elle est vide. Comment faire?

 

ps: j'ai changer le setting.inc.php deja.

 

 

post-1235210-0-45353100-1460628564_thumb.png

Share this post


Link to post
Share on other sites

Bonjour

 

ps_shop_url   Vous n'avez pas cette table dans le colonne de gauche dans phpmyadmin ?

 

Vous avez combien de tables en tout ?

Share this post


Link to post
Share on other sites

Merci de votre réponse.

Si bien sur la table est crée (je vous joint un screen), seulement, elle est vide. je ne peux que changer la structure (comme le type le name etc...)

 

j'ai actuellement 250 tables

 

(pour l'exportation j'ai exporté la bdd en structure en zip ).

post-1235210-0-45808800-1460633924_thumb.png

Edited by amz83 (see edit history)

Share this post


Link to post
Share on other sites

Bon j me permet un petit up; le problème de ma bdd est réparé je n'avais pas pris les data donc je n'avais que les structures.

 

alors; j'ai remplacé dans sp_shop_url : domain: localhost domain_ssl : localhost : physical url: c:\wamp\www\presta

 

dans config\settings.inc.php : 

define('_DB_SERVER_', 'localhost');
define('_DB_NAME_', '_DBdesineofinalefinale_');
define('_DB_USER_', 'root');
define('_DB_PASSWD_', '');
 
mais lrsque je double clique sur presta dans mon localhost j'arrive sur une page : le dns presta n'a pas pu être chargé. pourquoi? 
 
je suis complétement bloqué et je ne trouve nul part ce problème sr les forums.

Share this post


Link to post
Share on other sites

physical url: c:\wamp\www\presta

 

Laissé cela vide.

Votre configuration est bien en localhost pas en 127.0.0.1 ?

 

Le chemin est c:\wamp\www\presta donc dans le navigateur vous devez tapez http://localhost/presta

et dans ps_shop_url /localhost/presta

Share this post


Link to post
Share on other sites

Rebonjour j'ai bien compris mes différentes erreurs, j'ai retiré le physical url et j'ai bien tapé http://localhost/presta et le probleme dns a disparu en revanche j'ai  à présent error 500 internal error.

 

Je pense que la c'est moi qui ai du faire un mauvais truc mais je ne sais pas quoi, de plus lorsque vous dites de mettre dans sp_shop_url c'est dans quelle partie? domain? domain_ssl? les deux?

 

merci beaucoup de bien vouloir m'aider

Share this post


Link to post
Share on other sites

des nouvelles, car je continue de chercher, j'ai vu sur le net que l'on devait supprimer le cache compil (sauf index.php) et smarty (tout) + suppr le fichier htacces.

 

je passe le 500 internal error. et j'arrive la dessus

 

 [Debug] This page has moved

Please use the following URL instead: http://localhostfr/erreur-404

 

j'ai jamais vu ça. 

Share this post


Link to post
Share on other sites

Bonjour

 

  http://localhostfr/erreur-404  << il fait quoi ce fr ? pas de fr http://localhost

Oui ça peut arriver un 500 internal error cela peut aussi être dû au .htaccess qui ne vous sert pas en local

donc vous pouvez désactivé l'url rewriting, vous ne perdez pas les url simplifié sauf qu'elles ne sont plus utilisé.

 

 

vous dites de mettre dans sp_shop_url c'est dans quelle partie? domain? domain_ssl? les deux?

 

vous n'utilisez pas le https en local donc que dans domain ça suffirait mais par principe on le met dans les deux, bon c'est aussi une habitude technique :)

Share this post


Link to post
Share on other sites
Guest

 

Bon j me permet un petit up; le problème de ma bdd est réparé je n'avais pas pris les data donc je n'avais que les structures.

 

alors; j'ai remplacé dans sp_shop_url : domain: localhost domain_ssl : localhost : physical url: c:\wamp\www\presta

 

dans config\settings.inc.php : 

define('_DB_SERVER_', 'localhost');
define('_DB_NAME_', '_DBdesineofinalefinale_');
define('_DB_USER_', 'root');
define('_DB_PASSWD_', '');
 
mais lrsque je double clique sur presta dans mon localhost j'arrive sur une page : le dns presta n'a pas pu être chargé. pourquoi? 
 
je suis complétement bloqué et je ne trouve nul part ce problème sr les forums.

 

Bonjour ,

Comment a tu fais pour recuperer les "data" ?

car j'ai exactement 250 tables comme toi

Merci

Share this post


Link to post
Share on other sites

Pour recupérer les data je me suis rendu sur mon phpmyadmin, j'ai cliqué sur ma bdd. Puis dans l'onglet export j'ai fais un quick export c'est tout.

Share this post


Link to post
Share on other sites

oui ça peux fonctionner même si je ne fais pas confiance a l'exportation de bdd de prestashop. Du coup après l'avoir importer vous avez toutes vos base? dans ps_shop_url vous avez quelques chose ? (domain // domain_ssl // physical_url etc) ?

Share this post


Link to post
Share on other sites
Guest

oui ça peux fonctionner même si je ne fais pas confiance a l'exportation de bdd de prestashop. Du coup après l'avoir importer vous avez toutes vos base? dans ps_shop_url vous avez quelques chose ? (domain // domain_ssl // physical_url etc) ?

Merci pour votre aide

 

J'ai bien corrigé mon probleme

Je suis bloqué, je travail sous linux avec xamp et co.

donc pr acceder a un site en local je dois taper 127.0.0.1/~dilan ou localhost/~dilan dans mon navigateur

dans la table ps_shop_url que dois je mettre dans les champs ?

 

Pour l'instant dans la BDD en local dans la table ps_shop_url j'ai

domaine                localhost

domaine_ssl          localhost

physical_uri           /~dilan/

 

Donc j'ai un message d'erreur 500

Merci de votre aide

Respectueusement

Edited by Guest (see edit history)

Share this post


Link to post
Share on other sites

Alors, j'ai eu le même problème. Deja j'ai supprimé le fichier htaccess et je suis rentré directement dans le back office puis je suis allé désactivé les url simplifié. voila sinon j'ai un post plus complet on m'avait abandonné sur celui la ^^

 

https://www.prestashop.com/forums/topic/521112-passage-du-ligne-au-local-prestashop-404notfound/?do=findComment&comment=2304340

Share this post


Link to post
Share on other sites

au faite les url simplifiés sont dans : Préférence > seo et urls.

Share this post


Link to post
Share on other sites

Bonjour,

 

Perso, j'ai fais la même manip que vous la semaine derniere, j'ai mis mon site en local sous Wamp34, j'ai renommé simplement les champs dans le fichier setting.php pour la connection à la base et dans le backOffiche j'ai changé le chemin vers localhost et tout à bien fonctionné !

Edited by shoppingnet (see edit history)

Share this post


Link to post
Share on other sites

oui mais parfois ça te redirige sur un 404 not found, en effet il faut modifier le fichier setting.inc.php que tu trouve dans config, avec le nom de ta bdd etc mais va sur le lien que je t'ai passé j'ai collé tous les fichiers utiles.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More