Jump to content

Recommended Posts

Bonjour,

 

Probleme Ecrire un commentaire (productcomments)

 

J'utilise un module qui s'appele "configurateur de produit par etape" et depuis je ne peux plus ecrire de commentaire.

 

Sur les pages ou il n'y a pas le module, lors d'un clic pour ajouter un commentaire, just l'url change (ajoute #new_comment_form) et rien ne se passe

www.thefreeglasses.com/accessories-for-glasses/612-leather-case-brown.html

 

et sur les pages avec le module configurateur, par exemple http://www.thefreeglasses.com/hot-trendy-eyeglasses/128-sofia-hot-trendy-black-oval-and-women-spectacles.html

 

on peux cliquer sur le lien ecrire un commentaire et celui ouvre une fenetre pour ecrire un commentaire mais apres on ne pas pas valider le com, le bouton submit ne marche pas.

 

J'aimerais payer quequ'un pour reparer ce probleme.

 

La version de prestashop est la derniere.

 

Merci d'avance

Share this post


Link to post
Share on other sites

Bonjour,

 

sur la page http://www.thefreeglasses.com/accessories-for-glasses/612-jeans-glasses-case.html#new_comment_form vous avez une erreur javascript avec le module configurateur http://www.thefreeglasses.com/modules/configurator/views/js/front.js.

 

Donc votre soucis semble totalement lié à ce module, le développeur de celui-ci devrait corriger votre soucis.

Share this post


Link to post
Share on other sites

J'ai effacer le module, et j'ai perdu des centaines de donnees...Et le probleme est toujours la.

 

http://www.thefreeglasses.com/kids-eyewear-and-blue-light-blocker-computer-glasses/106-addison-classic-pink-circular-and-kids-spectacles.html

 

 

 

J'ai installe firebug et j'arrive a voir une erreur

500 Internal Server Error
  1.64s
[PrestaShopDatabaseException]

Unknown column 'bdfb' in 'where clause'

SELECT p.*, pl.params, pl.id_lang
                FROM ps_appagebuilder p
                    LEFT JOIN ps_appagebuilder_shop ps ON (ps.id_appagebuilder = p.id_appagebuilder AND id_shop=1)
                    LEFT JOIN ps_appagebuilder_lang pl ON (pl.id_appagebuilder = p.id_appagebuilder)
                WHERE
                    pl.id_lang=1
                    AND ps.id_shop=1
                    AND p.id_appagebuilder_positions IN (39,bdfb,41,42)
                ORDER BY p.id_appagebuilder


at line 791 in file classes/db/Db.php

786. if ($webservice_call && $errno) {
787. $dbg = debug_backtrace();
788. WebserviceRequest::getInstance()->setError(500, '[SQL Error] '.$this->getMsgError().'. From '.(isset($dbg[3]['class']) ? $dbg[3]['class'] : '').'->'.$dbg[3]['function'].'() Query was : '.$sql, 97);
789. } elseif (_PS_DEBUG_SQL_ && $errno && !defined('PS_INSTALLATION_IN_PROGRESS')) {
790. if ($sql) {
791. throw new PrestaShopDatabaseException($this->getMsgError().'<br /><br /><pre>'.$sql.'</pre>');
792. }
793.
794. throw new PrestaShopDatabaseException($this->getMsgError());
795. }
796. }

DbCore->displayError - [line 425 - classes/db/Db.php] - [1 Arguments]
DbCore->query - [line 643 - classes/db/Db.php] - [1 Arguments]
DbCore->executeS - [line 280 - modules/appagebuilder/classes/ApPageBuilderModel.php] - [1 Arguments]
ApPageBuilderModel->getAllItems - [line 1371 - modules/appagebuilder/appagebuilder.php] - [3 Arguments]
APPageBuilder->hookdisplayHeader - [line 587 - classes/Hook.php] - [1 Arguments]
HookCore::coreCallHook - [line 542 - classes/Hook.php] - [3 Arguments]
HookCore::exec - [line 579 - classes/controller/FrontController.php] - [1 Arguments]
FrontControllerCore->initContent - [line 101 - classes/controller/ModuleFrontController.php]
ModuleFrontControllerCore->initContent - [line 44 - modules/productcomments/controllers/front/default.php]
ProductCommentsDefaultModuleFrontController->initContent - [line 189 - classes/controller/Controller.php]
ControllerCore->run - [line 367 - classes/Dispatcher.php]
DispatcherCore->dispatch - [line 28 - index.php]

J'ai vu lorsque j'efface ce fichier, lenvoi de commentaire fonctionne: /modules/appagebuilder/appagebuilder.php

 

Avez vous une idee?

Share this post


Link to post
Share on other sites

Bonjour,

 

Il semble que le soucis vient d'une autre élément que le configurateur.

Quelle était l'erreur que le configurateur vous envoyé au niveau JS ?

 

Nous nous efforçons de proposer une version fiable du module.

Si nous avons l'erreur, nous vous transmettrons le correctif.

Share this post


Link to post
Share on other sites

Les problemes ont commencé une fois que j'ai installé votre module Configurateur.

Share this post


Link to post
Share on other sites

Quand j'installe votre module, le module RELATED PRODUCTS est touché, cela m'affiche des grosses photos. en gros votre module touche a mon theme.

Et aussi le module productscomments ne fonctionne plus juste apres avoir installé votre module, ca ajoute dans l'url du produit: #new_comment_form et c'est tout, rien ne ce passe.

 

Erreur detecter avec google inspect:

 

Uncaught ReferenceError: CONFIGURATOR is not defined(anonymous function) @ front.js:614j @ jquery-1.11.0.min.js:2k.fireWith @ jquery-1.11.0.min.js:2n.extend.ready @ jquery-1.11.0.min.js:2K @ jquery-1.11.0.min.js:2

 

c'est vraiment du n'importe quoi, 200 dollar foutu en l'air, j'ai envoyé des messages au developpeur, mais il reponds jamais. Je suis vraiment enervé!

Share this post


Link to post
Share on other sites

Si j'efface /modules/configurator/views/js/front.js

le product reviews et related products refonctionnent normalement.

Share this post


Link to post
Share on other sites

Pouvez vous regardez 5 minutes les 2 pages suivantes:

http://www.thefreeglasses.com/hot-trendy-eyeglasses/128-sofia-hot-trendy-black-oval-and-women-spectacles.html
Module configurateur installe et configure pour ce produit, RELATED PRODUCT et COMMENTAIRE OK

et

http://www.thefreeglasses.com/hot-trendy-eyeglasses/11-eyeglasses-jordan.html
module configurateur installe et NON configure pour ce produit, PROBLEME RELATED PRODUCT et COMMENTAIRE.

Share this post


Link to post
Share on other sites

Bonjour,

 

Je vous ai répondu sur le flux de support.

 

Nous vous avons mis la dernière version du module. Il permet notamment de personnaliser le configurateur de produit avec la personnalisation visuelle en fonction de l'étape ou vous vous trouvez superposant les calques.

 

Egalement, il vous permet de créer des formules de calculs que vous définissez pour chaque étape avec la possibilité de choisir des valeurs provenant d'étapes précédentes. 

 

Nous vous invitons donc à installer cette nouvelle version qui corrige le premier point tout en vous ajoutant d'autres fonctionnalités intéressantes.  :)

Share this post


Link to post
Share on other sites

BO/Page produit/Configurateur de produits/ le configurateur est desactivé, mais sur la page produit, il est toujours activé.
Non ce n'est pas un probleme de cache.
 

Share this post


Link to post
Share on other sites

impossible de creer une 2eme etape, ca me donne l'erreur: The object cannot be loaded (the identifier is missing or invalid) ,
J'ai juste rempli Private name, Public name, Options group.

Edited by grossiste (see edit history)

Share this post


Link to post
Share on other sites

J'ai désintallé votre module, et tous mes produits que j'avait ajouté des étapes ne sont maintenant plus disponible a la commande, Options Available for order decoché

Share this post


Link to post
Share on other sites

Bonjour,

 

Je vous communique le correctif par message privé.

 

Aujourd'hui? J'aimerais bien que ca marche, je veux juste creer 2 ou 3 etapes, simple, rien de compliqué

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More