Jump to content
deandreway

[Résolu] Statut commande- "Erreur HTTP 503"- Pas de mail client après changement de statut

Recommended Posts

Bonjour à tous,

 

Suite à une première commande "test" sur mon site j'ai reçu un mail d'erreur de la part de PayPlug qui est le suivant : La transmission vers votre serveur de la notification de transaction #2436785 (IPN) a échoué.

votre serveur a renvoyé l'erreur suivante : "HTTP 503" 

 

À ce moment la, le statut de la commande du client n'a pas changer et dans le Backoffice il est sensé passé du statut "paiement en cours" à "Paiement accepté"

Mon second problème c'est que je doit changer moi même le statut de la commande, le client lui il ne reçois pas de mail à propos du changement de statut de ça commande, je click sur "Renvoyer l'email au client" pour lui faire savoir... et la un autre message d'erreur s'affiche dans mon Backoffice : Une erreur est survenue lors de l'envoi de l'email au client.

 

AVEZ VOUS DÉJA EU AFFAIRE A CE PROBLÈME??? 
- JE VOUS DiT MERCI PAR AVANCE A CEUX QUI POURRONT M'AIDER A RÉSOUDRE CE PROBLÈME!

 

Edited by adame971@hotmail.com (see edit history)

Share this post


Link to post
Share on other sites

On ne peut pas faire de test de paiement depuis des plateforme externe (payplus, atos, systempay, ...) en étant en mode maintenance.

Créer un client front office,

Créer un groupe nommé test

Ajouter le client dans ce groupe

N'activer le module de paiement à tester que pour le groupe test

Activer la boutique

Faire les tests de paiement avec le client créé

Quand tout est conforme activer le module de paiement pour tout les groupes

Share this post


Link to post
Share on other sites

Le problème d'envoi de mail est différent, vérifie ta config mail. Ce n'est pas spécifique à un module c'est tout ton PrestaShop qui ne peut pas envoyer de mail

Share this post


Link to post
Share on other sites

merci pour ta réponse, j'ai tenté plusieurs configuration de mon adresse mail et rien a faire... lorsque je click sur envoyer un email test il y a un message d'erreur qui s'affiche pour tant j'utilise les bonnes info

 

 

 

Serveur SMTP: smtp.live.com

Utilisateur SMTP: monadressemail@hotmail.com

Mot de passe SMTP: le mot de passe de mon adresse mail

Chiffrement: ssl

Port: 25

Share this post


Link to post
Share on other sites

Tu es sûr et certain que smtp.live.com est ton serveur sortant?

le port 25 est très souvent filtré, tente le 587, sinon revoir la fiche de configuration avec live.com. Le problème n'est pas coté PrestaShop en substance

Share this post


Link to post
Share on other sites

lorsque j'active:

Ne jamais envoyer d'e-mails (utile en phase de test)

 

et que j'envoie un mail test je le reçois sans problème peu importe l'adresse mail... 

par contre une fois que j'active:

 

Utiliser mes propres paramètres SMTP (pour les experts uniquement)

 

je ne reçois plus rien a part un message d'erreur : Erreur : veuillez vérifier votre configuration

The SMTP connection failed to start [smtp.live.com:25]: fsockopen returned Error Number 110 and Error String 'Connection timed out'
 
 

Share this post


Link to post
Share on other sites

Le message est pourtant très clair, smtp.live.com ne veux pas te répondre et je ne comprends pas pourquoi quand je te propose de passer par le port 587 tu t'obstines avec le port 25.

Share this post


Link to post
Share on other sites

avec le port 587 :Erreur : veuillez vérifier votre configuration

Expected response code(s) [250] but got response [530 5.7.0 Must issue a STARTTLS command first]

Share this post


Link to post
Share on other sites

Donc cette fois le serveur te répond, mais il requiert STARTTLS et ce n'est pas supporté dans PrestaShop.

Tu vas devoir trouver un autre canal pour les envois de mail. Il est où ton serveur? Ton hébergeur ne propose pas l'envoi de mail?

Share this post


Link to post
Share on other sites

je ne suis pas très fort en informatique, mes questions vont surement paraitre bête mais je suis chez outlook, il faudrait peut etre que je change d'adresse mail pour faire un teste et voir si ca donne quelque non ? Gmail par exemple...

Edited by adame971@hotmail.com (see edit history)

Share this post


Link to post
Share on other sites

Non tu n'es pas chez outlook pour ton PrestaShop. Quel est ton hébergeur?

Share this post


Link to post
Share on other sites

Donc prend l'option d'envoi recommandé au lieu de l'option expert avec SMTP et ça va marcher nickel

 

Utiliser la fonction mail() de PHP (recommandé ; fonctionne dans la majorité des cas)

Edited by doekia (see edit history)

Share this post


Link to post
Share on other sites

je n'est pas l'option recommander dans mon Backoffice 

 

jai deux autres option:  

utiliser mes propres paramètres smtp (pour les experts uniquement)

et 

ne jamais envoyer d'email (utile en phase de test)

Share this post


Link to post
Share on other sites

est t'il possible de rajouter la fonction mail() de PHP (recommandé ; fonctionne dans la majorité des cas)

Share this post


Link to post
Share on other sites

Heu... le seul endroit où ça n'existe pas c'est sur le Cloud! Si c'est sur le Cloud alors poster dans la section Cloud

Share this post


Link to post
Share on other sites

et sur le cloud c'est smtp.relaymailin...

Share this post


Link to post
Share on other sites

Bonjour,

 

J'imagine que tu es en mutualisé ?

Pourquoi tu ne prends pas une adresse mail avec ton domaine lié ?

 

Sinon, pour information, on ne peut pas se servir de hotmail comme prestataire de smtp. Cela est possible avec gmail par exemple.

Ou alors, le smtp local...

Edited by Arnaud_69 (see edit history)

Share this post


Link to post
Share on other sites

Merci pour vos réponse , en effet je suis suis sur le cloud problème toujours pas résolut, j'utilise rarement le forum du cou p j'ai du posté au mauvais endroit! comment faire pour déplacer le sujet ? 

Share this post


Link to post
Share on other sites

Problème Résolu ! 

 

j'ai télécharger le module sendinblue, je me suis créé un compte sendinblue, puis j'ai utiliser les information fournis par sendinblue pour synchroniser mon site avec mon compte sendinblue j'ai ensuite entré les informations smtp et voili! voilou! tout fonctionne nickel.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More