Jump to content
mike.kessels

Melding "no Payment Module Installed" Bij Afronden Aankoop

Recommended Posts

Na een upgrade naar PS 1.6.1.3 is er plots iets misgelopen met de Hipay payment module en krijgen klanten die willen betalen de melding "No payment module installed" te zien. De bestelling kan niet worden afgerond.

 

De dev van de payment provider Hipay heeft naar de oorzaak gezocht en meldt:

There is a problem in the instalation of Prestashop, it seems that the HOOK_PAYMENT doesn't work and it is mandatory to display payment methods.

Please see this log :

[error] [pid 2635] mod_proxy_fcgi.c(745): [client 46.182.41.35:46314] AH01071: Got error 'PHP message: PHP Notice: Undefined index: weight_attribute in /data/sites/web/doccadocom/www/classes/Carrier.php on line 1389\nPHP message: PHP Notice: Undefined index: weight_attribute in /data/sites/web/doccadocom/www/classes/Carrier.php on line 1389\nPHP message: PHP Notice: Undefined index: weight_attribute in /data/sites/web/doccadocom/www/classes/Carrier.php on line 1389\nPHP message: PHP Notice: Undefined index: HOOK_PAYMENT in /data/sites/web/doccadocom/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 122\nPHP message: PHP Notice: Trying to get property of non-object in /data/sites/web/doccadocom/www/tools/smarty/sysplugins/smarty_internal_templatebase.php(157) : eval()'d code on line 122\n'

 

Kan iemand helpen?

Cheers,

Mike
 

Share this post


Link to post
Share on other sites

Moeilijk te zeggen zo. Een paar suggesties:

 

 - zorg dat je de laatste versie van HiPay gebruikt.

 

 - uninstall en dan reinstall de module

 

 - maak een testinstallatie van een nieuwe PS 1.6.1.3 met jouw theme en de HiPay module en kijk of die daar wel werkt

 

welke php versie gebruik je?

Share this post


Link to post
Share on other sites

Moeilijk te zeggen zo. Een paar suggesties:


 


 - zorg dat je de laatste versie van HiPay gebruikt.


 


 - uninstall en dan reinstall de module


 


 - maak een testinstallatie van een nieuwe PS 1.6.1.3 met jouw theme en de HiPay module en kijk of die daar wel werkt


 


welke php versie gebruik je?


 


Bedankt Musicmaster.


Ik heb al het bovenstaande geprobeerd. Ook Hipay support heeft dit geprobeerd en het werkt prima op een test versie van PS.


Ik wil echter vermijden om de hele shop over te zetten op een nieuwe versie van PS.


Dit issue loopt ondertussen al enkel weken. Ik heb een PS support pakket gekocht ondertussen. Kijken of zij er wat aan kunnen doen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More