Jump to content
Walde

Aktivierung der Overrides -> Module "Paypal" und "Sofortüberweisung" sind nicht mehr funktional

Recommended Posts

Hallo Walde,

 

versuche einmal die Module "PayPal" und "Sofortüberweisung" zu reseten und anschließend neu einzurichten.

 

Gruß

Holger

Share this post


Link to post
Share on other sites

Hallo zusammen,

ich habe mit den Zahlungs-Modulen "PayPal" und "Sofortüberweisung" folgendes Problem. Sobald ich die Overrides aktiviere, bricht der Bezahlvorgang, nach der Bestätigung der Zahlung z.B. bei PayPal, mit dem Fehler 500 ab. Im Prestashop bleibt die Bestellung als „verwaister Warenkorb“ stehen und wird nicht abgeschlossen. PayPal hat die Zahlung des Kunden jedoch verbucht.

Ich habe noch nicht sehr viel Erfahrung mit Prestashop und bin etwas verzweifelt. Die Overrides brauche ich für zwei andere Module.

1. EU Cookie Gesetz (Benachrichtigungs Banner + Blocker) Module

2. Advanced Pack - Make Packs from products Module

Prestashop 1.6.1.4

Den Cache habe ich bereits mehrfach gelöscht und das Template (auch das Standard) kompiliertAn dem verwendeten Template kann es eigentlich auch nicht liegen, da ich dasselbe Problem auch mit dem Standard-Template von Prestashop habe.

Hat Jemand eine Idee und könnte mich unterstützen?
URL: http://www.tripleaction.de/

 

Share this post


Link to post
Share on other sites

Da das Paypal-Modul selbst keine Overrides hat (ich vermute mal, das ist bei Sofortüberweisung auch nicht anders), dürften die Probleme durch unsauber programmierte Kauf-Module entstehen. Das ist bei PrestaShop Addons mangels wirksamer Qualitätskontrolle leider häufig anzutreffen.

 

Natürlich hat auch das Paypal-Modul immer mal wieder seine Macken. Das wird seit Jahren beklagt. Manchmal hilft es, eine ältere Version einzusetzen. Das wiederum könnte Probleme bereiten, wenn man immer gleich die neueste PrestaShop-Version nutzt. Denn 1.6.1.4 ist alles andere als bugfrei, da immer noch daran gebastelt wird. Deswegen wird denächst erst mal 1.6.1.5 rauskommen. Mal sehen, was die Zukunft bringt. ;)

 

Am einfachsten ist dein Problem beim EU-Cookie-Modul zu lösen. Da Deutschland diese EU-Richtlinie gar nicht umgesetzt hat, ist es eigentlich überflüssig.

Das andere Modul dagegen greift offenbar in den Warenkorb ein, und da liegt wohl der Hund begraben. Ansprechpartner dürfte hier auf jeden Fall der russische Entwickler sein, denn Paypal gehört zum Standard von PrestaShop. Er muss also nachbessern. Hoffentlich tut er das auch.

  • Like 1

Share this post


Link to post
Share on other sites

Ja natürlich sind die Overrides dann trotzdem noch vorhanden! Daran ändert auch die Deaktivierung nichts.

Und wenn du Pech hast, deinstalliert das Modul bei der Entfernung noch nicht mal die Overrides sauber. Sicherheitshalber schau mal in die Modul-Zip. Alles, was sich  dort im Ordner overrides befindet, muss bei Deinstallation auch aus dem gleichnamigen Ordner von PrestaShop wieder verschwunden sein.

 

So richtig Freude kommt dann auf, wenn es bereits gleichnamige Overrides anderer Module gab, die vielleicht andere Funktionen überschrieben haben, und dann so ein Modul dann bei Deinstallation der Einfachheit halber gleich die komplette Datei entfernt.

Edited by eleazar  (see edit history)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Cookies ensure the smooth running of our services. Using these, you accept the use of cookies. Learn More